Results 1 to 4 of 4

Thread: Using Mono

  1. #1

    Default Using Mono

    I need to copy over my friend's asp website. I just installed the mono module...But I have no idea how to use it. I found a website that directed me to do the following within httpd.conf:


    LoadModule mono_module modules/libmod_mono.so
    Alias /aspnet "/usr/share/doc/xsp/test"
    MonoApplications "/aspnet:/usr/share/doc/xsp/test"
    <Directory /usr/share/doc/xsp/test>
    SetHandler mono
    </Directory>


    sadly that did not work. When I restarted apache it errored out with:

    [warn] module mono_module is already loaded, skipping


    [crit] (13) Permission denied: Failed to attach to existing dashboard, and removing dashboard file '/tmp/mod_mono_dashboard_XXGLOBAL_1' failed )Operation not permitted). Further action impossible.



    ------------------


    any ideas?

  2. #2
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Using Mono

    Are you running Apache and mod_mono as root?

  3. #3

    Default Re: Using Mono

    Not sure. How would I be able to tell?

  4. #4
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Using Mono

    Use

    Code:
    ps -Af | grep apache
    ps -Af | grep mono
    to find the users of Apache and mono. They should be the same user. Check the owner and permissions of the mono dashboard file too,

    Code:
    cd /tmp
    ls -l

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •