Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: No sound in openSuSE 11.2 (Optiplex 380)

  1. #1

    Default No sound in openSuSE 11.2 (Optiplex 380)

    Hello everyone

    I have a problem with my new openSuSE installation regarding the sound and I would like to mention that I not an expert in using linux and I'm a rookie with this distribution.

    Environment:
    - Dell Optiplex 380
    - openSuSE 11.2 i586
    - KDE graphical environment

    current lspci -v result:

    00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
    Subsystem: Dell Device 0400
    Flags: fast devsel, IRQ 16
    Memory at fe6fc000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [50] Power Management version 2
    Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
    Capabilities: [100] Virtual Channel <?>
    Capabilities: [130] Root Complex Link <?>


    Symptoms:
    - No sound at all
    - tried to play the test sound from YaST but with no success
    - tried to play the sound usind the terminal command

    Steps made to solve the problem:

    - visited this thread: 11.2 sound - openSUSE Forums and tried all that applied to me but nothing worked

    - visited SDB:AudioTroubleshooting - openSUSE and made the steps 1 and 2. I have to mention that in a moment of absence of mind I have executed the command alsaconf.
    Before trying this to steps, lspci -v had one more line specifying the kernel module used and it was something like:

    Kernel driver in use: HDA Intel

    I can't do the step 3 because I don't have the path /proc/asound.

    Any suggestion it will be welcome.

    Thank you for your help in advance.

    Best regards,
    Florin

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,566
    Blog Entries
    38

    Default Re: No sound in openSuSE 11.2 (Optiplex 380)

    Quote Originally Posted by sviatovigt View Post
    - visited SDB:AudioTroubleshooting - openSUSE and made the steps 1 and 2. I have to mention that in a moment of absence of mind I have executed the command alsaconf.
    alsaconf may create an /etc/modprobe.d/sound file which is useless in 11.2 as 11.2 uses an /etc/modprobe.d/50-sound.conf file. So you could look under /etc/modprobe.d/ and if you see a "sound" file, then delete it.

    Reference step-1 in the troubleshooting guide, did you try ALL THREE tests for sound?
    SDB:AudioTroubleshooting - openSUSE

    ie. the two speaker-tests and the one aplay test?

    Quote Originally Posted by sviatovigt View Post
    I can't do the step 3 because I don't have the path /proc/asound.
    Well, then just skip step 3 and go on to 4.

    But if you find that guide too hard to follow, instead provide detailed information here on our forum, providing information recommended to be provided as detailed in the second half of our multimedia stickie:
    ... please post in this ... sub-forum, providing in your post the following information:
    • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
      SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script /usr/sbin/alsa-info.sh and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL. Just the URL. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
    • in a terminal, or xterm, or konsole, type: rpm -qa '*alsa*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -qa '*pulse*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
    • in a terminal, or xterm, or konsole, type: uname -a #and post output here
    • ...
    • for openSUSE-11.2 or later, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here
    When running the diagnostic script, be certain your PC is connected to the Intenet and also select the UPLOAD/SHARE option.

  3. #3

    Default Re: No sound in openSuSE 11.2 (Optiplex 380)

    Thank you for your quick answer

    Here are the information requested:

    > after running

    /usr/sbin/alsa-info.sh

    I obtained this link: http://www.alsa-project.org/db/?f=15...ae56280fce6a93

    > after running

    rpm -qa '*alsa*'

    I have obtained the following result:

    alsa-1.0.21-3.2.i586
    alsa-plugins-1.0.21-3.3.i586
    alsa-devel-1.0.21-3.2.i586
    alsa-utils-1.0.21-3.1.i586
    alsa-oss-1.0.17-25.2.i586
    alsa-firmware-1.0.20-3.2.noarch


    > after running

    rpm -qa '*pulse*'

    I have obtained the following result:

    libpulse-browse0-0.9.19-2.3.i586
    libxine1-pulse-1.1.16.1-7.6.i586
    libpulse-devel-0.9.19-2.3.i586
    libpulse-mainloop-glib0-0.9.19-2.3.i586
    libpulse0-0.9.19-2.3.i586


    > after running

    rpm -q libasound2

    I have obtained the following result:

    libasound2-1.0.21-3.2.i586

    > after running

    uname -a

    I have obtained the following result:

    Linux romflt-linux 2.6.31.5-0.1-desktop #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 i686 i686 i386 GNU/Linux

    > after running

    cat /etc/modprobe.d/50-sound.conf

    I have obtained the following result:

    options snd slots=snd-hda-intel
    # u1Nb.5JnQy4kmGO9:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel


    I would also like to mention that when I ran the command /usr/sbin/alsa-info.sh, I had the following errors:

    cat: /proc/asound/version: No such file or directory
    grep: /proc/asound/cards: No such file or directory
    cat: /proc/asound/cards: No such file or directory
    cat: /proc/asound/modules: No such file or directory
    ls: cannot access /dev/snd/*: No such file or directory
    grep: /proc/asound/cards: No such file or directory
    /usr/sbin/alsactl: save_state:1502: No soundcards found...
    cat: /tmp/alsa-info.cbcteVgZ1Y/alsactl.tmp: No such file or directory


    Thank you

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,566
    Blog Entries
    38

    Default Re: No sound in openSuSE 11.2 (Optiplex 380)

    Quote Originally Posted by sviatovigt View Post
    Here are the information requested:

    > after running

    /usr/sbin/alsa-info.sh

    I obtained this link: http://www.alsa-project.org/db/?f=15...ae56280fce6a93
    OK, thanks. I note the 2.6.31.5 kernel (not updated) on a 32-bit openSUSE-11.2 install. Clearly the ALC269Q hardware audio codec on your Dell OptiPlex 380 is not working with alsa.

    Do you have the sound switched ON in the BIOS ? Can you boot to the BIOS and check ?

    Can you type as a regular user:
    Code:
    dmesg > dmesg.txt
    and open dmesg.txt with a text editor and copy and paste its contents to PasteBin.be and press "dump" on that site, which will give you a URL indicating where the contents of your paste are posted. Please post here that URL. Just the URL.

    I did a search on an ALC269Q on the alsa site and found nothing, but I did find entries for the ALC269: Search results - AlsaProject

    Assuming sound is switched ON in the BIOS, I suspect you may need to udate the alsa driver, and possibly even the kernel.

    Guidance for updating alsa driver is here: Alsa-update - openSUSE Note the version of alsa-driver-kmp-desktop you install is dependant on the kernel version you have in place. Also note that when updating alsa, alsa-plugins, alsa-devel, alsa-utils, alsa-oss, alsa-firmware and libasound2 you MUST be careful to ensure they are updated and you are not fooled into thinking they are updated when they are not. I put a couple of images on the "alsa-update wiki" to try help new users avoid making that mistake, as sooooooo many make that mistake. After updating alsa one MUST reboot.

  5. #5

    Default Re: No sound in openSuSE 11.2 (Optiplex 380)

    Waiting for a response I had reinstalled openSuSE. Here are the new informations:

    > after running lspci -v:

    00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
    Subsystem: Dell Device 0400
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at fe6fc000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [50] Power Management version 2
    Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
    Capabilities: [100] Virtual Channel <?>
    Capabilities: [130] Root Complex Link <?>
    Kernel driver in use: HDA Intel


    > after installing alsa-firmware I had ran /usr/sbin/alsa-info.sh; the link for the result is: http://www.alsa-project.org/db/?f=a3...180d47fe3d8cb;

    > result for rpm -qa '*alsa*':

    alsa-1.0.21-3.2.i586
    alsa-plugins-1.0.21-3.3.i586
    alsa-utils-1.0.21-3.1.i586
    alsa-firmware-1.0.20-3.2.noarch
    alsa-oss-1.0.17-25.2.i586

    > result for rpm -qa '*pulse*':

    libpulse-mainloop-glib0-0.9.19-2.3.i586
    libpulse0-0.9.19-2.3.i586
    libxine1-pulse-1.1.16.1-7.6.i586


    > result for rpm -q libasound2:

    libasound2-1.0.21-3.2.i586


    > result for uname -a:

    Linux linux-pme8 2.6.31.5-0.1-desktop #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 i686 i686 i386 GNU/Linux

    > result for cat /etc/modprobe.d/50-sound.conf:

    options snd slots=snd-hda-intel
    # u1Nb.5JnQy4kmGO9:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel


    I am waiting for new instructions. Should I follow the steps for upgrading alsa and the kernel?

    Thank you

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,566
    Blog Entries
    38

    Default Re: No sound in openSuSE 11.2 (Optiplex 380)

    Quote Originally Posted by sviatovigt View Post
    Waiting for a response I had reinstalled openSuSE. Here are the new informations:

    > after installing alsa-firmware I had ran /usr/sbin/alsa-info.sh; the link for the result is: http://www.alsa-project.org/db/?f=a3...180d47fe3d8cb;
    This time the script output is different. SIGNIFICANTLY different. That is suprising to me. Clearly something was wrong with your first install.

    This second install is better.

    I note this:


    Card hw:0 'Intel'/'HDA Intel at 0xfe6fc000 irq 16'
    Mixer name : 'Realtek ALC269'Simple mixer control 'Master',0
    Mono: Playback 71 [82%] [-12.00dB] [on]
    Simple mixer control 'Speaker',0
    Front Left: Playback 87 [100%] [0.00dB] [on]
    Front Right: Playback 87 [100%] [0.00dB] [on]
    Simple mixer control 'PCM',0
    Front Left: Playback 0 [0%] [-51.00dB]
    Front Right: Playback 0 [0%] [-51.00dB]

    Your PCM at 0% is muting your sound. Turn that up to 100% and run the 3 speaker tests that are in the troubleshooting guide.


    Quote Originally Posted by sviatovigt View Post
    I am waiting for new instructions. Should I follow the steps for upgrading alsa and the kernel?
    Note I am a volunteer. I have a regular job. Sometimes it can take me a day or two to respond. So if you keep changing things while waiting for a reply, then you invalidate my reply.

    Anyway, see if you can get sound by increasing PCM to 100%. If that does NOT work, then try updating alsa. ONLY update alsa if you have no other choice.

  7. #7

    Default Re: No sound in openSuSE 11.2 (Optiplex 380)

    Yes, I know that, and that's why appreciate more your help. Thank you. Unfortunately, I was forced to reinstall the OS, I didn't do it because I thought it will solve my problem.
    Indeed, you were right, PCM volume was 0, but even if I change it to 100% I still have no sound.
    I re-ran /usr/sbin/alsa-info.sh and I have to tell you that I have the same value for PCM.
    I will try to upgrade alsa and I will let you know if it works.

    Thank you again.

    PS: I want you to know that I will appreciate the same your answer even if it will come after two days since my last reply.

    Best regards.

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,566
    Blog Entries
    38

    Default Re: No sound in openSuSE 11.2 (Optiplex 380)

    Quote Originally Posted by sviatovigt View Post
    Indeed, you were right, PCM volume was 0, but even if I change it to 100% I still have no sound.
    OK, ... when testing your sound, be certain to try EACH of those speaker tests (and the aplay test). Try as both a regular user and in a terminal with root permissions. If you can plug in a headset and try with that, then that would be good also.
    Quote Originally Posted by sviatovigt View Post
    I re-ran /usr/sbin/alsa-info.sh and I have to tell you that I have the same value for PCM.
    You need to move that PM up to 100% and have it shown as being up.
    Quote Originally Posted by sviatovigt View Post
    I will try to upgrade alsa and I will let you know if it works.
    OK, good luck. Don't forget what I noted about being certain you update and don't be fooled into thinking you have updated when you have not.

  9. #9

    Default Re: No sound in openSuSE 11.2 (Optiplex 380)

    ok. I have updated the drivers but the sound still doesn't work.

    I have to admit that I don't know if I understood clearly what you wanted to say by

    Don't forget what I noted about being certain you update and don't be fooled into thinking you have updated when you have not.
    If you (oldcpu) or anybody else wants me to provide additional information just ask me to.

    Thank you.

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,566
    Blog Entries
    38

    Default Re: No sound in openSuSE 11.2 (Optiplex 380)

    Quote Originally Posted by sviatovigt View Post
    ok. I have updated the drivers but the sound still doesn't work.

    I have to admit that I don't know if I understood clearly what you wanted to say by



    If you (oldcpu) or anybody else wants me to provide additional information just ask me to.

    Thank you.
    Yes, more information please.

    Please provide output of:
    Code:
    rpm -qa '*alsa*'
    rpm -qa '*pulse*'
    rpm -q libasound2
    rpm -qa '*kernel*'
    uname -a
    cat /etc/modprobe.d/50-sound.conf
    and again run the diagnotic script
    Code:
    /usr/sbin/alsa-info.sh
    and select the UPLOAD/SHARE option and then post here the URL it provides. Just the URL.

    Please also confirm you have sound working in another operating system.

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •