Results 1 to 10 of 10

Thread: Swiftfox - installed but won't open

  1. #1
    Join Date
    Jun 2008
    Location
    Oregon
    Posts
    455

    Default Swiftfox - installed but won't open

    I installed Swiftfox, but it won't open.

    It has an icon, and it bounces then disappears. what else is needed to make it run?

  2. #2

    Default Re: Swiftfox - installed but won't open

    As always, start $APPLICATION from terminal and read (error) messages.

  3. #3
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Swiftfox - installed but won't open

    Do you use Swiftfox on openSUSE? Any special reason for not using the original Firefox instead?

    Try running Swiftfox via console and post the output here, that should give us some more informations.

  4. #4
    Join Date
    Jun 2008
    Location
    Oregon
    Posts
    455

    Default Re: Swiftfox - installed but won't open

    davek@linux-kw2x:~> swiftfox
    /opt/swiftfox/swiftfox-bin: error while loading shared libraries: libdbus-glib-1.so.2: cannot open shared object file: No such file or directory
    davek@linux-kw2x:~>


    I've used it in mandriva and swiftfox runs much faster.

  5. #5
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Swiftfox - installed but won't open

    Swiftfox is searching for a 'shared file' from 'dbus-1-glib', I suppose that is already installed on your system?

    Your .rpm most likely is not build for openSUSE, so you will hardly make it work, I guess.

  6. #6

    Default Re: Swiftfox - installed but won't open

    Let me guess, you have a 64 Bit installation and the "optimized Firefox for linux" (aka swiftfox) is a 32 bit binary.

    Great "optimization" guys, even when explicitely choosing the AMD64 build one gets this here:

    Code:
    /tmp> tar xf swiftfox-3.6.0-athlon64.tar.bz2 
    /tmp> file swiftfox/swiftfox-bin 
    swiftfox/swiftfox-bin: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.8, dynamically linked (uses shared libs), stripped
    You will need the respective "Multilibs" in 32 bit version to run a 32 bit binary on a 64 bit installation, I am pretty sure this library will exist on your system, but only as 64 bit, search for the file, run "rpm -qf /path/to/file/file" to find out which package it belongs to and install the corresponding "<package>-32bit".

  7. #7

    Default Re: Swiftfox - installed but won't open

    Quote Originally Posted by gropiuskalle View Post
    Your .rpm most likely is not build for openSUSE, so you will hardly make it work, I guess.
    That rpm is not even an rpm but some "Installer" which can only be run as root as maybe the swiftfox-developers think $USER is too dumb to simply unpack a tarball and make a symlink himself (therefore being able to install it i.e. in his own $HOME).

    However, trying to get plugins running with that thing on 64 Bit will be even more "fun".

    I would leave my hands off this "optimized build", how much "optimization" can you expect if there isn't even a build for 64 Bit architecture?

  8. #8
    Join Date
    Jun 2008
    Location
    Oregon
    Posts
    455

    Default Re: Swiftfox - installed but won't open

    ...so its a 64 bit problem... my Mandriva PC is 32 bit. that's why it works.

    if you don't run more than 3gb RAM I still don't see the advantage to a 64 bit system. it always causes problems like this.

    I'll stick with Firefox.

  9. #9

    Default Re: Swiftfox - installed but won't open

    Quote Originally Posted by vinoman2 View Post
    it always causes problems like this.
    Oh, really?

    Code:
    ./swiftfox/swiftfox
    Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkTreeView::odd-row-color' of type `GdkColor' from rc file value "((GString*) 0xf2320280)" of type `GString'
    Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkTreeView::odd-row-color' of type `GdkColor' from rc file value "((GString*) 0xf21b9480)" of type `GString'
    [03-23 12:15:27] Torbutton NOTE: Restoring tor state
    Works for me™ on x86_64.

    How to get the respective 32bit-packages is described above.

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: Swiftfox - installed but won't open

    Just look for the package name in Yast-Software Management
    You will see the package plus one that has 32 in the name. Make sure both are installed. Note that this is a special 32 bit for 64 bit OS version and may not be the same as one puled from the 32 bit OS repos.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •