Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Not able to install rpm

  1. #1

    Post Not able to install rpm

    Hi, I am quite new to openSUSE. I tried installing flash player by downloading rpm from adobe web site. When I double click on the flash player rpm, it stops by giving an error

    "[PK_TMP_DIR|dir:///var/tmp/TmpDir.zCQnV0] Repository already exists."

    Please anyone help me to fix this problem.

    Thank You

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Not able to install rpm

    Open a terminal and become su -
    Do the following

    Code:
    zypper in flash-player
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,004

    Default Re: Not able to install rpm

    Hi,

    Welcome to the forums. While the advice above is technicaly correct, you might want to know more about why your way of installing was not the best one.

    We have some information for new openSUSE users:
    NEW Users - openSuse Pre-install (general) PLEASE READ - openSUSE Forums
    NEW Users - Suse-11.2 Pre-installation PLEASE READ - openSUSE Forums
    Multi-media and Restricted Format Installation Guide - openSUSE Forums
    Concepts - openSUSE
    Henk van Velden

  4. #4

    Default Re: Not able to install rpm

    Hi, Thank you for the post. But the same problem persists for all the RPMs. So is there any permanent solution for my problem.
    Can I delete PK_TMP_DIR? If so how?

    Please help me

    Thank you

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Not able to install rpm

    Please post result of

    Code:
    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Not able to install rpm

    Try to clean your tmp dir in var, maybe that will sort it out for you.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  7. #7
    palladium NNTP User

    Default Re: Not able to install rpm

    pramodbhat wrote:

    > Can I delete PK_TMP_DIR? If so how?


    'Clear Temp Files at Boot - openSUSE Forums'
    (http://tinyurl.com/yzmzp5b)

    --
    palladium

  8. #8

    Default Re: Not able to install rpm

    Hi, this is the result of zypper ld -r in my terminal







    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+--------------+-----------------------+---------+---------+----------+----------+-----------------------------------------------------------------+--------
    1 | PK_TMP_DIR | PK_TMP_DIR | Yes | Yes | 99 | plaindir | dir:///var/tmp/TmpDir.vQRCjU |
    2 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
    3 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    4 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    5 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
    6 | repo-update | openSUSE-11.2-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.2

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Not able to install rpm

    Open a terminal and become su and do

    Code:
    zypper rr 1
    then
    Code:
    zypper in flash-player
    then
    Code:
    zypper up
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: Not able to install rpm

    Hi All, Thanks a lot for the replies. Bit relieved now.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •