Results 1 to 5 of 5

Thread: Blender Launches Fullscreen

  1. #1

    Default Blender Launches Fullscreen

    I've just decided to switch from Ubuntu and give this distro another go. I've not used SUSE since 9.x so we'll see what happens. I'm running Gnome anyway but when I launch Blender installed from the repositories it goes fullscreen (press F11 in firefox and that's fullscreen). This isn't the default - the default is windowed like when Firefox is maximised say.
    You can run it from a terminal with the switch -w to launch it windowed but that doesn't do anything...still fullscreen. Then comes the kicker - I downloaded the alpha version of 2.5 which is a binary in a tarball and it still did it. What's going on? Why is openSUSE 11.2 forcing fullscreen mode? Any ideas because I quite like what I'm seeing in this version of openSUSE but I really need to do my 3D stuff in it and fullscreen makes things difficult when i want to multitask.

    Thanks

    Adam

  2. #2
    palladium NNTP User

    Default Re: Blender Launches Fullscreen

    i've never used (or seen) Blender, but here is what i would try, in
    the order i would try it...when Blender opens:

    1. try pressing Esc
    2. try pressing F11
    3. try press and hold Alt then Tab (maybe you could use this to switch
    to other apps?)

    if none of those work, i'd close Blender and try reading the apps for
    it to learn the default way to keyboard switch from/to full screen
    (what an idea!)

    it reading the manual doesn't work i'd use YaST to add a new user
    Test, then log out and back in as Test, and see if blender works right
    there...if so the problem is the hidden directory for Blender in your
    home...probably named .blender, and you can use diff to compare the
    files in your home with the ones in Test's home...to discover the
    fault in your....tedious, but possible..

    then i'd use a text editor to repair every config file inside the
    ..blender directory in _my_ home folder which so needed...or just copy
    them from Test over to my home..

    notes:
    -at the end of 1, 2 and 3 your Blender is likely to still work.
    -at the end of reading the manual, Blender is likely to work better.
    -after changing config files, Blender may or may not work at all.
    -as an alternative to making a new user, some might suggest to just
    close Blender and go into you home and change the name of .blender to
    ..blenderOLD then restart Blender, if that works then the bad config
    file along with anything you might have wanted to save is inside
    ..blender OLD

    good luck...hope you find it reading..

    --
    palladium

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,037
    Blog Entries
    14

    Default Re: Blender Launches Fullscreen

    Have blender 2.49a installed. Works like a charm on KDE4 and XFCE. No other apps have this weird behaviour?

    Just found something on compiz and blender, stating compiz causes this. Do you have compiz (i.e. desktop effects) running? Turn them off and see if things improve.
    Last edited by Knurpht; 21-Mar-2010 at 06:34. Reason: added compiz as a possible cause
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: Blender Launches Fullscreen

    Hello adam-red,

    First of all, welcome to the community.
    Just found something on compiz and blender, stating compiz causes this. Do you have compiz (i.e. desktop effects) running? Turn them off and see if things improve.
    I think this will help. Because I had the same problem when I used GNOME and Compiz. (Now I use KDE)

    You can also try unchecking "Legacy Fullscreen Support" under System->Preferences->Advanced Desktop Effects Settings.
    I'm not sure if this helps because I couldn't try it myself.
    You can run it from a terminal with the switch -w to launch it windowed but that doesn't do anything...still fullscreen.
    After some searching I found someone with the same problem.
    Running this command worked for him:
    Code:
    blender -w -p 0 0 1024 768
    This will run blender in a window with a size of 1024 by 768.
    The first two zero's are for the location of the window.

    If this works for you, you can edit the command in the menu.
    I don't know how to do that.
    But maybe someone else who's using GNOME knows how to do that.

    Best of luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  5. #5

    Default Re: Blender Launches Fullscreen

    Thanks for the replies. It seems it is indeed a problem caused by Compiz and disabling it resolves the issue. This has never been a problem for me personally on Ubuntu, but other people seem to have reported it now I know what to search for. Thanks for the responses anyway. Hopefully this'll help other people with the same problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •