Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Krunner issues

  1. #1
    Join Date
    Nov 2009
    Location
    Santiago, Chile
    Posts
    171

    Question Krunner issues

    Hi there people.
    Sometimes when I type something to run apps on krunner (alt + f2) it gets freeze for about 10 seconds. I say sometimes but sure it happens most of times I use krunner. Other times I write it on but then the app doesn't come up until about 10 seconds...

    Does someone else have this issue on krunner??
    KDE 4.4.1, openSUSE 11.2

    Thanks in advance.
    HP pavilion dv6-6185la - Intel i7 - AMD Radeon 6770M - openSUSE 12.2 - KDE 4.9

  2. #2
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Krunner issues

    I suggest removing the settings of KRunner:

    Code:
    rm ~/.kde4/share/config/krunnerrc
    You'll have to reconfigure those settings of KRunner after this.

  3. #3

    Default Re: Krunner issues

    I have similar problems with krunner. Like faco said, after starting an application, nothing happens for 10 to 15 seconds. Sometimes when typing text, krunner would freeze for some time. Occasionally krunner won't start at all (Alt+F2).

    All problems seem to be random and after short period of time everything is back to normal. I can't say for sure, but I think this all started with kde4.4 installation (currently 4.4.1, had 4.3.5 before). Tried to delete krunnerc, but it didn't help.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: Krunner issues

    Since 4.4 is beta maybe you should check in the beta form and see if others are having the same problem.

    Did you try gropiuskalle's suggestion?

  5. #5

    Default Re: Krunner issues

    Looks like this has been fixed in latest kde release.

    From 4.4.2 release notes
    "The audioplayer KRunner plugin has been fixed to not freeze the KRunner UI anymore"

  6. #6
    Join Date
    Nov 2009
    Location
    Santiago, Chile
    Posts
    171

    Default Re: Krunner issues

    Quote Originally Posted by rewop View Post
    Looks like this has been fixed in latest kde release.

    From 4.4.2 release notes
    "The audioplayer KRunner plugin has been fixed to not freeze the KRunner UI anymore"
    I already upgraded to the 4.4.2 version but the problem still exists. The fact is that it doesn't get freeze only because of the amarok plugin it gets so with any command I put in. Of course sometimes it works just pretty good.
    HP pavilion dv6-6185la - Intel i7 - AMD Radeon 6770M - openSUSE 12.2 - KDE 4.9

  7. #7
    Join Date
    Jan 2009
    Location
    Orlando, FL
    Posts
    172

    Default Re: Krunner issues

    I am having the same issue. KRunner freezes evertime for me. I am running latest versions from repositories for 4.4.2 and running on 11.1 64bit. Really annoying behavior.
    Desktop - Custom Build | Intel i7-950 | Asus P6X58D Premium MB | openSUSE 13.2 X86_64 | 12GB Ram | NVidia GTX580 | KDE 4.14.8

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,051
    Blog Entries
    14

    Default Re: Krunner issues

    Any of you tried gropiuskalle's suggestion? It might simply be some old settings. No krunner issues here.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9
    Join Date
    Jan 2009
    Location
    Orlando, FL
    Posts
    172

    Default Re: Krunner issues

    Quote Originally Posted by Knurpht View Post
    Any of you tried gropiuskalle's suggestion? It might simply be some old settings. No krunner issues here.
    I just tried it now and YES it fixed the issue I had. Thank you.
    Desktop - Custom Build | Intel i7-950 | Asus P6X58D Premium MB | openSUSE 13.2 X86_64 | 12GB Ram | NVidia GTX580 | KDE 4.14.8

  10. #10
    Join Date
    Nov 2009
    Location
    Santiago, Chile
    Posts
    171

    Default Re: Krunner issues

    I found that in my case the nepomuk search option was the problem. I just disabled it and now Krunner works great. Anyway this must be a nepomuk issue on my system and not exactly a KDE4 Krunner problem.
    HP pavilion dv6-6185la - Intel i7 - AMD Radeon 6770M - openSUSE 12.2 - KDE 4.9

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •