Results 1 to 8 of 8

Thread: konqueror started again and again

  1. #1
    Join Date
    Jan 2009
    Location
    Munich / Germany
    Posts
    69

    Default konqueror started again and again

    Hello,

    I have a strange effect here, where konqueror is started multiple times.
    It is no problem to start it from the K-Menu. But konqueror seems to be associated with different actions in applications, e.g. many "help" entries; among others e.g. Inkscape: "Hilfe/Inkscape Handbuch" (~ Help/Inkscape handbook")
    If I'm unfortunate enough to hit such an item, the konqueror items start flooding my task bar, while the mouse cursor - changed to the konqueror icon - is flickering like wild, while konqueror is starting again and again.
    None of the windows really open and all icons disappear after some time. (due to some resource overflow, but unfortunately I can't find the relevant log entry this time)

    How can I prevent this ? (Or debug this, if the cause is unclear)

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,992

    Default Re: konqueror started again and again

    I never heard of the starnge efects you have, but you could help people in helping you by at least tell which level of openSUSE and which level of KDE you use.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Stone Mountain, GA, USA
    Posts
    29

    Default Re: konqueror started again and again

    I may have accidentally stumbled across something just this morning while trying to get system sounds to work that may help. In the CONFIGURE DESKTOP (Personal setting) app there an option to configure DEFAULT APPLICATIONS. I can't say for sure that's where your solution is but I'd look there (as well as the other areas) to see if it helps.

    P.S.
    I can sympathize with your annoyance about multiple version of Konqueror (the same app starting for every 'help' request, it bugs me too). So much, that I've limit using 'help' only as a very last resort.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,992

    Default Re: konqueror started again and again

    Quote Originally Posted by hcvv View Post
    .... but you could help people in helping you by at least tell which level of openSUSE and which level of KDE you use.
    Missed you my question for some reason? We try to help, when you do not provide even the slightest bit of info asked for, it is getting difficult for us.
    Henk van Velden

  5. #5
    Join Date
    Jan 2009
    Location
    Munich / Germany
    Posts
    69

    Thumbs up Re: konqueror started again and again

    Hello,

    first off: With the hints given, this lead me to the correct solution. You find this below the =====. I tell the complete story here for letting you know the (boring) details. (But I still can't understand everything - see below)

    but you could help people in helping you by at least tell which level of openSUSE and which level of KDE you use.
    ooops, sorry, stupid me - surely you need to know this:
    Suse 11.2 (64 Bit), patched up to date
    KDE 4.3.5

    I may have accidentally stumbled across something just this morning while trying to get system sounds to work that may help. In the CONFIGURE DESKTOP (Personal setting) app there an option to configure DEFAULT APPLICATIONS.
    I tried this, here is my result:
    I changed this to firefox (I've installed 3.6 from Mozilla binary tar-ball)

    If I now do the same thing in Inkscape, firefox offers to download (!) the following file:
    file:///var/tmp/kdecache-jost/krun/6484.0.index.php

    There are no multiple startups (better), but I still don't get to see the contents either (still bad) :-(

    So I tried to configure this back to konqueror (just as a test).
    If I click the [...] button, I get the list like in the K-menu. If I choose Internet/Web-Browser/konqueror I got an entry named "konqbrowser". If I use this and try it in inkscape again, I get a pop up: (my translation below, I failed to have inkscape start with english GUI, using > export KDE_LANG="en_US";inkscape)
    "Die Datei /var/tmp/kdecache-jost/krun/6607.0.index.php ist als UTF-8 kodiert geffnet worden, enthlt aber ungltige Zeichen. Der Zugriff ist auf Nur-Lesen gesetzt worden, da ein Speichern den Inhalt der Datei zerstren knnte. ffnen Sie die Datei erneut mit der korrekten Kodierung oder deaktivieren Sie den Nur-Lesen-Modus ber das Men."
    ==
    "The file var/tmp/kdecache-jost/krun/6607.0.index.php has been opened as UTF-8 coded, but contains invalid characters. The access has been set to read-only, because saving could destroy the contents of the file. Open the file again using the correct coding or deactivate the read-only-mode using the menu"

    On clicking ok, just the source-text is opened (so similar to firefox)

    But - tata - here is the "trick":
    ========================================
    I choose (again my translation) K-menu/programs/system configuration
    There "Standard components"; "Web Browser"
    I entered (by hand) "konqueror" in the line and applied the setting.
    And now konqueror starts (just once :-) and displays the wanted help page. (on Inkscape)
    My problem is, I now have no clue, what has been wrong in the first place. At least I didn't see anything suspect in the menu when I opened it the first time.

    (There is some small "chance" that I get the problem again: I have rarely seen strange things happening, depending on hibernate/suspend usage before)

    Thanks for pointing me in the right direction - one really bad annoyance solved !

    Martin

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,992

    Default Re: konqueror started again and again

    Congrats, nice you are satisfied.
    Henk van Velden

  7. #7
    Join Date
    Jan 2009
    Location
    Munich / Germany
    Posts
    69

    Default Re: konqueror started again and again

    Hello,

    I just rechecked, using a second account (which I never configured myself in this regard.) To my amazement
    - In the configuration "K-menu/programs/system configuration"
    Under "Standard components"; "Web Browser"
    There was chosen "with the following browser" but the field
    was just empty. (I don't think, the configuration in my first
    account looked like this, while the problem still persisted)
    - When I tried to open the Inkscape help, I had the old problem.

    Just for the fun of it:
    I put a screen-shot of this on my domain:
    http://www.majo.name/konqueror.png

    When I explicitly typed "konqueror" in the entry, the problem was solved - as with my account.

    So I'm asking myself, if this is problem which might bite quite a couple of Suse users ?

    Regards

    Martin

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,992

    Default Re: konqueror started again and again

    Never saw this before, But I love it (on anothers system )
    Henk van Velden

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •