Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: gnome apps floating point exception

  1. #1

    Default gnome apps floating point exception

    gnome games, specifically solitaire and gimp both have started returning a floating point exception fault.

    Any help appreciated

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,924

    Default Re: gnome apps floating point exception

    Hello johnbat,

    Welcome to the Forums (I see this is your first post).

    I can understand your annoyance at applications bailing out with floating point exceptions. However you will most probably have searched these forums for similar threads first and have not found any others expiriencing this. This makes it the more inmportant that you tell a bit more about what you have like openSUSE level. Which DE (I suppose Gnome, but that is not for sure, one can run Gnome applic on KDE with ease). Did this start just yesterday after an update or after the install of e new product.

    In short, you should tell us much more then the short sentence you gave.
    Henk van Velden

  3. #3

    Default Re: gnome apps floating point exception

    Thanks for the welcome.

    You're quite correct. Google doesn't find anything to help.
    I'm running OpenSuse 11.2 My desktop is KDE. Although I have as much Gnome installed as I need to run sol and gimp, I don't use the Gnome desktop.
    I'm not certain, but I think the fault started after a zypper dup upgrade.

    Initially gimp just hung in limbo. After I re-installed gimp with yast2 the fault changed to a floating point exception

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,924

    Default Re: gnome apps floating point exception

    Why did you do a zypper dup? To upgrade from 11.1 to 11.2?

    What repos do you have enabled. Please the output of
    Code:
    zypper lr
    And what level of Gimp is iinstalled? I have 2.6.7 on openSUSe 11.2 and use it inside KDE 4.3.5 without the problem you have. But you problem may be due to an incompatible mix of Gimp with some library.
    Henk van Velden

  5. #5

    Default Re: gnome apps floating point exception

    I used zypper dup because I come from Debian where you use apt-get dist-upgrade when you want to upgrade to the latest versions of all installed software.

    I suspect that this is not the Opensuse way and would appreciate some guidance in this regard.

    It is a fresh 11.2 install that I have managed to break.

  6. #6

    Default Re: gnome apps floating point exception

    ~> zypper lr
    # | Alias | Name | Enabled | Refresh
    ---+-------------------------------------+-----------------------------+---------+--------
    1 | Packman | Packman | Yes | Yes
    2 | Packman Repository | Packman Repository | Yes | Yes
    3 | VideoLan Repository | VideoLan Repository | Yes | No
    4 | home:broumbroum23 | home:broumbroum23 | Yes | Yes
    5 | http-download.opensuse.org-7d6e8cb8 | Updates for openSUSE 11.2-0 | Yes | Yes
    6 | openSUSE 11.2-0 | openSUSE 11.2-0 | Yes | No
    7 | repo-debug | openSUSE-11.2-Debug | No | Yes
    8 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes
    9 | repo-oss | openSUSE-11.2-Oss | Yes | Yes
    10 | repo-source | openSUSE-11.2-Source | No | Yes

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,924

    Default Re: gnome apps floating point exception

    Zypper dup is for going to a next level of openSUSE. When you only want to update what is new in the repos, you use zypper up.

    You have two Packman repos, one is enough. I should have asked for
    Code:
    zypper lr -d
    That would have shown the URLs and we would be able to more easily decide which one has to go.

    You better disable the Videolan one. Once you have the one packet from there, you do not need it anymore.

    And what about the broumbroum? When you got from there what you needed, disable it also for the moment. These or not garanteed to mix good with the standard repos.

    And the Gimp level?

    In any case you could do (after the disableing above)
    Code:
    zyper ref
    zypper up
    And then check again for the error.
    Henk van Velden

  8. #8
    Join Date
    Jan 2010
    Location
    Orlando, FL
    Posts
    212

    Default Re: gnome apps floating point exception

    I'm using the KDE Factory repo's and KDE 4.4.1 rel 227

    I use zypper dup to update all my KDE packages and everything else. All is running great.

    Is this not recommended while we're on the subject? tks
    Cheers, Big Ears!

    DΞLL Precision M6500: i7-820QM w/USB 3.0, 8.0GB DDR3-1333, Intel x-25M 160 G2 + 500GB 7200.3, nVidia Quadro FX 3800M 1.0GB DDR3, RGBLED, Intel 6300//Win7Pro x64
    DΞLL Vostro 1220 //openSUSE 11.3 KDE/Win7Pro 32

  9. #9

    Default Re: gnome apps floating point exception

    I have taken out the repos you suggested.
    zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+-------------------------------------+-----------------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
    1 | Packman | Packman | Yes | Yes | 99 | rpm-md | Index of /suse/11.2 |
    2 | http-download.opensuse.org-7d6e8cb8 | Updates for openSUSE 11.2-0 | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |
    3 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
    4 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    5 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    6 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |

    Yast2 I have updated gimp:
    gimp -v
    GNU Image Manipulation Program version 2.6.7

    using GEGL version 0.1.0 (compiled against version 0.1.0)
    using GLib version 2.22.4 (compiled against version 2.22.1)
    using GTK+ version 2.18.6 (compiled against version 2.18.1)
    using Pango version 1.26.2 (compiled against version 1.26.0)
    using Fontconfig version 2.7.0 (compiled against version 2.7.0)

    The error messages now, after an update:
    :~> gimp
    (script-fu:29713): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error
    Floating point exception

    :~> sol
    Floating point exception

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,924

    Default Re: gnome apps floating point exception

    My advice was to do
    Code:
    zypper ref
    zypper up
    not to only update gimp.
    Henk van Velden

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •