Results 1 to 7 of 7

Thread: New KRandR Program

  1. #1
    upscope NNTP User

    Default New KRandR Program

    Nvidia 190-53, OS,KDE and Video Card version in signature.

    Yesterday my 15 year old 19" Panasonic Monitor gave up the ghost.
    Purchased and install a new Samsung Syncmaster 2233SW LCD Monitor
    (21.5"). It can up and configured out of the box. The resolution
    defaults to 1280x1024. This is not the default recommended by
    SamSung. I change the resolution to 1920 by 1080 with Nvidia X
    server settings and the config desktop --> display. Cannot save
    setting because xorg.config cannot be updated. which I understand is
    OK. Everytime I restart of shutdown and start again I have to
    reinstalled the resolution to default 1920x1080. Nothing seems to
    retain the changed settings.

    Today I got update to KRandR program. And found item in Bugzilla to
    use it. I rebooted and it does not detect monitor as Samsung and
    only offers 1280x1024 as highest resolution. If I change the
    resolution with Nvidia Server, then KRandR set to higher resolution
    but does not detect monitor, calls it default.

    Am I missing something or do i need to report bug in KRandR? Any
    help would be appreciated
    --
    Russ
    | openSUSE 11.2 (2.6.31.12-0.1-desktop) x86_64 | KDE 4.3.5 release 3
    | Intel Core 2 Dual E7200 | 4 GB RAM | GeForce 8400 GS | 320GB Disc
    (2) |

  2. #2
    Join Date
    Nov 2009
    Location
    Uruguay
    Posts
    737

    Default Re: New KRandR Program

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    What about using sax2?

    - --
    VampirD

    Microsoft Windows is like air conditioning
    Stops working when you open a window.
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.12 (GNU/Linux)
    Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org/

    iEYEARECAAYFAkuNU+wACgkQJQ+0ABWtaVknBQCeL05X3AfytbJ8mFmfxvPtFJBH
    HJsAoO0rvqEbbn3TVQYvRm93XUn2lQIL
    =Q4JX
    -----END PGP SIGNATURE-----

  3. #3
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,021

    Default Re: New KRandR Program

    Quote Originally Posted by upscope View Post
    I change the resolution to 1920 by 1080 with Nvidia X
    server settings and the config desktop --> display. Cannot save
    setting because xorg.config cannot be updated. which I understand is
    OK. Everytime I restart of shutdown and start again I have to
    reinstalled the resolution to default 1920x1080. Nothing seems to
    retain the changed settings.
    Run nvidia-settings as root, then it will write/update xorg.conf.


    Today I got update to KRandR program. And found item in Bugzilla to
    use it. I rebooted and it does not detect monitor as Samsung and
    only offers 1280x1024 as highest resolution. If I change the
    resolution with Nvidia Server, then KRandR set to higher resolution
    but does not detect monitor, calls it default.

    Am I missing something or do i need to report bug in KRandR? Any
    help would be appreciated
    KRandR doesn't work well with NVIDIA cards. Stick with nvidia-settings.
    Günter

    Desk: Leap 42.2, KDE 5, Intel i3, 8Gb, Kingston 64Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,996
    Blog Entries
    14

    Default Re: New KRandR Program

    Quote Originally Posted by upscope View Post
    Nvidia 190-53, OS,KDE and Video Card version in signature.

    Any
    help would be appreciated
    --
    Russ
    | openSUSE 11.2 (2.6.31.12-0.1-desktop) x86_64 | KDE 4.3.5 release 3
    | Intel Core 2 Dual E7200 | 4 GB RAM | GeForce 8400 GS | 320GB Disc
    (2) |
    Please first try this: remove/rename xorg.conf, restart X and let HAL do the autodetection and configuration. You may very well end up with a proper desktop resolution.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    upscope NNTP User

    Default Re: New KRandR Program

    Knurpht wrote:

    >
    > upscope;2129492 Wrote:
    >> Nvidia 190-53, OS,KDE and Video Card version in signature.
    >>
    >> Any
    >> help would be appreciated
    >> --
    >> Russ
    >> | openSUSE 11.2 (2.6.31.12-0.1-desktop) x86_64 | KDE 4.3.5
    >> | release 3 Intel Core 2 Dual E7200 | 4 GB RAM | GeForce 8400 GS
    >> | | 320GB Disc
    >> (2) |

    >
    > Please first try this: remove/rename xorg.conf, restart X and let
    > HAL do the autodetection and configuration. You may very well end
    > up with a proper desktop resolution.
    >

    I'll try this. I did go into my 11.3 MS1 system and it is
    remembering the setting but reports the refresh rate as 50 HZ,
    Should be 60 according to Samsung. 11.2 lets me change it but 11.3
    doesn't.

    I'll post the results later today.

    Thanks.

    --
    Russ
    | openSUSE 11.2 (2.6.31.12-0.1-desktop) x86_64 | KDE 4.3.5 release 3
    | Intel Core 2 Dual E7200 | 4 GB RAM | GeForce 8400 GS | 320GB Disc
    (2) |

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,570
    Blog Entries
    38

    Default Re: New KRandR Program

    In case you did not see this guide, here is a "practical theory" guide on nvidia graphic drivers in openSUSE:
    openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

  7. #7
    upscope NNTP User

    Default Re: New KRandR Program (Solved)

    upscope wrote:

    > Nvidia 190-53, OS,KDE and Video Card version in signature.
    >
    > Yesterday my 15 year old 19" Panasonic Monitor gave up the ghost.
    > Purchased and install a new Samsung Syncmaster 2233SW LCD Monitor

    Solved.
    Thanks to everyones input I now have this working.I did the
    following:
    Renamed xorg.conf
    Ran nvidia settings as root.
    executed rcxdm stop then
    rcxdm start.

    After looking my system now starts at 1920x1980 even after
    rebooting. I checked /etc/X11 and there is no xorg.conf file. there
    are several others called backup etc. This goes along with the how
    to oldcpu pointed me to. I will leave the old file there incase its
    needed.

    Thanks to everyone's help.

    --
    Russ
    | openSUSE 11.2 (2.6.31.12-0.1-desktop) x86_64 | KDE 4.3.5 release 3
    | Intel Core 2 Dual E7200 | 4 GB RAM | GeForce 8400 GS | 320GB Disc
    (2) |

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •