Results 1 to 7 of 7

Thread: modifying the start option

  1. #1

    Default modifying the start option

    hi, everyone i'm new in this forum, and after the install on the hd i had to modify manually the start option otherwise i wouldn't .
    I found out in the option that i have to give: pci=noacpi and the start will go on.
    My question is , how to do this automatically, i mean modifying before every boot would be annoying.

    thanks a lot

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: modifying the start option

    Edit the file menu.lst like this:

    Depending if using gnome or kde do one of the following in a terminal

    Code:
    kdesu kwrite /boot/grub/menu.lst
    or
    Code:
    gnomesu gedit /boot/grub/menu.lst
    In your menu there add the argument to the main openSUSE boot, like in my example

    default 0
    timeout 8
    ##YaST - generic_mbr
    gfxmenu (hd0,1)/boot/message
    ##YaST - activate

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.2 - 2.6.31.12-0.1
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.31.12-0.1-default root=/dev/disk/by-id/ata-ST9160827AS_5RF16D1B-part2 resume=/dev/disk/by-id/ata-ST9160827AS_5RF16D1B-part5 splash=silent quiet showopts pci=noacpi vga=0x367
    initrd /boot/initrd-2.6.31.12-0.1-default
    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.2 - 2.6.31.12-0.1
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.31.12-0.1-default root=/dev/disk/by-id/ata-ST9160827AS_5RF16D1B-part2 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x367
    initrd /boot/initrd-2.6.31.12-0.1-default
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: modifying the start option

    hi , before y reply thank you for your advice.
    Well did what you said like this:

    default 0
    timeout 8
    ##YaST - generic_mbr
    gfxmenu (hd0,1)/boot/message
    ##YaST - activate

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.2 - 2.6.31.12-0.1
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.31.12-0.1-default root=/dev/disk/by-id/ata-ST9160827AS_5RF16D1B-part2 resume=/dev/disk/by-id/ata-ST9160827AS_5RF16D1B-part5 splash=silent quiet showopts pci=noacpi vga=0x367
    initrd /boot/initrd-2.6.31.12-0.1-default
    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.2 - 2.6.31.12-0.1
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.31.12-0.1-default root=/dev/disk/by-id/ata-ST9160827AS_5RF16D1B-part2 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x367
    initrd /boot/initrd-2.6.31.12-0.1-default

    and i modify it with my HD and kernel because there were just different

    replace; kernel and hd

    and restart the system, in the menu appears this new boot option but when i clic on it doesnt worked the start, just goes to the next display stays still.

    i hope you do have another solution to this mattter.

    thanks a lot again.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: modifying the start option

    Please post the result of this from a su terminal

    Code:
    cat /boot/grub/menu.lst
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: modifying the start option

    linux-uhib:/home/rudy # cat /boot/grub/menu.lst
    # Modified by YaST2. Last modification on Mon Mar 1 18:12:29 ICT 2010
    # THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
    # Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

    default 0
    timeout 8
    gfxmenu (hd0,5)/boot/message
    ##YaST - activate

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.2
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.31.5-0.1-default root=/dev/disk/by-id/ata-ST340014A_5JX49QL2-part6 resume=/dev/disk/by-id/ata-ST340014A_5JX49QL2-part5 splash=silent quiet showopts vga=0x314
    initrd /boot/initrd-2.6.31.5-0.1-default

    ###Don't change this comment - YaST2 identifier: Original name: windows 1###
    title windows 1
    rootnoverify (hd0,0)
    chainloader +1

    ###Don't change this comment - YaST2 identifier: Original name: windows 2###
    title windows 2
    map (hd1) (hd0)
    map (hd0) (hd1)
    rootnoverify (hd1,0)
    makeactive
    chainloader +1

    ###Don't change this comment - YaST2 identifier: Original name: windows 3###
    title windows 3
    map (hd1) (hd0)
    map (hd0) (hd1)
    rootnoverify (hd1,1)
    makeactive
    chainloader +1

    ###Don't change this comment - YaST2 identifier: Original name: floppy###
    title Floppy
    rootnoverify (fd0)
    chainloader +1

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.2
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.31.5-0.1-default root=/dev/disk/by-id/ata-ST340014A_5JX49QL2-part6 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x314
    initrd /boot/initrd-2.6.31.5-0.1-default


    default 0
    timeout 8
    ##YaST - generic_mbr
    gfxmenu (hd0,1)/boot/message
    ##YaST - activate

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.2 - 2.6.31.5-0.1
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.31.5-0.1-default root=/dev/disk/by-id/ata-ST340014A_5JX49QL2 resume=/dev/disk/by-id/ata-ST340014A_5JX49QL2-part5 splash=silent quiet showopts pci=noacpi vga=0x367
    initrd /boot/initrd-2.6.31.5-0.1-default
    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.2 - 2.6.31.5-0.1
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.31.5-0.1-default root=/dev/disk/by-id/ata-ST340014A_5JX49QL2-part2 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x367
    initrd /boot/initrd-2.6.31.5-0.1-default linux-uhib:/home/rudy #

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: modifying the start option

    Quote Originally Posted by lobstercrab View Post
    linux-uhib:/home/rudy # cat /boot/grub/menu.lst
    # Modified by YaST2. Last modification on Mon Mar 1 18:12:29 ICT 2010
    # THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
    # Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

    default 0
    timeout 8
    gfxmenu (hd0,5)/boot/message
    ##YaST - activate

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.2
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.31.5-0.1-default root=/dev/disk/by-id/ata-ST340014A_5JX49QL2-part6 resume=/dev/disk/by-id/ata-ST340014A_5JX49QL2-part5 splash=silent quiet showopts vga=0x314
    initrd /boot/initrd-2.6.31.5-0.1-default

    ###Don't change this comment - YaST2 identifier: Original name: windows 1###
    title windows 1
    rootnoverify (hd0,0)
    chainloader +1

    ###Don't change this comment - YaST2 identifier: Original name: windows 2###
    title windows 2
    map (hd1) (hd0)
    map (hd0) (hd1)
    rootnoverify (hd1,0)
    makeactive
    chainloader +1

    ###Don't change this comment - YaST2 identifier: Original name: windows 3###
    title windows 3
    map (hd1) (hd0)
    map (hd0) (hd1)
    rootnoverify (hd1,1)
    makeactive
    chainloader +1

    ###Don't change this comment - YaST2 identifier: Original name: floppy###
    title Floppy
    rootnoverify (fd0)
    chainloader +1

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.2
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.31.5-0.1-default root=/dev/disk/by-id/ata-ST340014A_5JX49QL2-part6 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x314
    initrd /boot/initrd-2.6.31.5-0.1-default


    default 0
    timeout 8
    ##YaST - generic_mbr
    gfxmenu (hd0,1)/boot/message
    ##YaST - activate

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.2 - 2.6.31.5-0.1
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.31.5-0.1-default root=/dev/disk/by-id/ata-ST340014A_5JX49QL2 resume=/dev/disk/by-id/ata-ST340014A_5JX49QL2-part5 splash=silent quiet showopts pci=noacpi vga=0x367
    initrd /boot/initrd-2.6.31.5-0.1-default
    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.2 - 2.6.31.5-0.1
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.31.5-0.1-default root=/dev/disk/by-id/ata-ST340014A_5JX49QL2-part2 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x367
    initrd /boot/initrd-2.6.31.5-0.1-default linux-uhib:/home/rudy #
    You don't understand.

    You need to edit YOUR boot option. So the very first part:

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.2
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.31.5-0.1-default root=/dev/disk/by-id/ata-ST340014A_5JX49QL2-part6 resume=/dev/disk/by-id/ata-ST340014A_5JX49QL2-part5 splash=silent quiet showopts vga=0x314 pci=noacpi
    initrd /boot/initrd-2.6.31.5-0.1-default
    You can remove the other stuff you added in, it will never work.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: modifying the start option

    first of all , i apologize, i just understood wrong, interpreted your advice as adding it to my menu list and not posting it at the first line., anyway thank a lot. it's working fine again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •