Results 1 to 6 of 6

Thread: unable to run StarDict

  1. #1
    Join Date
    Jan 2010
    Location
    Tbilisi, Georgia.
    Posts
    44

    Default unable to run StarDict

    Hi everyone,

    I've already posted about my problem in the different section (applications), but they couldn't help me and moderator suggested me to post here and just link back my old post:

    problem with running stardict - openSUSE Forums

    I want to say additionally, that I also tried to contact developers on project contact emails which I found on official StarDict site, but with no success, non of them answered me, or maybe my mail was captured by SPAM-filter.

    Anyways, I'm still trying to get some help. My old post was related to my IBM laptop, on which I tried to install StarDict with help of 1-Click install, but today I tried the different way. As I also have the Desktop PC at home, I decided to install on it StarDict, but this time without any 1-Click Install, but I just searched packages through the Webpin, I checked just tqo packages, StarDict itself and one additional EN_RU dictionary. It also added a couple necessary libraries to run the program properly and started installation which finished successfully. But as soon, as I tried to start software from my Kickoff application launcher, I got the same picture - frozen splash screen and nothing more. After this I tried to run it from terminal and here's what I got:



    Maybe you could help me? Please, I really need any kind of dictionary on my openSUSE as English is not my native language, so if you can't help with solving this issues, then maybe you can suggest me another dictionary software with relatively good quality (I'm already using Dictionary from plasma widgets and Google Dictionary) but I don't like their capabilities. I need something similar to Lingvo (on MS Windows).

    Thanks in advance.

  2. #2
    Join Date
    Jan 2010
    Location
    Tbilisi, Georgia.
    Posts
    44

    Default Re: unable to run StarDict

    I forget to post my software configuration: I'm running openSUSE 11.2 x64 and KDE Desktop 4.3.5

  3. #3
    Join Date
    Jun 2008
    Location
    Taichung city,Taiwan
    Posts
    115

    Default Re: unable to run StarDict

    You can
    1. just remove /usr/lib64/stardict/plugins/stardict_espeak.so
    (if you don't need any sound effect) or
    2. install pusleaudio, then YaST->Hardware->Sound->other->Enable Pulseaudio Support

  4. #4
    Join Date
    Jan 2010
    Location
    Tbilisi, Georgia.
    Posts
    44

    Default Re: unable to run StarDict

    Quote Originally Posted by swyear View Post
    You can
    1. just remove /usr/lib64/stardict/plugins/stardict_espeak.so
    (if you don't need any sound effect) or
    2. install pusleaudio, then YaST->Hardware->Sound->other->Enable Pulseaudio Support
    Oh, thanks God that at least one man uses this dictionary and knows something about it, as I already thought that I was the only user trying to run this application.

    Well, your suggestion helped me, but it seems only half way. Here's what I've done, I just created sub directory in /usr/lib64/stardict/plugins/ and put that file stardict_espeak.so there. After this, I run it again from CLI and the chain of loaded plugins became longer ==>

    Dict.cn plug-in loaded.
    Man plug-in loaded.
    WordNet data parsing plug-in loaded.
    HTML data parsing plug-in loaded.
    Festival plug-in loaded.
    WordNet dict rendering plug-in loaded.
    QQWry plug-in loaded.
    PowerWord data parsing plug-in loaded.
    XDXF data parsing plug-in loaded.
    Spelling plugin loaded.

    and after this, application still hangs and the cursor just blinks maybe I should remove something more? The sound effects really isn't important for me.

    And one more question, why you made me to remove that file, it's fact that it helped to move forward, but I'm just curious, is that software bug, or the problem is in my software/hardware configuration?

    Thanks a lot for helping me.

  5. #5
    Join Date
    Jun 2008
    Location
    Taichung city,Taiwan
    Posts
    115

    Default Re: unable to run StarDict

    Quote Originally Posted by vojd View Post
    Oh, thanks God that at least one man uses this dictionary and knows something about it, as I already thought that I was the only user trying to run this application.

    Well, your suggestion helped me, but it seems only half way. Here's what I've done, I just created sub directory in /usr/lib64/stardict/plugins/ and put that file stardict_espeak.so there. After this, I run it again from CLI and the chain of loaded plugins became longer ==>

    Dict.cn plug-in loaded.
    Man plug-in loaded.
    WordNet data parsing plug-in loaded.
    HTML data parsing plug-in loaded.
    Festival plug-in loaded.
    WordNet dict rendering plug-in loaded.
    QQWry plug-in loaded.
    PowerWord data parsing plug-in loaded.
    XDXF data parsing plug-in loaded.
    Spelling plugin loaded.

    and after this, application still hangs and the cursor just blinks maybe I should remove something more? The sound effects really isn't important for me.

    And one more question, why you made me to remove that file, it's fact that it helped to move forward, but I'm just curious, is that software bug, or the problem is in my software/hardware configuration?

    Thanks a lot for helping me.
    REMOVE stardict_espeak.so
    or move it to somewhere other than a sub-dir(maybe stardict will search recursively)
    I'm not sure if this is a bug
    In openSUSE 11.2 Release-Note talk something about pulseaodio support in KDE:
    You should enable pulseaudio support manually!
    and stardict seem like a gnome-based application...
    So if you want stardict to use espeak-plugin
    You should install pulseaudio, and enable pulseaudio support.
    or just REMOVE the espeak.so
    (you can remove that file safely, if you want to use that file again, you could force re-install stardict again)

  6. #6

    Default Re: unable to run StarDict

    I had been puzzled by the same problem as Vojd. Problem sovled. Thank you!
    OpenSUSE 11.2. 64 bit, Xfci, processor: Athlon(TM) 64 Prozessor 3200+, graphics: NVIDIA GeForce 9500 [unfortunately very noisy!], 3 GB RAM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •