Results 1 to 3 of 3

Thread: Help installing ATI Drivers on 2.6.33

  1. #1

    Default Help installing ATI Drivers on 2.6.33

    Hi there,

    I recently (today) re-installed OpenSUSE onto my new SSD. In order to enable newer features of this drive, I upgraded from the default 2.6.31 kernel to the 2.6.33 kernel immediately. I rebooted, and the next thing on my "to-do" list was to install my proprietary ATI fglrx drivers.

    However, doing so through the repository calls for a dependency of ati-fglrxG02-kmp-desktop/default with is a Kernel Module, however, such a version only supports up to 2.6.31 (or so I seem to believe). Instead, I grabbed the newest Catalyst from ATI's website (at the time of this writing, 10.2) and tried to install it. I finished, and reboot and my mouse cursor was no where to be found.

    So, after invisi-clicking my way around to Firefox, I found some tips and tried adding "Option "HWCursor" "off"" to my xorg.conf and reboot again, to no avail.

    So I uninstalled everything, and retried, this time trying to create an RPM out of the .run file. I used --listpkg and then ran --buildpkg with SuSE/SUSE112-AMD64 or what have you and it then spat an error that that wasn't valid, despite being copied directly from their listpkg output.

    In short, I'm just looking for a way to get this stupid driver to work. I'll be upgrading to an NVidia graphics card ASAP but in the meantime I do need to get this working. Thanks!

    EDIT: Card is HD4850, forgot to mention that

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Help installing ATI Drivers on 2.6.33

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Help installing ATI Drivers on 2.6.33

    Nope. While I appreciate the link, I've already covered that aspect of my troubles. I need the fglrx driver, and I need it on a newer kernel than 2.6.31. I could use an older Catalyst version, if the newer ones are causing problems, but the only Catalyst I remember having problems was 9.11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •