Results 1 to 6 of 6

Thread: ooo3.2 openSUSE version - Writer

  1. #1
    upscope NNTP User

    Default ooo3.2 openSUSE version - Writer

    I have created a document (ooo 3.2.0.5., openSUSE11.2.) with a
    mailto hyperlink in it. My default mail program is Kmail. The hyper
    link will not open it. If I install thunderbird, it open the equal
    of composer and I can send the email. I have looked at help. nothing
    on hyperlinks. Google show some issues but not this one.

    I've gone to options --> Internet --> E-mail and inserted:
    kmail -caption "%c"
    still wil not work. How or where to I make a change to use Kmail
    instead of thunderbird? Is there a how to for configuring mailto
    link?

    Thanks
    --
    Russ
    | openSUSE 11.2 (2.6.31.12-0.1-desktop) x86_64 | KDE 4.3.5 release 3
    | Intel Core 2 Dual E7200 | 4 GB RAM | GeForce 8400 GS | 320GB Disc
    (2) |

  2. #2
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: ooo3.2 openSUSE version - Writer

    Run "Configure Desktop" and choose kmail as the default mail application.
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  3. #3
    upscope NNTP User

    Default Re: ooo3.2 openSUSE version - Writer

    syampillai wrote:

    >
    > Run "Configure Desktop" and choose kmail as the default mail
    > application.hav
    >

    Thanks for the reply. I had the default mail program set to "Use
    Kmail as preferred email program. I even tried it by changing to:
    Use a different email client and put The call from the Icon in it.
    "kmail -caption "%c"". Also checked run in terminal. Neither helped.
    Yesterday I discovered that file --> send calls kmail fine. Its only
    the mailto: that will not call kmail but it calls Thunderbird OK, if
    its installed. I changed back to use kmail as preferred client.

    In addition the hyperlink toolbar shows the correct URL Name and
    correct URL.

    Should I report this as Bug?

    Thanks again.

    --
    Russ
    | openSUSE 11.2 (2.6.31.12-0.1-desktop) x86_64 | KDE 4.3.5 release 3
    | Intel Core 2 Dual E7200 | 4 GB RAM | GeForce 8400 GS | 320GB Disc
    (2) |

  4. #4

    Default Re: ooo3.2 openSUSE version - Writer

    I never use OpenOffice.org, but tested with the OpenOffice.org:STABLE OBS version and saw the same behavior.

    Quote Originally Posted by upscope View Post
    Should I report this as Bug?
    Sure.
    Even supposing it's a config problem, it should at least give an error message. As it is now is plain wrong, a bug to be fixed.

  5. #5

    Default Re: ooo3.2 openSUSE version - Writer

    I had some more luck with Google: OpenOffice.org Forum :: [Solved] mailto: hyperlinks not working with KMail

    My OpenOffice_org-libs-core package provides
    /usr/lib64/ooo3/basis3.2/program/open-url
    /usr/lib64/ooo3/basis3.2/program/kde-open-url

    If I execute the first with 'mailto:a@a.com' as parameter nothing happens, but with kde-open-url works. So the problem seems to be that the KDE specific script isn't used.
    Anyway IMHO those two scripts shouldn't exist at all. OpenOffice.org should use xdg-open


    It's a shame that someone found the problem in 2007 and he never informed the devs... so we are here today. I will report it if you don't, but say me if so.

  6. #6
    upscope NNTP User

    Default Re: ooo3.2 openSUSE version - Writer

    RedDwarf wrote:

    >
    > I had some more luck with Google: 'OpenOffice.org Forum ::
    > [Solved] mailto: hyperlinks not working with KMail'
    > (http://www.oooforum.org/forum/viewtopic.phtml?t=61775)
    >
    > My OpenOffice_org-libs-core package provides
    > /usr/lib64/ooo3/basis3.2/program/open-url
    > /usr/lib64/ooo3/basis3.2/program/kde-open-url
    >
    > If I execute the first with 'mailto:a@a.com' as parameter nothing
    > happens, but with kde-open-url works. So the problem seems to be
    > that the KDE specific script isn't used.
    > Anyway IMHO those two scripts shouldn't exist at all.
    > OpenOffice.org should use 'xdg-open'
    > (http://portland.freedesktop.org/xdg-.../xdg-open.html)
    >
    >
    > It's a shame that someone found the problem in 2007 and he never
    > informed the devs... so we are here today. I will report it if you
    > don't, but say me if so.
    >

    Added comments to Novell bugzilla bug #572761 which I had already
    opened. I reported it there since this is openSUSE version of
    openoffice.

    Thanks for your response. Feel free to add comments. I did quote
    your reply to me on it.

    --
    Russ
    | openSUSE 11.2 (2.6.31.12-0.1-desktop) x86_64 | KDE 4.3.5 release 3
    | Intel Core 2 Dual E7200 | 4 GB RAM | GeForce 8400 GS | 320GB Disc
    (2) |

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •