Results 1 to 7 of 7

Thread: Multiple Online Update errors

  1. #1

    Default Multiple Online Update errors

    Online Update is offered up 6 updates - only 2 succeeded (Mozilla and libpoppler).


    Here's the errors for other packages:
    kbd - Keyboard and Font Utilities (includes aaa_base update)
    Subprocess failed. Error: RPM failed: error: package kbd-1.14.1-20.2.x86_64 is not installed

    php5: fix for several vulnerabilities
    Subprocess failed. Error: RPM failed: error: package php5-ctype-5.3.0-2.4.3.x86_64 is not installed

    patterns-openSUSE: add susehelp to KDE base pattern
    Subprocess failed. Error: RPM failed: error: package
    patterns-openSUSE-file_server-11.2-20.22.1.x86_64 is not installed

    KDE 4.3.5 Update
    Subprocess failed. Error: RPM failed: rpmdb: PANIC: Invalid argument
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30977) from dbcursor->c_put: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30977) storing record into Requireversion
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30977) from dbcursor->c_get: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30977) getting "" records from Requireversion index
    rpmdb: PANIC: fatal region error detected; run recovery
    [...]

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Multiple Online Update errors

    Close the updater and try doing this in su terminal

    Code:
    zypper up
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Multiple Online Update errors

    Quote Originally Posted by caf4926 View Post
    Close the updater and try doing this in su terminal
    Code:
    zypper up
    Same ...

    Continue? [y/n/?] (y): y
    Retrieving package kwalletmanager-4.3.5-0.1.1.x86_64 (1/71), 407.0 KiB (714.0 KiB unpacked)
    Retrieving delta: ./rpm/x86_64/kwalletmanager-4.3.1_4.3.5-3.4_0.1.1.x86_64.delta.rpm, 21.0 KiB
    Retrieving: kwalletmanager-4.3.1_4.3.5-3.4_0.1.1.x86_64.delta.rpm [done (0 B/s)]
    Applying delta: ./kwalletmanager-4.3.1_4.3.5-3.4_0.1.1.x86_64.delta.rpm [done]
    Installing: kwalletmanager-4.3.5-0.1.1 [error]
    Installation of kwalletmanager-4.3.5-0.1.1 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: rpmdb: PANIC: Invalid argument
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30977) from dbcursor->c_put: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30977) storing record into Requireversion
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30977) from dbcursor->c_get: DB_RUNRECOVERY: Fatal error, run database recovery
    error: error(-30977) getting "" records from Requireversion index
    rpmdb: PANIC: fatal region error detected; run recovery
    [...]

    EDITED: Prior to this set of updates, Online Updated updated the updater applet,
    and afterwards, all this is happening.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Multiple Online Update errors

    Please try this in a su terminal

    Code:
    rpmdb --rebuilddb
    It takes a while

    Then try updating
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Multiple Online Update errors

    I had similar problem and that cleared it up perfectly
    Thanks

  6. #6

    Default Re: Multiple Online Update errors

    I also had this problem, and this advice seems to have cleared it up. Thanks!

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Multiple Online Update errors

    Quote Originally Posted by gfoster5 View Post
    I also had this problem, and this advice seems to have cleared it up. Thanks!
    Good news folks
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •