Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: A Lot of software not working.

  1. #1
    Join Date
    Feb 2010
    Location
    Ohio
    Posts
    16

    Talking A Lot of software not working.

    Using OpenSuse 11.2 - much of the software I have installed via the install software program does not load. Several of the applications have question mark icons in the menu. Here is a short list of what claimed to have installed but when clicked on nothing happens. Zinf, Jokosher Audio Editor, Marlin sample editor, SoundRecEd Recorder (this one has a question mark icon and actually appears in the menu 2x), Skale Tracker, orDrumbox. There may be more but for sure , none of these apps run when I click them from the menu. I believe I added the packman repo when I was looking for an Audacity program that would be able to open an mp3 file. So some of this software could be coming from unofficial sources but I don't get how you could run the installer and it says the programs installed but then none of them run. Luckily, the apps that I use most often all do work - but I did want to experiment with some of these other tools.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,650

    Default Re: A Lot of software not working.

    Where are you getting these packages??

    RPMs packaged for Red Hat most likely will not work on Suse and visa versa. Things are in different places.

    If at all possible you should install from a Suse repository by the Yast-Software management program or zypper (CL)

    Id not then it should be installed from source.

    As to mp3 you need to follow the mulitmedia guid to install proprietary codecs

    Multi-media and Restricted Format Installation Guide - openSUSE Forums

  3. #3
    Join Date
    Feb 2010
    Location
    Ohio
    Posts
    16

    Cool Re: A Lot of software not working.

    I get the software through the Yast software install program. I have approx 9 different OpenSuse repositories for 11.2 - one repo for Nvidia and 2 repos from Packman. I pick the software from the choices that come up. Everything says it is fine but then a lot of them do not launch. The mp3 issue was solved when I removed the Audacity program that was from the OpenSuse repo and instead got the good one from Packman that actually opens mp3 files. I could encode to mp3 from the opensuse one but not open an mp3 file. That problem has been solved thanks to Packman. I just wonder why all this other software is not working. I can provide more information if needed. Let me know what to post.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,650

    Default Re: A Lot of software not working.

    There is your problem Repo madness.

    Too many repos. You are loading conflicting packages.

    Post

    zypper lr -d

  5. #5
    Join Date
    Feb 2010
    Location
    Ohio
    Posts
    16

    Cool Re: A Lot of software not working.

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+-------------------------------------+------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------------------+--------
    1 | Libdvdcss repository | Libdvdcss repository | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/11.2/ |
    2 | Packman | Packman repository (openSUSE_11.2) | Yes | No | 99 | rpm-md | Index of /pub/packman/suse/11.2 |
    3 | download.nvidia.com-opensuse | NVIDIA Repository | Yes | Yes | 99 | rpm-md | ftp://download.nvidia.com/opensuse/11.2/ |
    4 | download.opensuse.org-standard | Main Repository (Contrib) | Yes | Yes | 99 | rpm-md | Index of /repositories/openSUSE:/11.2:/Contrib/standard |
    5 | ftp.skynet.be-suse | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.2 |
    6 | http-download.opensuse.org-d63d1ae7 | Updates for openSUSE 11.2-0 | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |
    7 | openSUSE 11.2-0 | openSUSE 11.2-0 | Yes | No | 99 | yast2 | cd:/// |
    8 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
    9 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    10 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    11 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: A Lot of software not working.

    3 | download.nvidia.com-opensuse | NVIDIA Repository | Yes | Yes | 99 | rpm-md | ftp://download.nvidia.com/opensuse/11.2/ |
    4 | download.opensuse.org-standard | Main Repository (Contrib) | No | No | 99 | rpm-md | Index of /repositories/openSUSE:/11.2:/Contrib/standard |
    5 | ftp.skynet.be-suse | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.2 |
    6 | http-download.opensuse.org-d63d1ae7 | Updates for openSUSE 11.2-0 | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |
    7 | openSUSE 11.2-0 | openSUSE 11.2-0 | No | No | 99 | yast2 | cd:/// |
    8 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
    9 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    10 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    11 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
    Change to that
    Open a su terminal and do

    Code:
    zypper dup
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: A Lot of software not working.

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8
    Join Date
    Feb 2010
    Location
    Ohio
    Posts
    16

    Default Re: A Lot of software not working.

    Will this revert my Audacity program back to the one that does not open mp3 files? Also would it pay to do this zypper dup and also to follow the instructions on the Multi-media and restricted format installation guide? Or is it too late because I did not do that originally? If I were to do the zypper dup as well as follow the instructions in the guide which order would I proceed?

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: A Lot of software not working.

    Change the repos as I indicated

    Tell me what zypper dup reports before you commit to it
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: A Lot of software not working.

    Quote Originally Posted by morphx99mq View Post
    Using OpenSuse 11.2 - much of the software I have installed via the install software program does not load.
    I expect much is not most. But yes, can happen... open bug reports.

    Quote Originally Posted by morphx99mq View Post
    Several of the applications have question mark icons in the menu.
    I tried zinf. You don't see a real icon for it because... it doesn't specifies an icon.
    Others can have different problems... but this is a bug or something to enhance.

    Quote Originally Posted by morphx99mq View Post
    Here is a short list of what claimed to have installed but when clicked on nothing happens. Zinf, Jokosher Audio Editor, Marlin sample editor, SoundRecEd Recorder (this one has a question mark icon and actually appears in the menu 2x), Skale Tracker, orDrumbox. There may be more but for sure , none of these apps run when I click them from the menu.
    Zinf fails also to start, I can confirm that. The problem has nothing to do with the question mark icon, it's a new bug.
    Didn't test the others. You can run them from a terminal, perhaps this way you get more info about the problem. But anyway they can be simply bugs that nobody reported and so nobody fixed.
    Notice the latest version of Zinf (2.2.5) is from 2004... it's old and unmaintained. You should report the problem to Packman, but instead of fixing it they probably will just delete it from the repos. For a WinAmp-like player, nowadays people uses Audacious (GTK/Gnome) or Qmmp (Qt/KDE).

    Quote Originally Posted by morphx99mq View Post
    I believe I added the packman repo when I was looking for an Audacity program that would be able to open an mp3 file. So some of this software could be coming from unofficial sources but I don't get how you could run the installer and it says the programs installed but then none of them run.
    Yes, at least Zinf comes from Packman.
    At some point packagers start to maintain so many packages that they don't even test if they start. This isn't a problem. If nobody uses the software then its inability to start is a no problem. And if an user uses it, it's supposed he will inform the packager about the problem.
    The real problem is most users never inform the packager, and so the package is never fixed.
    To inform the packager use Submitting Bug Reports - openSUSE. And if it's a Packman package use the "Packager" links from its website (PackMan :: Package details for zinf).
    Sorry, no. A post in this forum most of the time will not arrive to the packager.

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •