Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Can't get mic to work

  1. #1

    Default Can't get mic to work

    I am trying to get my mic working for voice chat on DDo, but I have had no luck so far. I have a headset with a microphone on it, but I don't seem to be able to get it to record. the audio out put works though. Any ideas?

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,522
    Blog Entries
    37

    Default Re: Can't get mic to work

    Quote Originally Posted by hito_kiri View Post
    I am trying to get my mic working for voice chat on DDo, but I have had no luck so far. I have a headset with a microphone on it, but I don't seem to be able to get it to record. the audio out put works though. Any ideas?
    There is advice for configuring a mic here:
    Microphone - openSUSE
    in particular, when testing, use the program arecord from a terminal as follows:
    Code:
    arecord -vv -fdat foo.wav
    where "foo.wav" is an arbitrary name ... you could use instead "anyname.wav"

    You need to be precise and exact when setting up your mixer so that your mic will record. So please set your mixer up carefully.

    If you fail after trying the above, then we will need more information, in which case please set your mixer exactly how you think it should be set up, and then provide the information recommended to be provided in the 2nd half of the multimedia stickie : Welcome to multimedia sub-area - openSUSE Forums

    I quote:
    post in this .... providing in your post the following information:
    • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
      SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script /usr/sbin/alsa-info.sh and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL. Just the URL. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
    • in a terminal, or xterm, or konsole, type: rpm -qa '*alsa*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -qa '*pulse*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
    • in a terminal, or xterm, or konsole, type: uname -a #and post output here
    • for openSUSE-11.1 or earlier, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/sound #and post output here
    • for openSUSE-11.2 or later, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,650

    Default Re: Can't get mic to work

    Go to mixer make sure the microphone is captured, be sure capture is also capture. Note you may need to add that control go to settings and add the capture control and then that the capture box is checked.

  4. #4

    Default Re: Can't get mic to work

    O.k. I have been working on this more. I tried arecord and had no luck, the mic works though, as i tried it on another computer. Here are the outputs of the commands that are needed:

    1. http://www.alsa-project.org/db/?f=fd...d0c270c5fda6cc

    2. alsa-1.0.22-4.1
    java-1_6_0-sun-alsa-1.6.0.u18-0.1.1
    python-alsaaudio-0.5-0.pm.1.1
    alsa-firmware-1.0.20-10.1
    alsa-plugins-jack-32bit-1.0.22-4.5
    alsa-plugins-32bit-1.0.22-4.5
    alsa-plugins-1.0.22-4.5
    alsa-utils-1.0.21-8.2
    alsa-driver-kmp-default-1.0.22.1.20100304_2.6.27.45_0.1-3.1
    alsa-oss-32bit-1.0.17-52.1
    alsa-devel-1.0.22-4.1
    alsa-tools-1.0.22-2.1
    alsa-tools-gui-1.0.22-2.1
    alsa-plugins-jack-1.0.22-4.5
    alsa-oss-1.0.17-52.1

    3. libpulse0-0.9.14-2.2.1
    libpulse0-32bit-0.9.14-2.2.1

    4. libasound2-1.0.22-4.1

    5. Linux linux-eo5c 2.6.27.45-0.1-default #1 SMP 2010-02-22 16:49:47 +0100 x86_64 x86_64 x86_64 GNU/Linux

    6. alias snd-card-0 snd-intel8x0
    alias sound-slot-0 snd-intel8x0 ac97_quirk=alc_jack


    I hope this helps some.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,522
    Blog Entries
    37

    Default Re: Can't get mic to work

    Quote Originally Posted by hito_kiri View Post
    O.k. I have been working on this more. I tried arecord and had no luck, the mic works though, as i tried it on another computer. Here are the outputs of the commands that are needed:

    1. http://www.alsa-project.org/db/?f=fd...d0c270c5fda6cc
    Ok, I note a 64-bit openSUSE-11.1 with a 2.6.27.45-0.1-default kernel and an update to 1.0.22 of alsa with an ALC655 hardware audio codec on your pc.

    I did a search on the alsa web site to see if there were any updates relevant to the ALC655, and did not see any. I also searched in the ALSA documentation HD-Audio-Models.txt file if there were any entries for an ALC655 and I did not see any.

    Next, I looked at your PC's mixer settings (as documented by the diagnostic script), and I have some questions ...

    !!Amixer output
    !!-------------

    !!-------Mixer controls for card 0 [AMD8111]

    Card hw:0 'AMD8111'/'AMD AMD8111 with ALC655 at irq 17'
    Mixer name : 'Realtek ALC655 rev 0'
    Simple mixer control 'Line',0
    Front Left: Playback 0 [0%] [-34.50dB] [off] Capture [off]
    Front Right: Playback 0 [0%] [-34.50dB] [off] Capture [off]
    Simple mixer control 'Mic',0
    Mono: Playback 31 [100%] [12.00dB] [on]
    Front Left: Capture [on]
    Front Right: Capture [on]
    Simple mixer control 'Mic Boost ( 20dB)',0
    Mono: Playback [on]
    Simple mixer control 'Mic Select',0
    Items: 'Mic1' 'Mic2'
    Item0: 'Mic1'
    Simple mixer control 'IEC958',0
    Mono: Playback [on] Capture [off]
    Simple mixer control 'Aux',0
    Front Left: Playback 0 [0%] [-34.50dB] [off] Capture [off]
    Front Right: Playback 0 [0%] [-34.50dB] [off] Capture [off]
    Simple mixer control 'Mono Output Select',0
    Items: 'Mix' 'Mic'
    Item0: 'Mix'
    Simple mixer control 'Capture',0
    Front Left: Capture 15 [100%] [22.50dB] [on]
    Front Right: Capture 15 [100%] [22.50dB] [on]
    Simple mixer control 'Mix',0
    Front Left: Capture [off]
    Front Right: Capture [off]
    Simple mixer control 'Mix Mono',0
    Front Left: Capture [off]
    Front Right: Capture [off]
    Simple mixer control 'Channel Mode',0
    Items: '2ch' '4ch' '6ch'
    Item0: '2ch'
    Is this an external mic? Your PC appears to have two mic ports ... mic1 and mic2. Have you plugged the mic into the correct one? (you appear to have mic1 selected). There is a digital capture which may be applicable to an internal digital mic if this is a laptop and that is switched off. Is this a laptop ?

    You have various capture controls for the mixer OFF, ... please confirm they should be OFF. ..

    ... and finally when using arecord, I recommend this: Microphone - openSUSE
    which recommends
    Code:
    arecord -vv -fdat foo.wav
    where "foo.wav" is a file that will be recorded in the directory in which you were located at the command prompt of the terminal/konsole. The -vv option means the verbose output just like aplay, -fdat means 48kHz, 2-channel, 16bit format. It shows a VU-peak meter, so you will see usually what is being recorded. Push Ctrl-C to quit the recording; otherwise it'll continue endlessly. After finishing the recording, try to play back the file via aplay again.

    6. alias snd-card-0 snd-intel8x0
    alias sound-slot-0 snd-intel8x0 ac97_quirk=alc_jack
    Why do you have ac97_quirk=alc_jack selected ? Is that essential ? What happens if you remove it, reboot and test?

  6. #6

    Default Re: Can't get mic to work

    Is this an external mic? Your PC appears to have two mic ports ... mic1 and mic2. Have you plugged the mic into the correct one? (you appear to have mic1 selected). There is a digital capture which may be applicable to an internal digital mic if this is a laptop and that is switched off. Is this a laptop ?

    You have various capture controls for the mixer OFF, ... please confirm they should be OFF. ..
    It is not a laptop, I have a mic port on the front and rear and I have tried both. As to the captures being off, I have no idea. If I click on the mixer, I have front, surround, center, pcm,mic, mic boost, and capture. It looks like the mic and mic boost are currently muted, I don't know why I didn't set them that way, but I know during testing I made sure they weren't.

    I did arecord as you described before, it oddly picks up the static when i touch the mic cord, or when I plug it in, but not the voice (and I tried practically screeming in to it. Like I said though, it is not the mic itself as it worked on another computer just fine.

    Why do you have ac97_quirk=alc_jack selected ? Is that essential ? What happens if you remove it, reboot and test?
    I have no idea what that is, do you mean remove it from the config file?

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,522
    Blog Entries
    37

    Default Re: Can't get mic to work

    Quote Originally Posted by hito_kiri View Post
    As to the captures being off, I have no idea. If I click on the mixer, I have front, surround, center, pcm,mic, mic boost, and capture. It looks like the mic and mic boost are currently muted, I don't know why I didn't set them that way, but I know during testing I made sure they weren't.
    If your mixer is kmix, you can control the channels that are presented by going to kmix > settings > configure channels

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,522
    Blog Entries
    37

    Default Re: Can't get mic to work

    Quote Originally Posted by hito_kiri View Post
    I have no idea what that is, do you mean remove it from the config file?
    How did it get there ?

    What is the output of:
    Code:
    cat /etc/modprobe.d/50-sound.conf
    Do you see in that file "ac97_quirk=alc_jack" . Typically that has to be deliberately entered by someone in to the file. If you did not enter that, then I have to ask, how did it get there? Perhaps there is some automated process that is new to me ?

  9. #9
    JosephKK NNTP User

    Default Re: Can't get mic to work

    On Fri, 12 Mar 2010 01:26:01 GMT, hito kiri <hito_kiri@no-mx.forums.opensuse.org> wrote:

    >
    >> Is this an external mic? Your PC appears to have two mic ports ... mic1
    >> and mic2. Have you plugged the mic into the correct one? (you appear to
    >> have mic1 selected). There is a digital capture which may be applicable
    >> to an internal digital mic if this is a laptop and that is switched off.
    >> Is this a laptop ?
    >>
    >> You have various capture controls for the mixer OFF, ... please confirm
    >> they should be OFF. ..

    >
    >It is not a laptop, I have a mic port on the front and rear and I have
    >tried both. As to the captures being off, I have no idea. If I click
    >on the mixer, I have front, surround, center, pcm,mic, mic boost, and
    >capture. It looks like the mic and mic boost are currently muted, I
    >don't know why I didn't set them that way, but I know during testing I
    >made sure they weren't.
    >
    >I did arecord as you described before, it oddly picks up the static
    >when i touch the mic cord, or when I plug it in, but not the voice (and
    >I tried practically screeming in to it. Like I said though, it is not
    >the mic itself as it worked on another computer just fine.
    >
    >> Why do you have ac97_quirk=alc_jack selected ? Is that essential ? What
    >> happens if you remove it, reboot and test?

    >
    >I have no idea what that is, do you mean remove it from the config
    >file?


    Being mainly a hardware guy, i will ask: What size in your microphone
    plug and the corresponding jacks you are using? It sounds like you
    have a microphone with a 1/10" (2.5 mm) plug plugged into 1/8" (3.5 mm)
    jacks. Adapters are available, though they may not be easy to find.

  10. #10

    Default Re: Can't get mic to work

    If your mixer is kmix, you can control the channels that are presented by going to kmix > settings > configure channels
    Do I need any more channels, I would really like to not have anymore than I have to.

    Quote:
    Originally Posted by hito_kiri View Post
    I have no idea what that is, do you mean remove it from the config file?
    How did it get there ?

    What is the output of:
    Code:

    cat /etc/modprobe.d/50-sound.conf

    Do you see in that file "ac97_quirk=alc_jack" . Typically that has to be deliberately entered by someone in to the file. If you did not enter that, then I have to ask, how did it get there? Perhaps there is some automated process that is new to me ?
    I have no idea how it got there, I don't remember modifying anything. I also don't have the 50-sound.conf file, I have sound and sound~, but here are the outputs of both of them:

    cat /etc/modprobe.d/sound
    alias snd-card-0 snd-intel8x0
    alias sound-slot-0 snd-intel8x0 ac97_quirk=alc_jack

    cat /etc/modprobe.d/sound~
    alias snd-card-0 snd-intel8x0
    alias sound-slot-0 snd-intel8x0
    ac97_quirk=alc_jack


    Being mainly a hardware guy, i will ask: What size in your microphone
    plug and the corresponding jacks you are using? It sounds like you
    have a microphone with a 1/10" (2.5 mm) plug plugged into 1/8" (3.5 mm)
    jacks. Adapters are available, though they may not be easy to find.
    No it is a 3.5mm.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •