Results 1 to 3 of 3

Thread: Emacs Color Themes

  1. #1

    Default Emacs Color Themes

    Does anybody here use the color theme plugin with GNU emacs? I put the files (color-theme.el and the themes folder) in my load path and everything appears to work, but many of the themes don't display correctly.

    On those that fail, only the portions of the buffer which actually contain text are themed, the rest is just plain white. This is particularly noticeable when using a dark background, as I tend to do. If this isn't a good enough description, I can attach a picture.

    Just as an example: charcoal-black works perfectly while dark-laptop fails as described.

    This problem seems to be unique to openSUSE as the plugin works okay on the Red Hat machines I use at school.

    Any ideas?

  2. #2

    Default Re: Emacs Color Themes

    Hello karljs,

    Welcome to the community. I see it's you first post.
    And I'm very sorry for the late response.
    Does anybody here use the color theme plugin with GNU emacs?
    No, I don't use emacs at all.
    I put the files (color-theme.el and the themes folder) in my load path and everything appears to work, but many of the themes don't display correctly.
    Can you give us a link to those files.

    And can you please tell us which version of Emacs and openSUSE you have.

    Best of luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  3. #3

    Default [solved] Re: Emacs Color Themes

    Thanks, better late than never!

    I have actually solved this problem myself in the meantime. The problem was a conflict between the themes and the default font settings I had changed through Emacs.

    In case anybody else comes along and sees this, I advise NOT using the customize settings from the menu. Just changing the default font caused a whole bunch of settings to be written to my .emacs file, including some which try to designate font foreground and background colors.

    If you want to change your font and use color themes harmoniously, just put a one liner into your .emacs file like
    (set-default-font "<font>")

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •