Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Boxee on 11.2?

  1. #1
    Join Date
    Nov 2009
    Location
    Dallas, Texas, USA
    Posts
    55

    Default Boxee on 11.2?

    I'm in love with my Opensuse 11.2. Love my KDE 4.4. The only thing I miss from my Ubuntu installation, is the ability to use Boxee.

    I would be more than willing to compile Boxee from source. I only have 2 problems with that:

    1) I don't know where I can find all the build-deps or what they are for that matter to build Boxee.

    2) I'm running on a Netbook. Yes, my measly Intel Atom is no fun for compiling and building.

    What are my options/what can I do to get Boxee up and running on 11.2? I've tried searching on build service for an RPM, but I think due to legal restrictions, Boxee can't be on there.

  2. #2
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Boxee on 11.2?

    Boxee seems to contain closed code, at least I don't see any source available. How about checking an alternative, for example →Moovida, →MythTV or →Freevo? All of them are available via Packman.

  3. #3
    Join Date
    Nov 2009
    Location
    Dallas, Texas, USA
    Posts
    55

    Default Re: Boxee on 11.2?

    What do you mean? The source code is right here: http://dl.boxee.tv/boxee-sources-0.9.20.10711.tar.bz2

  4. #4
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Boxee on 11.2?

    Oh pardon me for relying on the Boxee-site, which did not offer a source but only binaries. Besides, that source is not of much help for you, is it?

    1) I don't know where I can find all the build-deps or what they are for that matter to build Boxee.

    2) I'm running on a Netbook. Yes, my measly Intel Atom is no fun for compiling and building.
    ...and since a precompiled Boxee does not exist (as you found out already)... um, what was your question again?

  5. #5
    Join Date
    Nov 2009
    Location
    Dallas, Texas, USA
    Posts
    55

    Default Re: Boxee on 11.2?

    Quote Originally Posted by gropiuskalle View Post
    Oh pardon me for relying on the Boxee-site, which did not offer a source but only binaries. Besides, that source is not of much help for you, is it?



    ...and since a precompiled Boxee does not exist (as you found out already)... um, what was your question again?
    My question is how do I go about finding out the build-deps I'll need in order to build Boxee.

  6. #6
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Boxee on 11.2?

    So you *do* want to compile it... kaykay.

    Look for a file called "README.linux", all dependencies are listed there.

  7. #7
    Join Date
    Nov 2009
    Location
    Dallas, Texas, USA
    Posts
    55

    Default Re: Boxee on 11.2?

    Quote Originally Posted by gropiuskalle View Post
    So you *do* want to compile it... kaykay.

    Look for a file called "README.linux", all dependencies are listed there.
    Okay, I'll look into that. Thanks for the info.

    I hope to get this thing working so I can do a write up on how to get Boxee running on Opensuse (here's looking at you Ubuntu...)

  8. #8
    Join Date
    Jun 2008
    Posts
    1,825
    Blog Entries
    1

    Default Re: Boxee on 11.2?

    Quote Originally Posted by isaacj87 View Post
    Okay, I'll look into that. Thanks for the info.

    I hope to get this thing working so I can do a write up on how to get Boxee running on Opensuse (here's looking at you Ubuntu...)
    Keep in mind, the libs might be named something slightly differently. Don't be afraid to search using this Software.openSUSE.org
    ______________________________________________________________________________________
    Don't ask "if" something can be done, for it can always be done. Rather instead ask "How" can it be done.

  9. #9
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Boxee on 11.2?

    If you want packages built, ask me. I'll either do it, or get someone else to. If they are not already built.
    Hmmm... usually signatures are off-topic, but in this case...

  10. #10
    Join Date
    Jun 2008
    Posts
    1,825
    Blog Entries
    1

    Default Re: Boxee on 11.2?

    This would be no easy feat. I might have to apply several patches, just to get it working. This is going to take me some time. If anyone else wants to jump in, then we can collaborate together on it.

    The deps are as follows.
    Code:
    Build-Depends: debhelper (>= 7.0.50), quilt, python-support, cmake,
     autotools-dev, autoconf, automake, unzip, libboost-dev,
     libgl1-mesa-dev | libgl-dev, libglu-dev, libglew-dev, libmad0-dev, libjpeg-dev,
     libsamplerate-dev, libogg-dev, libvorbis-dev, libfreetype6-dev,
     libfontconfig-dev, libbz2-dev, libfribidi-dev, libsqlite3-dev,
     libmysqlclient-dev, libasound-dev, libpng-dev, libpcre3-dev, liblzo2-dev,
     libcdio-dev, libsdl-dev, libsdl-image1.2-dev, libsdl-mixer1.2-dev, libenca-dev,
     libjasper-dev, libxt-dev, libxtst-dev, libxmu-dev, libxinerama-dev, libcurl3,
     libcurl4-gnutls-dev | libcurl-dev, libdbus-1-dev, libhal-storage-dev,
     libhal-dev, libpulse-dev, libavahi-common-dev, libavahi-client-dev,
     libxrandr-dev, libavcodec-dev, libavformat-dev, libavutil-dev, libpostproc-dev,
     libswscale-dev, liba52-dev, libdts-dev, libfaad-dev, libmp4ff-dev,
     libmpeg2-4-dev, libass-dev, libflac-dev, libwavpack-dev,
     python-dev, gawk, gperf, nasm [!amd64], libcwiid1-dev, libbluetooth-dev,
     zlib1g-dev, libmms-dev, libsmbclient-dev, libtiff4-dev
    ______________________________________________________________________________________
    Don't ask "if" something can be done, for it can always be done. Rather instead ask "How" can it be done.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •