Results 1 to 5 of 5

Thread: Wine installed, not running

  1. #1
    Join Date
    Feb 2010
    Location
    Belgium
    Posts
    2

    Default Wine installed, not running

    Hi all,

    Being newly converted here from ubuntu i've still got get used to yast-things and rpm-stuff but i'll try my best. I am running 11.2 Gnome, all updates finished. I used the live-CD to install and do not have the DVD iso available. It's also in dutch locale so i might miss sometimes in the exact english menu names.


    I installed wine through yast (i think), anyways with the "add software" thing.
    It installed both wine and wine-gecko according to "software management". It doesnt add itself in the gnome-menu (nor in the suse-edited menu labeled computer) and when looking in my homefolder, the directory /.wine isnt created.
    I tried to install it again, this time using a one click install but that didnt change anything...

    Any ideas?
    All help greatly appreciated.

  2. #2
    Join Date
    Aug 2009
    Location
    United States
    Posts
    288

    Default Re: Wine installed, not running

    you might want to take a look at this post Where is my WINE - openSUSE Forums
    Allen Howard
    Comptia A+, Network+, CCENT, and IT for Sales Certified Technician
    ____________________________________________________

  3. #3
    Join Date
    Feb 2010
    Location
    Belgium
    Posts
    2

    Default Re: Wine installed, not running

    tx for the reply.

    Running it by command with "wine" seems to work, however it doesn't show as installed apps... and i'm not too fond of playonlinux.

    Still an issue the suse devs should look into.

    Anyways, i'm up & running

  4. #4

    Default Re: Wine installed, not running

    Just edit the menu by right clicking on the launcher and select "menu editor". You can place new items in the wine Programs submenu or anywhere else. I know it is annoying, but you only have to do it once for each program, and IIRC the folders are even created there when wine installs something, just not the actual program links.

    Once you run wine for the first time it will create and configure the wineprefix (defaults to ~/.wine). It also automatically updates the wineprefix when a new version of wine is run too.

    Edit: oops, skipped right over that Gnome part. I run KDE, so I don't know how applicable my menu editing directions will be. Surely Gnome offers similar functionality though?
    Last edited by poorboywilly; 17-Feb-2010 at 16:38. Reason: more info

  5. #5
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Wine installed, not running

    Hei,

    If you want to run wine itself just type winefile. Run winecfg to configure various settings, hardware, directories etc. It is probably easy to add winefile as an entry in the menu manually as well, I am on KDE and do not know Gnome. If you want to install any programmes or games just click on the .exe file directly (you probably know this) from your linux environment and choose 'open with > wine', after the installation the program/game will probably have its own entry in the Gnome menu. And, thus, you don't have to open wine to run the selected application.

    This is how I do it in KDE, anyway.


    Cheers,
    Olav

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •