Results 1 to 6 of 6

Thread: cant get compiz to work

  1. #1
    Join Date
    Feb 2010
    Location
    catalonia
    Posts
    19

    Default cant get compiz to work

    Hello community,

    I have just installed compiz through the YaST2 software manager. It all downloaded and installed OK as I can see it in the Kickoff Application Launcher. But although I have set the configuration for cube rotate, when I point and click to different desktops on the task bar, the switch is without rotation.

    Any ideas?

    Thanks

    Yan

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: cant get compiz to work

    Please, you need to provide more information:
    a. what desktop ? xfce ? kde ? gnome ?
    b. what graphic hardware (be specific) !!
    c. what graphic driver !!
    d. what openSUSE version ?

    I believe that only with that, will you be able to get a reasonable help suggestion from our community.

    Good luck and best wishes with your efforts.

  3. #3
    Join Date
    Feb 2010
    Location
    catalonia
    Posts
    19

    Default Re: cant get compiz to work

    Hi Old CPU

    To answer your questions:

    -) Desktop : is KDE 4
    -) Graphic Hardware : Mobile 915GM/GMS/910GML Express Graphics Controller
    -) Graphic Driver : xorg-x11-driver-video
    -) opensuse 11.2

    Thanks for any help

    Yan

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: cant get compiz to work

    Quote Originally Posted by yanvolking View Post
    To answer your questions:

    -) Desktop : is KDE 4
    -) Graphic Hardware : Mobile 915GM/GMS/910GML Express Graphics Controller
    -) Graphic Driver : xorg-x11-driver-video
    -) opensuse 11.2
    xorg-x11-driver-video is the rpm that contains the Intel and many other graphic drivers. Its not the actual driver. Do you know if it is using the VESA or the Intel graphic driver in use ?

    If you have the Intel driver in use, then assuming everything is configured correctly (which it is by default) there is not much you can do, other than perhaps try a custom xorg.conf file or try a cutting edge mesa and cutting edge xorg-x11-driver-video. If you have the vesa driver in use, then you could switch to using the Intel driver.

    Do you have an /etc/X11/xorg.conf file ? openSUSE-11.2 does not need that file for many hardware devices but it has been known to fail to configure the hardware device properly in some cases.

    If you look in the /var/log/Xorg.0.log file, you should be able to tell if your PC is using the Vesa or Intel driver by entries such as (==) Intel (**) Intel or (==) Vesa (**) Vesa

    There is some practical guidance here to better understand the driver that is available: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

  5. #5
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: cant get compiz to work

    Hi,

    Perhaps this how-to from our extensive collections of how-to's can help:

    Installing and Configuring Compiz - openSUSE Forums

    If you have any questions after following that, feel free to ask here.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,742

    Default Re: cant get compiz to work

    compiz is not needed in KDE4!!! It uses kwin4.

    I have the cube, wiggly windows, what ever and NO compiz. More eye candy then I can stand.

    Best to uninstall it it will just give you problems.

    Personal setting - Desktop the All effects tab. Select your poison.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •