Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Trouble Updating Java Help

  1. #1

    Default Trouble Updating Java Help

    Hoping somebody can help me here.

    Firefox 3.5.7
    SuSE 11.2 64bit
    Current Java Version 1.6.0_0

    The latest version is 6.0_18

    Followed instructions for a number of different ways of getting Java updated and i've failed miserably.

    Can somebody please help me get Java updates installed.

    Mark

  2. #2
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Trouble Updating Java Help

    Quote Originally Posted by akwe-xavante View Post
    Hoping somebody can help me here.

    Firefox 3.5.7
    SuSE 11.2 64bit
    Current Java Version 1.6.0_0

    The latest version is 6.0_18

    Followed instructions for a number of different ways of getting Java updated and i've failed miserably.

    Can somebody please help me get Java updates installed.

    Mark
    Hi!
    I've just installed the 11.2 and I haven't added any extra repositories just installed the java-1_6_0-sun package.
    Please post here the output of:
    Code:
    zypper lr
    Code:
    zypper info java-1_6_0-sun
    .
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  3. #3

    Default Re: Trouble Updating Java Help

    Output as asked below and thank you for your reply and help.

    reason for wanting to update Java is because i'm getting websites asking me to either enable Java or update it. Java is enabled but not upto date though.


    devilsbackbone:/usr/java/jre1.6.0_18/bin # zypper lr
    # | Alias | Name | Enabled | Refresh
    --+-------------------------------------+---------------------------------------------+---------+--------
    1 | download.opensuse.org-webcam | openSUSE BuildService - Drivers for webcams | Yes | Yes
    2 | ftp.skynet.be-suse | Packman Repository | Yes | Yes
    3 | home:Lord_LT | home:Lord_LT | Yes | Yes
    4 | http-download.opensuse.org-41fe85e0 | Updates for openSUSE 11.2-0 | Yes | Yes
    5 | openSUSE 11.2-0 | openSUSE 11.2-0 | Yes | No
    6 | repo-debug | openSUSE-11.2-Debug | No | Yes
    7 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes
    8 | repo-oss | openSUSE-11.2-Oss | Yes | Yes
    9 | repo-source | openSUSE-11.2-Source | No | Yes
    You have new mail in /var/spool/mail/??????????????????
    devilsbackbone:/usr/java/jre1.6.0_18/bin # zypper info java-1_6_0-sun
    Retrieving repository 'Packman Repository' metadata [done]
    Building repository 'Packman Repository' cache [done]
    Retrieving repository 'Updates for openSUSE 11.2-0' metadata [done]
    Building repository 'Updates for openSUSE 11.2-0' cache [done]
    Loading repository data...
    Reading installed packages...


    Information for package java-1_6_0-sun:

    Repository: Updates for openSUSE 11.2-0
    Name: java-1_6_0-sun
    Version: 1.6.0.u18-0.1.1
    Arch: x86_64
    Vendor: openSUSE
    Installed: No
    Status: not installed
    Installed Size: 87.2 MiB
    Summary: Java(TM) 6 Runtime Environment
    Description:
    ile system. It is the foundation of the
    Nautilus file manager. It provides a modular architecture and ships
    with several modules that implement support for file systems, HTTP,
    FTP, and others. It provides a URI-based API, a back-end supporting
    asynchronous file operations, a MIME type manipulation library, and
    other features.

  4. #4

    Default Re: Trouble Updating Java Help

    Noticed the line: Not installed but i have followed the instructions on the Java website at the end of which it returns the message Done as it's supposed to and thats supposed to do it!?

    It clearly hasn't installed but i'm totally lost as to what to do next.

  5. #5
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Trouble Updating Java Help

    Quote Originally Posted by akwe-xavante View Post
    Noticed the line: Not installed but i have followed the instructions on the Java website at the end of which it returns the message Done as it's supposed to and thats supposed to do it!?

    It clearly hasn't installed but i'm totally lost as to what to do next.
    zypper claims that the java-1_6_0-sun package isn't installed. It's possible that you have missed something in that tutorials. So simply install it:
    Code:
    sudo zypper in java-1_6_0-sun
    .
    *sudo requires your root password*
    Good luck.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  6. #6

    Default Re: Trouble Updating Java Help

    Thank you. Java is now installed but i am still getting the messages:

    Enable Java or update Java and Java is out of date because the Java website tells me it's out of date:

    Verifying Java Version
    Oops! You don't have the recommended Java installed.
    Your Java version is 1.6.0_0. Please click the button below to get the recommended Java for your computer.

    NOTE: If you recently completed your Java software installation, you may need to restart your browser (close all browser windows and re-open) before verifying your installation.
    Download Free Java for Linux

    Version 6 Update 18


    I have closed all browser windows and i still get the same messages saying i need to enable Java or Update it but the Java website says its enabled and out of date.

  7. #7
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Trouble Updating Java Help

    Ow, I've missed something.
    Maybe there is no browser-plugin installed for java generally.
    Try this in terminal:
    Code:
    zypper se java-1_6_0-sun-plugin
    . My guess is that this package isn't installed.
    Installing this one should solve your problem.
    Code:
    sudo zypper in java-1_6_0-sun-plugin
    Hope that helps.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  8. #8

    Default Re: Trouble Updating Java Help

    Thank you for your replies.

    I'm still having trouble, a couple of websites i use are giving me grief. Other websites requiring Java are working a treat as usual but all of a sudden two of them are telling me i need Java updating or enabling.

    In the process of updating Java it looks as though i disabled or messed Java up. But now its all working again accept these two websites i use. They still ask me to either enable or update java.

    Java is now installed and enable and working but it is still out of date though.

    These two websites are working fine from a Win7 computer with Java up to date.

    So for now i'll use a Windows Computer until SuSE updates Java automatically at some point over the next few days, weeks!

    I have contacted these two companies about the problem, there response was "We don't support Linux and or Firefox" But there websites were working on Linux using Firefox until Friday of last week! I don't have an alternative company to use for the services they provide me.

    Hey Ho!

    My Dreams of moving over to SuSE Linux completely are scuppered once again, never mind.

    Mark

  9. #9
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Trouble Updating Java Help

    Quote Originally Posted by akwe-xavante View Post
    Thank you for your replies.

    I'm still having trouble, a couple of websites i use are giving me grief. Other websites requiring Java are working a treat as usual but all of a sudden two of them are telling me i need Java updating or enabling.
    So, if the websites with Java requirement are working successfully, that means you have installed the Java browser-plugin successfully.
    Quote Originally Posted by akwe-xavante View Post
    In the process of updating Java it looks as though i disabled or messed Java up. But now its all working again accept these two websites i use. They still ask me to either enable or update java.

    Java is now installed and enable and working but it is still out of date though.
    Java isn't disabled - as you mentioned above *some* websites are working.
    Java is up-to-date - you can prove it with
    Code:
    zypper info java-1_6_0-sun
    .
    I assume that you have installed the Java browser-plugin as I suggested in my previous post.
    Make sure that the plugin isn't disabled. Open Firefox > Tools > Add-ons > Plugins > Java (TM) Plugin .....
    Quote Originally Posted by akwe-xavante View Post
    These two websites are working fine from a Win7 computer with Java up to date.

    So for now i'll use a Windows Computer until SuSE updates Java automatically at some point over the next few days, weeks!

    I have contacted these two companies about the problem, there response was "We don't support Linux and or Firefox" But there websites were working on Linux using Firefox until Friday of last week! I don't have an alternative company to use for the services they provide me.

    Hey Ho!

    My Dreams of moving over to SuSE Linux completely are scuppered once again, never mind.

    Mark
    Regarding to the response of these companies, it's possible that they are no longer supporting Linux/Firefox - I haven't figured out yet what's that supposed to mean Linux AND OR Firefox.
    You can freely move over to openSUSE. Download Virtualbox from the repositories and install Windows and Java to your virtualized PC.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  10. #10

    Default Re: Trouble Updating Java Help

    Thank you for your continued support and help.

    If I / you hop over to Verify Java Version

    and click on "Verify Java Version" i'm told that my version of Java is out of date and i need to update it. I did this because all of a sudden without warning i could no longer use two web services that require Java installed and enabled for.

    This is where i then messed things up by following instructions to update Java by downloading Linux 64bit java and installing it from the Java website.

    Things went wrong.

    I now have Java back and enabled thanks to your help but my problem continues. The Java website continues to inform me that my current version is out of date and the two websites that i'm having a problem with tell me i need to enable Java or update it.

    Other websites that require Java are working without issues so far.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •