Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: Miro troubles

  1. #1

    Default Miro troubles

    Hi,

    This is what I get when I run miro:

    ERROR:dbus.proxies:Introspect error on :1.4:/org/participatoryculture/dtv/OneTime: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

    /usr/bin/miro: line 27: 19974 Segmentation fault MOZILLA_FIVE_HOME=/usr/lib/xulrunner-1.9.1 LD_LIBRARY_PATH=/usr/lib/xulrunner-1.9.1 miro.real "$@"



    Please help.

    Thanks in advance

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: Miro troubles

    What version of FFox?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Miro troubles

    Its 3.5.4

    If it helps, I have just updated to KDE 4.4 and after updating, tried to install Miro from Yast first and, when it didnt work, tried to install from one-click

  4. #4
    palladium NNTP User

    Default Re: Miro troubles

    Newzer85 wrote:
    > Hi,
    >
    > This is what I get when I run miro:
    >
    > ERROR:dbus.proxies:Introspect error on
    > :1.4:/org/participatoryculture/dtv/OneTime:


    it is always good to try a google on the error, have a look:
    http://www.google.com/search?q=miro+linux+"dbus.proxies%3AIntrospect+error+on"


    <snip>

    > Possible causes include:


    > the remote application did not send a reply


    > the message bus security policy blocked the reply,


    > the reply timeout expired,


    > or the network connection was broken.


    which of those four things do you think happened, and why?

    are you sure the remote application is alive?

    have you installed or changed the setup of your system's security
    (AppArmor, or whatever)?

    is your network healthy?

    i installed Miro *months* ago and have so far found the downloads to
    be excruciatingly slow!! so much so that i used it so little i forgot
    i had it, or why i hadn't used it..

    i just NOW clicked it to life and tried to watch a video...minutes
    later it had 44 minutes of download time on a "The Basics of Miro"
    video, the SAME five minute video i can watch at
    http://www.getmiro.com/ without waiting..

    so, good luck!

    is there a Miro forum? you might need to be there..

    --
    palladium

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: Miro troubles

    Better post result of:

    Code:
    zypper lr -d
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: Miro troubles

    I did google it only to find everything that was suggested right in order. As for the error, I am a non-technical person so I am not really sure but I think its the first one "
    > the remote application did not send a reply"
    because the message came after a long time since I entered the command.The netrwork was working which I had checked when I got the message.

    About Miro : Well, I am a bit of a software junkie. That combined with my love for TV got me interested in Miro. Currently I use feed in my torrent application (qbittorrent in case you are interested) to donwload the TV episodes.

  7. #7

    Default Re: Miro troubles

    Sorry for late reply, I didnt have my system with me when I got your message

    Here's the result for my zypper command :

    zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+---------------------------------+--------------------------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------------------+--------
    1 | download.opensuse.org-Community | openSUSE BuildService - KDE:KDE4:Community | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.2 |
    2 | download.opensuse.org-non-oss | Main Repository (NON-OSS) | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    3 | download.opensuse.org-oss | Main Repository (OSS) | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    4 | ftp.skynet.be-suse | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.2 |
    5 | openSUSE:Factory:Contrib | openSUSE:Factory:Contrib | Yes | Yes | 99 | rpm-md | Index of /repositories/openSUSE:/Factory:/Contrib/openSUSE_11.2 |
    6 | openSUSE_11.2 | openSUSE_11.2 | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.2 |
    7 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
    8 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    9 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    10 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
    11 | repo-update | openSUSE-11.2-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.2


    Thanks

  8. #8

    Default Re: Miro troubles

    Sorry for late reply, I didnt have my system with me when I got your message

    Here's the result for my zypper command :

    zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+---------------------------------+--------------------------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------------------+--------
    1 | download.opensuse.org-Community | openSUSE BuildService - KDE:KDE4:Community | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.2 |
    2 | download.opensuse.org-non-oss | Main Repository (NON-OSS) | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    3 | download.opensuse.org-oss | Main Repository (OSS) | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    4 | ftp.skynet.be-suse | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.2 |
    5 | openSUSE:Factory:Contrib | openSUSE:Factory:Contrib | Yes | Yes | 99 | rpm-md | Index of /repositories/openSUSE:/Factory:/Contrib/openSUSE_11.2 |
    6 | openSUSE_11.2 | openSUSE_11.2 | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.2 |
    7 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
    8 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    9 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    10 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
    11 | repo-update | openSUSE-11.2-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.2


    Thanks

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: Miro troubles

    I'm not sure of the value of repo #5? I would remove it unless you know why it's there and know how to manage it

    Repo #1 does not match it's counterpart repo #6
    Assuming you have repo #6 to get kde4.4?

    The correct repo is
    Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.2_KDE4_Factory_Desktop

    You must use the switcher on the kde4 repos. Like this:
    ImageBam - Fast, Free Image Hosting and Photo Sharing

    And finally on Packman:
    http://tinyurl.com/yejwull

    Once you have done that, we can work on the issue if it remains.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: Miro troubles

    I think it has improved, still not working though. I got this error message:
    Image - TinyPic - Free Image Hosting, Photo Sharing & Video Hosting

    I guess this means I have to delete some files from my / folder right?

    This is the current status of my hard disk:
    Image - TinyPic - Free Image Hosting, Photo Sharing & Video Hosting

    Also the message I get when I enter miro in terminal:
    PyNotify support disabled on your platform.
    2010-02-16 06:58:49,870 INFO Starting up Miro
    2010-02-16 06:58:49,874 INFO Version: 2.5.4
    2010-02-16 06:58:49,883 INFO OS: Linux 2.6.31.5-0.1-default i686
    2010-02-16 06:58:49,884 INFO Revision: ssh://wguaraldi@pcf1.pculture.org/var/git/miro - 1e20db82
    2010-02-16 06:58:49,885 INFO Builder: abuild@eckhaus
    2010-02-16 06:58:49,885 INFO Build Time: 1266063667.35
    2010-02-16 06:58:49,886 INFO Starting event loop thread
    2010-02-16 06:58:49,887 INFO Restoring database...
    2010-02-16 06:58:49,888 INFO Python version: 2.6.2 (r262:71600, Oct 24 2009, 03:16:31)
    [GCC 4.4.1 [gcc-4_4-branch revision 150839]]
    2010-02-16 06:58:49,889 INFO Sqlite3 version: 3.6.16
    2010-02-16 06:58:49,889 INFO Gtk+ version: (2, 18, 1)
    2010-02-16 06:58:49,890 INFO Pysqlite version: 2.4.1
    2010-02-16 06:58:49,890 INFO PyGObject version: (2, 20, 0)
    2010-02-16 06:58:49,891 INFO opening database /home/archish/.miro/sqlitedb
    2010-02-16 06:58:49,891 INFO PyGtk version: (2, 16, 0)
    2010-02-16 06:58:49,892 INFO Language: [('LANG', 'en_US.UTF-8')]
    2010-02-16 06:58:49,894 INFO set_renderer: trying to add gstreamerrenderer
    2010-02-16 06:58:49,895 ERROR OperationalError when upgrading database: no such table: dtv_variables
    Traceback (most recent call last):
    File "/usr/lib/python2.6/site-packages/miro/storedatabase.py", line 178, in upgrade_database
    self._upgrade_database()
    File "/usr/lib/python2.6/site-packages/miro/storedatabase.py", line 210, in _upgrade_database
    current_version = self._get_variable(VERSION_KEY)
    File "/usr/lib/python2.6/site-packages/miro/storedatabase.py", line 258, in _get_variable
    "WHERE name=?", (name,))
    OperationalError: no such table: dtv_variables
    2010-02-16 06:58:49,920 INFO GStreamer version: GStreamer 0.10.26
    2010-02-16 06:58:49,929 INFO gstreamerrenderer: ElementNotFoundError 'gconfaudiosink'
    2010-02-16 06:58:49,930 INFO set_renderer: couldn't load gstreamerrenderer: Traceback (most recent call last):
    File "/usr/lib/python2.6/site-packages/miro/plat/renderers/__init__.py", line 45, in set_renderer
    app.video_renderer = module.VideoRenderer()
    File "/usr/lib/python2.6/site-packages/miro/plat/renderers/gstreamerrenderer.py", line 259, in __init__
    Renderer.__init__(self)
    File "/usr/lib/python2.6/site-packages/miro/plat/renderers/gstreamerrenderer.py", line 139, in __init__
    self.audiosink = gst.element_factory_make(audiosink, "sink")
    ElementNotFoundError: autoaudiosink

    2010-02-16 06:58:49,931 ERROR init_renderer: error detected... trying to use gstreamerrenderer
    Traceback (most recent call last):
    File "/usr/lib/python2.6/site-packages/miro/plat/renderers/__init__.py", line 67, in init_renderer
    set_renderer("%srenderer" % r)
    File "/usr/lib/python2.6/site-packages/miro/plat/renderers/__init__.py", line 45, in set_renderer
    app.video_renderer = module.VideoRenderer()
    File "/usr/lib/python2.6/site-packages/miro/plat/renderers/gstreamerrenderer.py", line 259, in __init__
    Renderer.__init__(self)
    File "/usr/lib/python2.6/site-packages/miro/plat/renderers/gstreamerrenderer.py", line 139, in __init__
    self.audiosink = gst.element_factory_make(audiosink, "sink")
    ElementNotFoundError: autoaudiosink
    2010-02-16 06:58:49,931 INFO set_renderer: trying to add gstreamerrenderer
    2010-02-16 06:58:49,932 INFO GStreamer version: GStreamer 0.10.26
    2010-02-16 06:58:49,932 INFO gstreamerrenderer: ElementNotFoundError 'gconfaudiosink'
    2010-02-16 06:58:49,933 INFO set_renderer: couldn't load gstreamerrenderer: Traceback (most recent call last):
    File "/usr/lib/python2.6/site-packages/miro/plat/renderers/__init__.py", line 45, in set_renderer
    app.video_renderer = module.VideoRenderer()
    File "/usr/lib/python2.6/site-packages/miro/plat/renderers/gstreamerrenderer.py", line 259, in __init__
    Renderer.__init__(self)
    File "/usr/lib/python2.6/site-packages/miro/plat/renderers/gstreamerrenderer.py", line 139, in __init__
    self.audiosink = gst.element_factory_make(audiosink, "sink")
    ElementNotFoundError: autoaudiosink

    2010-02-16 06:58:49,933 ERROR init_renderer: no valid renderer has been loaded
    Traceback (most recent call last):
    File "/usr/lib/python2.6/site-packages/miro/plat/renderers/__init__.py", line 74, in init_renderer
    set_renderer("gstreamerrenderer")
    File "/usr/lib/python2.6/site-packages/miro/plat/renderers/__init__.py", line 45, in set_renderer
    app.video_renderer = module.VideoRenderer()
    File "/usr/lib/python2.6/site-packages/miro/plat/renderers/gstreamerrenderer.py", line 259, in __init__
    Renderer.__init__(self)
    File "/usr/lib/python2.6/site-packages/miro/plat/renderers/gstreamerrenderer.py", line 139, in __init__
    self.audiosink = gst.element_factory_make(audiosink, "sink")
    ElementNotFoundError: autoaudiosink
    2010-02-16 06:58:51,616 INFO Shutting down Downloader...
    2010-02-16 06:58:51,617 INFO Shutting down event loop
    2010-02-16 06:58:51,619 INFO Closing Database...
    2010-02-16 06:58:51,620 INFO closing database
    2010-02-16 06:58:51,620 INFO Vacuuming the db before shutting down.
    2010-02-16 06:58:51,705 INFO Shutting down...
    2010-02-16 06:58:51,706 INFO Saving preferences...
    2010-02-16 06:58:51,706 INFO Shutting down icon cache updates
    2010-02-16 06:58:51,706 INFO Shutting down movie data updates
    2010-02-16 06:58:51,707 INFO Done shutting down.
    2010-02-16 06:58:51,707 INFO Remaining threads are:
    2010-02-16 06:58:51,707 INFO <_MainThread(MainThread, started -1219197248)>

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •