Results 1 to 5 of 5

Thread: Problem with Stardict Pronunciation

  1. #1

    Default Problem with Stardict Pronunciation

    For activating human pronunciation I always install WyabdcRealPeopleTTS in stardict; but normally that feature doesn't work in Gnome and I should go to sound section and check "Use TTS Program" and write "aplay %s" in Commandline till human pronunciation works but in openSUSE 11.2 (KDE) these methods don't work. I install QStardict in openSUSE and use this method and it works in QStardit but not in Stardict. I prefer stardict and looking for a way for activating it in stardict. Can anyone help me?

  2. #2
    Join Date
    Jun 2008
    Location
    Taichung city,Taiwan
    Posts
    115

    Default Re: Problem with Stardict Pronunciation

    Is there any error message?
    I install stardict from Education repository.
    and remove stardict_espeak.so stardict_festival.so in
    /usr/lib(64)/stardict/plugins/
    follow the qstardict wiki
    use pronounce-word.sh to pronounce words with WyabdcRealPeopleTTS
    But my WyabdcRealPeopleTTS is placed in /usr/share/stardict/WyabdcRealPeopleTTS
    so you have to modify the TTS_PATH

    try
    bash /path to/pronounce-word.sh something
    paste output here.

    my output:
    bash bin/pronounce-word.sh something

    /usr/share/stardict/WyabdcRealPeopleTTS/s/something.wav:

    File Size: 8.56k Bit Rate: 88.7k
    Encoding: Unsigned PCM
    Channels: 1 @ 8-bit
    Samplerate: 11025Hz
    Replaygain: off
    Duration: 00:00:00.77

    In:100% 00:00:00.77 [00:00:00.00] Out:37.1k [ -=|=- ] Hd:3.3 Clip:0
    Done.

  3. #3

    Default Re: Problem with Stardict Pronunciation

    Hi swyear,

    Thanks for your reply. I install stardict from repository too and as you mentioned I remove stardict_festival.so and stardict_espeak.so.bak (I don't have stardict_espeak.so). Here is my output:

    Code:
    $: bash ~/.pronounce-word.sh something
    /usr/share/WyabdcRealPeopleTTS/s/something.wav:
    
     File Size: 8.56k     Bit Rate: 88.7k
      Encoding: Unsigned PCM
      Channels: 1 @ 8-bit
    Samplerate: 11025Hz
    Replaygain: off
      Duration: 00:00:00.77
    
    In:100%  00:00:00.77 [00:00:00.00] Out:37.1k [    -=|=-    ] Hd:3.2 Clip:0
    Done.
    but in stardict it didn't work. I run stardict from terminal and I don't see any errors. I use 64 bit openSUSE 11.2.

  4. #4

    Default Re: Problem with Stardict Pronunciation

    I found the problem! I should click on "Command TTS" not "Real People TTS". Is there a way that "Command TTS" become the default or I assign this settings to "Real People TTS"?

  5. #5

    Default Re: Problem with Stardict Pronunciation

    My problem solved completely! I remove all path in "RealPeopleTTS search path:" in sound section. Now I have CommandTTS and It's my default pronunciation.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •