Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: openSUSE 11.2, fglrx and KDE4 Desktop Effects

  1. #11

    Default Re: openSUSE 11.2, fglrx and KDE4 Desktop Effects

    We found the solution in the bug report:
    https://bugs.kde.org/show_bug.cgi?id=226791

    All you have to do is to:
    - (remove the previous "hack" that you used to enable compositing)
    - open the kwin config file ~/.kde4/share/config/kwinrc
    - find the section [Compositing]
    - change the option "CheckIsSafe" from "false" to "true"

    I think that this enabled compositing for everyone that wrote a comment in the bug report...

  2. #12

    Default Re: openSUSE 11.2, fglrx and KDE4 Desktop Effects

    For the sake of completeness:

    [This applies to fglrx ATI propriatary driver, OpenSuSe 11.2 with KDE 4.4]

    When desktop compositing fails, go and change the file ~/.kde4/share/config/kwinrc (no need for root):

    Line:
    [Compositing]
    ...
    CheckIsSafe=false
    ..
    Change to: CheckIsSafe=true

    Additional information is contained in this bugreport:
    https://bugs.kde.org/show_bug.cgi?id=226791

  3. #13

    Default Re: openSUSE 11.2, fglrx and KDE4 Desktop Effects



    We managed to do it at (approx) the same time... sorry for the double post.

    Quote Originally Posted by djurodrljaca View Post
    We found the solution in the bug report:
    https://bugs.kde.org/show_bug.cgi?id=226791

    All you have to do is to:
    - (remove the previous "hack" that you used to enable compositing)
    - open the kwin config file ~/.kde4/share/config/kwinrc
    - find the section [Compositing]
    - change the option "CheckIsSafe" from "false" to "true"

    I think that this enabled compositing for everyone that wrote a comment in the bug report...

  4. #14

    Default Re: openSUSE 11.2, fglrx and KDE4 Desktop Effects

    had the same problem with kernel 2.6.34x and the intel driver for a very long time. just came looking for a solution and...

    Quote Originally Posted by djurodrljaca View Post
    We found the solution in the bug report:
    https://bugs.kde.org/show_bug.cgi?id=226791

    All you have to do is to:
    - (remove the previous "hack" that you used to enable compositing)
    thank you! this worked. although i just enabled the "Disable Functionality checks" option in the advanced desktop effects tab.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •