Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: 11.2 64bit Nvidia Googleearth

  1. #1

    Angry 11.2 64bit Nvidia Googleearth

    Hello

    A bit of a problem here and T.B.H i get tired of it.
    I have a new installation of Opensuse 11.2 64bit.
    Nvidia graphic card: GeForce 6150SE nForce 430
    Kernel: 2.6.31.12-0.1-desktop

    Everythings works except for googleearth. It seems to start and running without crashing but i don`t see the planet just a black screen.

    I tried everything and installed a lot of nvidia drivers, one click install and the hard way. But it always results in xserver not starting.
    The driver i`m using right now is NVIDIA-Linux-x86_64-190.53.

    I tried to install the NVIDIA-Linux-x86_64-173.14.25-pkg2.run
    But when it started X it gave a error:
    the kernelmodule is not matching the driver.
    Kernel module NVIDIA-Linux-x86_64-173.14.18
    while driver is NVIDIA-Linux-x86_64-173.14.25

    Thanks

  2. #2
    palladium NNTP User

    Default Re: 11.2 64bit Nvidia Googleearth

    Tux-2010 wrote:
    > Everythings works except for googleearth. It seems to start and running
    > without crashing but i don`t see the planet just a black screen.


    how did you determine that the "no planet" in Googleearth problem was
    a nvidia driver problem?

    did you get an error message, or what?


    > I tried everything and installed a lot of nvidia drivers, one click
    > install and the hard way. But it always results in xserver not
    > starting.


    did you find some other user's posting of "no planet" that was solved
    fixed by changing nvidia drivers?

    > The driver i`m using right now is NVIDIA-Linux-x86_64-190.53.


    ok, have you turned on 3D support in YaST > Hardware > Graphics Card &
    Monitor ??



    > I tried to install the NVIDIA-Linux-x86_64-173.14.25-pkg2.run
    > But when it started X it gave a error:
    > the kernelmodule is not matching the driver.
    > Kernel module NVIDIA-Linux-x86_64-173.14.18
    > while driver is NVIDIA-Linux-x86_64-173.14.25


    right, the nvidia driver must match the kernel module, or it won't work..

    see if you have 3D enabled...if you do, and you don't see a beautiful
    Earth you are probably gonna need to do a lot of reading trying to
    find a problem similar to yours which has been solved...

    HA!

    i looked at the first hit from:
    http://www.google.com/search?q="google+earth"+"no+planet"+solved

    and guess yours is a permissions problem..

    i guess you installed Google Earth as root....am i right?

    i hope you don't normally run KDE logged into root, do you?
    in fact, i hope you 'never' log into KDE (or Gnome, XFCE, etc) as
    root, because it is never required to do so..

    logged in as a regular user, see if you can run it from a terminal
    this way

    sudo googleearth

    and, give the root password when prompted (you will not see what you type)

    then come back with the results of this experiment and i'll fill you
    in on why not to log into KDE as root, and how to do 'admin' stuff
    without..

    --
    palladium

  3. #3

    Default Re: 11.2 64bit Nvidia Googleearth

    Quote Originally Posted by palladium View Post
    Tux-2010 wrote:
    > Everythings works except for googleearth. It seems to start and running
    > without crashing but i don`t see the planet just a black screen.


    how did you determine that the "no planet" in Googleearth problem was
    a nvidia driver problem?

    did you get an error message, or what?
    No, i did not get a error message but when googling the problem.
    But a lot of times it was mentioned it might be a nvidia driver problem.

    Quote Originally Posted by palladium View Post
    Tux-2010 wrote:
    > I tried everything and installed a lot of nvidia drivers, one click
    > install and the hard way. But it always results in xserver not
    > starting.


    did you find some other user's posting of "no planet" that was solved
    fixed by changing nvidia drivers?
    No, only answers as it might be a nvidia

    Quote Originally Posted by palladium View Post

    > The driver i`m using right now is NVIDIA-Linux-x86_64-190.53.


    ok, have you turned on 3D support in YaST > Hardware > Graphics Card &
    Monitor ??
    Yes it`s turned on.

    Quote Originally Posted by palladium View Post
    Tux-2010 wrote:[color=blue]

    > I tried to install the NVIDIA-Linux-x86_64-173.14.25-pkg2.run
    > But when it started X it gave a error:
    > the kernelmodule is not matching the driver.
    > Kernel module NVIDIA-Linux-x86_64-173.14.18
    > while driver is NVIDIA-Linux-x86_64-173.14.25


    right, the nvidia driver must match the kernel module, or it won't work..
    The problem is when i installed the NVIDIA-Linux-x86_64-173.14.25 it did not install thekernel module NVIDIA-Linux-x86_64-173.14.25

    Quote Originally Posted by palladium View Post
    Tux-2010 wrote:[color=blue]
    see if you have 3D enabled...if you do, and you don't see a beautiful
    Earth you are probably gonna need to do a lot of reading trying to
    find a problem similar to yours which has been solved...

    HA!

    i looked at the first hit from:
    http://www.google.com/search?q="google+earth"+"no+planet"+solved

    and guess yours is a permissions problem..

    i guess you installed Google Earth as root....am i right?
    No you`re not right i installed it in user mode

    Quote Originally Posted by palladium View Post
    Tux-2010 wrote:[color=blue]
    i hope you don't normally run KDE logged into root, do you?
    in fact, i hope you 'never' log into KDE (or Gnome, XFCE, etc) as
    root, because it is never required to do so..
    Of course not.

    Quote Originally Posted by palladium View Post
    Tux-2010 wrote:[color=blue]
    logged in as a regular user, see if you can run it from a terminal
    this way

    sudo googleearth

    and, give the root password when prompted (you will not see what you type)

    then come back with the results of this experiment and i'll fill you
    in on why not to log into KDE as root, and how to do 'admin' stuff
    without..

    --
    palladium
    Googleearth was never installed as root however when i run it as root or as user i get the same problem.
    I starts but i don`t see a Planet

  4. #4
    palladium NNTP User

    Default Re: 11.2 64bit Nvidia Googleearth

    since 3D is enabled, and it is not a permissions problem i am out of
    ideas and help...suggest you continue with google searches until
    someone smarter than me comes with _the_ answer..

    while i highly doubt that changing the nvidia driver will help (since
    you have 3D successfully enabled), but it may...the thing you MUST do
    when changing nvidia drivers is to compile the driver using the
    headers of the kernel *in use* or it will never work..

    have you searched to learn the one best nvidia driver for that board
    and your kernel...it isn't something to guess about...sorry, i can't
    tell you exactly how to determine _the_ driver to use...but, if i were
    doing it for myself i would begin here:

    http://www.google.com/search?q="GeForce+6150SE+nForce+430"+"which+driver"+linux

    --
    palladium

  5. #5

    Default Re: 11.2 64bit Nvidia Googleearth

    I removed googleearth including .googleearth and .config/Google and installed it again.
    Now i get a planet but it crashes after 3 seconds

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: 11.2 64bit Nvidia Googleearth

    I am not sure if this solves your problem, but I saw something similar on a machine with an older nvidia card.

    I solved it by changing a setting in google earth.
    Open the tools menu and goto options
    in the dialog at the right there is a possibility (checkbox) to switch to "Abgesicherter Grafikmodus" (in the german dialog) which I guess is in the english version something like "Save mode" or "Compatibility mode" or similar
    and then restart google earth.

    Of course whenever one switches to something called save or compatibility there is a loss in performance, but google earth runs fluently with it even on this older machine.

  7. #7
    palladium NNTP User

    Default Re: 11.2 64bit Nvidia Googleearth

    Tux-2010 wrote:
    > I removed googleearth including .googleearth and .config/Google


    i can't readily find the instructions on how to uninstall Google
    Earth, how did you do it?

    are you sure you installed all of it?

    i ask because i know it installs a custom built version of WINE, but,
    i don't know where it puts that, or what happens if you leave bits of
    the bogus "registry" around for a subsequent install attempt..


    > and installed it again.
    > Now i get a planet but it crashes after 3 seconds


    what crashes? (Google Earth, the WINE it runs in, or KDE or openSUSE
    or . . .)

    What exactly are you seeing? is Google Earth disappearing from your
    screen? or is your whole screen going black? or maybe the screen is
    freezing and the mouse won't move? or, exactly what is happening..

    have you looked in earlier posts here to see if crashing after a few
    seconds has been encountered by others, and solved? there is a link on
    this page where can go to an advanced search page and drill down to
    pay dirt, maybe..

    (what i'm saying is: i've not experienced these particular problems
    with Google Earth and so i don't know exactly how to fix it....maybe
    someone else will happen by, see your post and give you _the_
    answer...but, that might not happen until next week.....or never...the
    choice is your to wait and see, or try to move on though another
    million other posts..)

    i think i'd first make sure i had uninstalled completely and
    correctly, and then i'd do an install according to the
    documentation...and then go from there....but, it may be easier to see
    if someone else has solved what you see now..

    --
    palladium

  8. #8

    Default Re: 11.2 64bit Nvidia Googleearth

    Quote Originally Posted by palladium View Post
    Tux-2010 wrote:
    > I removed googleearth including .googleearth and .config/Google


    i can't readily find the instructions on how to uninstall Google
    Earth, how did you do it?
    I did not uninstall it i just removed the directories

    Quote Originally Posted by palladium View Post
    Tux-2010 wrote:[color=blue]
    are you sure you installed all of it?

    i ask because i know it installs a custom built version of WINE, but,
    i don't know where it puts that, or what happens if you leave bits of
    the bogus "registry" around for a subsequent install attempt..
    Well that i do not know like i said i just removed the directories

    Quote Originally Posted by palladium View Post
    Tux-2010 wrote:[color=blue]

    > and installed it again.
    > Now i get a planet but it crashes after 3 seconds


    what crashes? (Google Earth, the WINE it runs in, or KDE or openSUSE
    or . . .)

    What exactly are you seeing? is Google Earth disappearing from your
    screen? or is your whole screen going black? or maybe the screen is
    freezing and the mouse won't move? or, exactly what is happening..

    have you looked in earlier posts here to see if crashing after a few
    seconds has been encountered by others, and solved? there is a link on
    this page where can go to an advanced search page and drill down to
    pay dirt, maybe..

    (what i'm saying is: i've not experienced these particular problems
    with Google Earth and so i don't know exactly how to fix it....maybe
    someone else will happen by, see your post and give you _the_
    answer...but, that might not happen until next week.....or never...the
    choice is your to wait and see, or try to move on though another
    million other posts..)

    i think i'd first make sure i had uninstalled completely and
    correctly, and then i'd do an install according to the
    documentation...and then go from there....but, it may be easier to see
    if someone else has solved what you see now..

    --
    palladium
    Right now i see Googleearth working

    What i did.

    I unmarked the 3D in yast.

    Logged out

    ctrl alt backspace

    When i logged in everything worked fine.

    And 3D is marked again?

    Sorry i don`t have a logical explanation for this.

    Thanks for the help

  9. #9

    Default Re: 11.2 64bit Nvidia Googleearth

    And it`s back to not working

    When starting Googleearth it opens a second and closes almost immediately.

    This time i get at least a error

    Google Earth has caught signal 11.



    We apologize for the inconvenience, but Google Earth has crashed.
    This is a bug in the program, and should never happen under normal
    circumstances. A bug report and debugging data have been written
    to this text file:

    /path/to/.googleearth/crashlogs/crashlog-4b76ef08.txt

    Major Version 5
    Minor Version 1
    Build Number 3533
    Build Date Nov 11 2009
    Build Time 16:41:31
    OS Type 11
    OS Major Version 2
    OS Minor Version 6
    OS Build Version 31
    OS Patch Version 12
    Crash Signal 11
    Crash Time 1266085280
    Up Time 3.21149

    Stacktrace from glibc:
    ./googleearth-bin[0x805caa6]
    [0xffffe400]
    [0x856b4f8]

  10. #10

    Default Re: 11.2 64bit Nvidia Googleearth

    So i did once again

    Unmarked the 3D in yast.

    Logged out

    ctrl alt backspace

    When i log in everything works fine.
    However after a reboot GE stats crashing again.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •