Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Mic not working on Dell E6400, OpenSuse 11.2 fresh installation

  1. #1

    Default Mic not working on Dell E6400, OpenSuse 11.2 fresh installation

    Hello All,
    I just had a fresh installation of Suse 11.2 on this Dell E6400 Latitude laptop and after that I was able to made the integrated webcam work , but no luck with internal mic.

    ALSA URL
    http://www.alsa-project.org/db/?f=ea...1ff6ad64d6ba45

    rpm -qa | grep alsa

    Code:
    alsa-utils-1.0.21-3.1.i586
    alsa-plugins-1.0.21-3.3.i586
    alsa-1.0.21-3.2.i586
    alsa-oss-1.0.17-25.2.i586
    alsa-devel-1.0.21-3.2.i586
    alsa-plugins-pulse-1.0.21-3.3.i586
    rpm -qa | grep pulse

    Code:
    pulseaudio-module-gconf-0.9.19-2.3.i586
    libpulse-browse0-0.9.19-2.3.i586
    pulseaudio-module-x11-0.9.19-2.3.i586
    pulseaudio-module-zeroconf-0.9.19-2.3.i586
    pulseaudio-utils-0.9.19-2.3.i586
    libxine1-pulse-1.1.16.1-7.6.i586
    libpulse-devel-0.9.19-2.3.i586
    libpulse0-0.9.19-2.3.i586
    alsa-plugins-pulse-1.0.21-3.3.i586
    libpulse-mainloop-glib0-0.9.19-2.3.i586
    pulseaudio-module-lirc-0.9.19-2.3.i586
    pulseaudio-0.9.19-2.3.i586
    pulseaudio-module-bluetooth-0.9.19-2.3.i586
    rpm -q libasound2

    Code:
    libasound2-1.0.21-3.2.i586
    uname -a

    Code:
    Linux linux-igob 2.6.31.12-0.1-desktop #1 SMP PREEMPT 2010-01-27 08:20:11 +0100 i686 i686 i386 GNU/Linux
    I tried
    Code:
     arecord -vv -fdat foo.wav
    but, the file foo.wav doesnt have any recorded sound.

    On the same laptop if Ubuntu 9.10 is installed, then mic works like a charm. Any help will be appreciated.

    Cheers!!!
    ~S

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: Mic not working on Dell E6400, OpenSuse 11.2 fresh installation

    From the mixer in the panel make sure you have the MIC channel enabled and that it is not muted.
    'Configure Channels'
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Mic not working on Dell E6400, OpenSuse 11.2 fresh installation

    The options selected in Mixer are as follows
    Master
    Front
    PCM
    Headphone
    capture (it is selected )
    Digital Mic (only volume controls)
    PC Beep

    There are few more options I can select but they are not shown on mixer.
    Do I need to select anything more?

    Cheer!!
    ~S

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: Mic not working on Dell E6400, OpenSuse 11.2 fresh installation

    If your sound is working ok generally it is more likely just a setting that you are overlooking.
    Our resident sound guru is away at the moment, which doesn't help.
    SDB:AudioTroubleshooting - openSUSE
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Mic not working on Dell E6400, OpenSuse 11.2 fresh installation

    I tried all I can find about mic not working on suse and offered solutions here on the forum, but nothing seems to work for me. Seems like I hit the dead end. Am a newbie, so cant fiddle much without much of input from experts.
    I hope that sound guru returns soon to take a shot at my problem.
    No mic for me

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: Mic not working on Dell E6400, OpenSuse 11.2 fresh installation

    Be patient. @oldcpu should be back tomorrow, if not today. But he was delayed in the US.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    26,446
    Blog Entries
    34

    Default Re: Mic not working on Dell E6400, OpenSuse 11.2 fresh installation

    Quote Originally Posted by sandeepvirdi View Post
    I tried all I can find about mic not working on suse and offered solutions here on the forum, but nothing seems to work for me. Seems like I hit the dead end. Am a newbie, so cant fiddle much without much of input from experts.
    I hope that sound guru returns soon to take a shot at my problem.
    No mic for me
    Note your integrated mic is likely a digital mic. You do not have that selected, and you need to select the digital mic. I note in RED:

    !!Amixer output
    !!-------------
    !!-------Mixer controls for card 0 [Intel]

    Mixer name : 'Intel G45 DEVCTG'
    Simple mixer control 'Front Mic Jack Mode',0
    Items: 'Mic In' 'Line In'
    Item0: 'Mic In'
    Simple mixer control 'Mic Jack Mode',0
    Items: 'Mic In' 'Line In'
    Item0: 'Mic In'
    Simple mixer control 'IEC958',0
    Mono: Playback [on]
    Simple mixer control 'Capture',0
    Front Left: Capture 15 [100%] [22.50dB] [on]
    Front Right: Capture 15 [100%] [22.50dB] [on]
    Simple mixer control 'Capture',1
    Front Left: Capture 15 [100%] [22.50dB] [on]
    Front Right: Capture 15 [100%] [22.50dB] [on]
    Simple mixer control 'Digital Mic',0
    Front Left: Capture 3 [100%] [30.00dB]
    Front Right: Capture 3 [100%] [30.00dB]
    Simple mixer control 'Input Source',0
    Items: 'Mic' 'Front Mic' 'Digital Mic'
    Item0: 'Mic'
    Simple mixer control 'Input Source',1
    Items: 'Mic' 'Front Mic' 'Digital Mic'
    Item0: 'Mic'
    Simple mixer control 'Mux',0
    Front Left: Capture 0 [0%] [0.00dB]
    Front Right: Capture 0 [0%] [0.00dB]
    Simple mixer control 'Mux',1
    Front Left: Capture 0 [0%] [0.00dB]
    Front Right: Capture 0 [0%] [0.00dB]
    Your mixer is setup to ensure the digital mic does not capture. YOU need to change that setting.

    If you are using KDE you can add extra controls in kmix under "settings > configure channels ".

    When testing your mic, please use:
    Code:
      arecord -vv -fdat foo.wav
    where "foo.wav" is any file name you select ... ie it could also be "anyfilename.wav". Reference: Microphone - openSUSE

  8. #8

    Default Re: Mic not working on Dell E6400, OpenSuse 11.2 fresh installation

    The digital mic flag needs to be fixed in ALSA configration. Try these:

    Internal microphone on Dell Studio 1557 not working on 11.2 - openSUSE Forums

    https://bugs.launchpad.net/ubuntu/+s...22/+bug/153963

    I used the option in the second link, but you might wanna try the first link first - it's easier.

  9. #9

    Default Re: Mic not working on Dell E6400, OpenSuse 11.2 fresh installation

    I have a Dell Latitude E6500 laptop and I am experiencing quite similar problems in Slackware 13.0:
    [rdagold@slack13 ~]$ uname -a
    Linux mhq 2.6.29.6 #3 SMP Mon Dec 7 15:01:06 CST 2009 x86_64 Intel(R) Core(TM) 2 Duo CPU T9600@2.80GHz GenuineIntel GNU/Linux
    I hope to be able to positively contribute to this topic and to receive some help from you all.

    Everything is fine here with this laptop, except that I am completely unable to record audio, either using the built-in microphone or an external one. I can do this under Windows 7, so the microphones are not defect. Audio output is ok, both for the built-in speakers and the external headset. I can listen to my mp3 in mpd/ncmpcpp and watch (HD) movies at youtube, for example.

    Following advice I found at Archlinux, Ubuntu and Suse forums, I have run alsaconf and I changed /etc/modprobe.d/sound:

    [rdagold@slack13 ~]$ cat /etc/modprobe.d/sound
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    options snd-hda-intel model=dell-m4-1
    I have then tried to record sound using sox (rec) and arecord applications. Both of them returned perfectly (and annoyingly) clean WAV files. I've also given Ekiga a try but it didn't work either, as expected.

    Afterwards, I have tried several different alsamixer configurations for my capture devices and tried to record sound both via the builtin microphone and via an external one. It was all to no avail. Here are two screenshots of (rather obvious testing) configurations that I attempted:

    1)http://tinyurl.com/yb8wb33
    2)http://tinyurl.com/yepnxw6

    In case you prefer, here is the output of amixer:

    Simple mixer control 'Master',0
    Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    Playback channels: Mono
    Limits: Playback 0 - 127
    Mono: Playback 127 [100%] [0.00dB] [on]
    Simple mixer control 'Headphone',0
    Capabilities: pvolume pswitch
    Playback channels: Front Left - Front Right
    Limits: Playback 0 - 127
    Mono:
    Front Left: Playback 126 [99%] [0.75dB] [on]
    Front Right: Playback 126 [99%] [0.75dB] [on]
    Simple mixer control 'PCM',0
    Capabilities: pvolume
    Playback channels: Front Left - Front Right
    Limits: Playback 0 - 255
    Mono:
    Front Left: Playback 255 [100%] [0.00dB]
    Front Right: Playback 255 [100%] [0.00dB]
    Simple mixer control 'Front',0
    Capabilities: pvolume pswitch
    Playback channels: Front Left - Front Right
    Limits: Playback 0 - 127
    Mono:
    Front Left: Playback 127 [100%] [0.00dB] [on]
    Front Right: Playback 127 [100%] [0.00dB] [on]
    Simple mixer control 'Capture',0
    Capabilities: cvolume cswitch
    Capture channels: Front Left - Front Right
    Limits: Capture 0 - 15
    Front Left: Capture 15 [100%] [22.50dB] [off]
    Front Right: Capture 15 [100%] [22.50dB] [off]
    Simple mixer control 'Capture',1
    Capabilities: cvolume cswitch
    Capture channels: Front Left - Front Right
    Limits: Capture 0 - 15
    Front Left: Capture 15 [100%] [22.50dB] [off]
    Front Right: Capture 15 [100%] [22.50dB] [off]
    Simple mixer control 'Analog Loopback',0
    Capabilities: pswitch pswitch-joined
    Playback channels: Mono
    Mono: Playback [off]
    Simple mixer control 'Analog Loopback',1
    Capabilities: pswitch pswitch-joined
    Playback channels: Mono
    Mono: Playback [off]
    Simple mixer control 'DAC0',0
    Capabilities: cvolume cswitch
    Capture channels: Front Left - Front Right
    Limits: Capture 0 - 31
    Front Left: Capture 31 [100%] [12.00dB] [off]
    Front Right: Capture 31 [100%] [12.00dB] [off]
    Simple mixer control 'DAC1',0
    Capabilities: cvolume cswitch
    Capture channels: Front Left - Front Right
    Limits: Capture 0 - 31
    Front Left: Capture 31 [100%] [12.00dB] [off]
    Front Right: Capture 31 [100%] [12.00dB] [off]
    Simple mixer control 'Digital',0
    Capabilities: cvolume
    Capture channels: Front Left - Front Right
    Limits: Capture 0 - 120
    Front Left: Capture 120 [100%] [30.00dB]
    Front Right: Capture 120 [100%] [30.00dB]
    Simple mixer control 'Digital Input Source',0
    Capabilities: enum
    Items: 'Analog Inputs' 'Mixer' 'Digital Mic 1'
    Item0: 'Analog Inputs'
    Simple mixer control 'Import0 Mux',0
    Capabilities: cvolume cswitch
    Capture channels: Front Left - Front Right
    Limits: Capture 0 - 31
    Front Left: Capture 31 [100%] [12.00dB] [off]
    Front Right: Capture 31 [100%] [12.00dB] [off]
    Simple mixer control 'Import1 Mux',0
    Capabilities: cvolume cswitch
    Capture channels: Front Left - Front Right
    Limits: Capture 0 - 31
    Front Left: Capture 31 [100%] [12.00dB] [off]
    Front Right: Capture 31 [100%] [12.00dB] [off]
    Simple mixer control 'Input Source',0
    Capabilities: cenum
    Items: 'Mic' 'Front Mic'
    Item0: 'Front Mic'
    Simple mixer control 'Input Source',1
    Capabilities: cenum
    Items: 'Mic' 'Front Mic'
    Item0: 'Front Mic'
    Simple mixer control 'Mux',0
    Capabilities: cvolume
    Capture channels: Front Left - Front Right
    Limits: Capture 0 - 3
    Front Left: Capture 3 [100%] [30.00dB]
    Front Right: Capture 3 [100%] [30.00dB]
    Simple mixer control 'Mux',1
    Capabilities: cvolume
    Capture channels: Front Left - Front Right
    Limits: Capture 0 - 3
    Front Left: Capture 3 [100%] [30.00dB]
    Front Right: Capture 3 [100%] [30.00dB]
    It is worth to note that the codec to be used is correctly assigned (IDT 92HD71B7X):

    [rdagold@slack13 ~]$ cat /proc/asound/card0/codec#* | grep Codec
    Codec: IDT 92HD71B7X
    The currently installed alsa packages in the system are:

    [rdagold@slack13 ~]$ ls /var/log/packages/ | grep alsa
    alsa-lib-1.0.18-x86_64-2
    alsa-oss-1.0.17-x86_64-1
    alsa-utils-1.0.18-x86_64-2
    Output of lspci -vvnn
    00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
    Subsystem: Dell Device [1028:024f]
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 21
    Region 0: Memory at f6fdc000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [50] Power Management version 2
    Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
    Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
    Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
    Address: 0000000000000000 Data: 0000
    Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
    DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
    ExtTag- RBE- FLReset+
    DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
    RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
    MaxPayload 128 bytes, MaxReadReq 128 bytes
    DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
    LnkCap: Port #0, Speed unknown, Width x0, ASPM unknown, Latency L0 <64ns, L1 <1us
    ClockPM- Surprise- LLActRep- BwNot-
    LnkCtl: ASPM Disabled; Disabled- Retrain- CommClk-
    ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
    LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
    Capabilities: [100] Virtual Channel <?>
    Capabilities: [130] Root Complex Link <?>
    Kernel driver in use: HDA Intel
    Kernel modules: snd-hda-intel
    Output of alsa-info.sh: http://pastebin.com/f214a29fa

    I hope to have included all relevant information. I feel quite lost on what to try next. Thank you all in advance for any help/suggestions/orientation you may be able to provide me!

  10. #10
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    26,446
    Blog Entries
    34

    Default Re: Mic not working on Dell E6400, OpenSuse 11.2 fresh installation

    Quote Originally Posted by rdagold View Post
    I have a Dell Latitude E6500 laptop and I am experiencing quite similar problems in Slackware 13.0:
    We typically don't provide slackware support. I also suspect there are slackware users who know way more about sound than myself who may be able to provide guidance more applicable to slackware.

    Still, the 1st thing I note is your alsa version is VERY OLD given the current version of alsa is 1.0.22.1 Your hardware is relatively new, and hence I recommend you update your alsa version.

    Next, I note this in your mixer settings:

    #!!Amixer output
    #!!-------------
    #
    #!!-------Mixer controls for card 0 [Intel]
    # Mixer name : 'IDT 92HD71B7X'
    Simple mixer control 'Capture',0
    Capabilities: cvolume cswitch
    # Front Left: Capture 15 [100%] [22.50dB] [off]
    # Front Right: Capture 15 [100%] [22.50dB] [off]
    Simple mixer control 'Capture',1
    # Front Left: Capture 15 [100%] [22.50dB] [off]
    # Front Right: Capture 15 [100%] [22.50dB] [off]
    Simple mixer control 'DAC0',0
    # Front Left: Capture 31 [100%] [12.00dB] [off]
    # Front Right: Capture 31 [100%] [12.00dB] [off]
    Simple mixer control 'DAC1',0
    # Front Left: Capture 31 [100%] [12.00dB] [off]
    # Front Right: Capture 31 [100%] [12.00dB] [off]
    Simple mixer control 'Import0 Mux',0
    # Front Left: Capture 31 [100%] [12.00dB] [off]
    # Front Right: Capture 31 [100%] [12.00dB] [off]
    Simple mixer control 'Import1 Mux',0
    # Front Left: Capture 31 [100%] [12.00dB] [off]
    # Front Right: Capture 31 [100%] [12.00dB] [off]
    Simple mixer control 'Input Source',0
    # Items: 'Mic' 'Front Mic'
    # Item0: 'Mic'
    Simple mixer control 'Input Source',1
    # Items: 'Mic' 'Front Mic'
    # Item0: 'Mic'
    Simple mixer control 'Mux',0
    # Front Left: Capture 3 [100%] [30.00dB]
    # Front Right: Capture 3 [100%] [30.00dB]
    Simple mixer control 'Mux',1
    # Front Left: Capture 3 [100%] [30.00dB]
    # Front Right: Capture 3 [100%] [30.00dB]
    Practically EVERYWHERE I look in your mixer, you have capture switched OFF. That guarantee's your mic will not work.

    You also have "mic" selected nistead of "front mic". That suggests to me there is more than one mic input on your Dell E6400. Ensure you have the correct one selected.

    And also, when testing for capture functionality, I recommend this test
    Code:
     arecord -vv -fdat foo.wav
    for testing capture, ...

    .. don't forget what I noted about updating your alsa version.

    and finally, I recommend you go to a slackware forum for help and NOT here. Apologies, but I am over tasked as it is, and I really do not have the time to support both slackware users and openSUSE users.

    Sorry.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •