Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Problem with short-cut gnome-do + Menu

  1. #1
    Join Date
    Jun 2008
    Location
    Barcelona, Spain
    Posts
    35

    Default Problem with short-cut gnome-do + Menu

    Hi!

    I have an opensuse 11.2 installed at my laptop, using gnome desktop. The problem is the short-cut to gnome-do (winkey space). Every time I push this key combination, the principal gnome Menu appears; no gnome-do input window (only after some attemps and behind of the principal gnome Menu window).
    I look at keyboard shortcuts, but I cannot find the correct way to configure this "problem".

    Anybody could help me, please?

    Please, excuse me my bad english, it isnt my habitual language.

    Thank you very much.

  2. #2

    Question Re: Problem with short-cut gnome-do + Menu

    Same problem here... anybody does know how you're supposed to change the binding between the menu and the "super key"?

    I can't find it...

    Thanks

  3. #3
    Join Date
    Jun 2008
    Location
    Barcelona, Spain
    Posts
    35

    Default Re: Problem with short-cut gnome-do + Menu

    Quote Originally Posted by zanzax View Post
    Same problem here... anybody does know how you're supposed to change the binding between the menu and the "super key"?

    I can't find it...
    I'm sorry, but nobody reply me, and I don't know how to solve this problema.

  4. #4

    Default Re: Problem with short-cut gnome-do + Menu

    Hey,

    I also had this problem with the Gnome-Do version installed by default in 11.2. Try adding the following repo:

    Index of /repositories/Mono:/Community/openSUSE_11.2

    Currently this repo has version 0.8.3.1 of Gnome-Do. I believe it fixes that problem.

  5. #5

    Default Re: Problem with short-cut gnome-do + Menu

    Sorry, I just realized the information I provided is inaccurate. Actually I believe the problem lies with the Compiz version shipped by default. Somehow, the Super Key (aka WinKey) is acting as a shortcut to the main menu, which conflicts with the Gnome-Do shortcut. There are two things you might try (of course, there's no harm done in upgrading Gnome-Do also):

    1 - change the Gnome-Do shortcut from Super+Space to something else (without using the Super Key)

    OR

    2 - Installing a different Compiz version. I currently have installed the version from this repo: Index of /repositories/X11:/XGL/openSUSE_11.2

    I'm able to use Super+Space for Gnome-Do without any problems.

    Hope it helps.

  6. #6
    Join Date
    Jun 2008
    Location
    Barcelona, Spain
    Posts
    35

    Default Re: Problem with short-cut gnome-do + Menu

    Thank you! I will try to change the compiz version.

    Regards.

  7. #7

    Default Re: Problem with short-cut gnome-do + Menu

    I changed the compiz version and now I don't have compiz at all... If I run it from the cli I get this error:

    $ compiz --replace
    compiz (cube) - Warn: Failed to load slide: freedesktop
    WARNING: Application calling GLX 1.3 function "glXCreatePixmap" when GLX 1.3 is not supported! This is an application bug!

    I've been searching, but I don't know what to do... :c. What packages I was supposed to update?

  8. #8

    Default Re: Problem with short-cut gnome-do + Menu

    I have the following packages from the XGL repo (http://download.opensuse.org/reposit...openSUSE_11.2/). Btw, I use GNOME in openSUSE 11.2:

    • compiz
    • compiz-branding-openSUSE
    • compiz-emerald
    • compiz-emerald-themes
    • compiz-gnome
    • compiz-manager
    • compiz-plugins-extra
    • compiz-plugins-main
    • compizconfig-settings-manager
    • emerald-themes-extra
    • libcompizconfig
    • libprotobuf4
    • python-compizconfig
    • simple-ccsm

    Anyway, I think the message you're getting in the Terminal is just a warning regarding a certain function not supported by your system. Do you have an ATI graphics card? I ask because I found several bug reports with that message regarding ATI cards (Application calling GLX 1.3 function "glXCreatePixmap" when GLX 1.3 is not supported!). Look here, for instance: https://bugs.edge.launchpad.net/ubun...iz/+bug/433488

    Just load ccsm and enable only the plugins you need. You probably have to reassign the screen edges as well (to call for Expo, or whatever). Test it, and see if it works.

    Also, always make sure you have the latest drivers for you graphics card. There are repos just for this end, straight from the hardware vendors:

    ATI: http://www2.ati.com/suse/11.2/ (or 11.1 or 11.0 if you're using an older openSUSE)

    NVIDIA: http://download.nvidia.com/opensuse/11.2/

  9. #9

    Default Re: Problem with short-cut gnome-do + Menu

    Sorry for the delay in answering. I didn't know what I did exactly, but now is working fine with the XGL repo. The only difference with the previous installation was that I installed fusion-icon and didn't install libprotobuf. Sounds crazy that something like that could change compiz behaviour, but the fact it did it.

    I read about that bug, specially that in many places people said it's only a warning and Compiz still works fine. At least in my case, that didn't work that way.

    My video car isn't NVIDIA nor ATI, I'm using Intel . Any tip to get better performance?

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: Problem with short-cut gnome-do + Menu

    You are never getting great performance from Intel video. The included driver for Intel is just about as good as it gets. The only thing you can really say about Intel video hardware is that it is cheap. For cutting edge NVIDIA and ATI are it. I have an older NVIDIA 6800+ based card and it would blow away any Intel chip set and it is over 4 years old.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •