Results 1 to 10 of 10

Thread: glxgears errors

  1. #1

    Default glxgears errors

    Whenever I run glxgears or glxinfo from an ssh or vnc session, I get "Error: couldn't get an RGB, double-buffered visual". I can run glx stuff fine on the console under KDE, but that's not practical for the intended users. I've tried updating drivers (it's a Dell R610 w/ Matrox G200ew videa), firmware, rpms, etc., even running ssh with -X or -Y, but to no avail. If anyone has any ideas of what else I can do, let me know. I'll be running strace, and some other utilities to see what I can find in the meantime. Thanks in advance.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,746

    Default Re: glxgears errors

    GLxgears is OpenGL 3D. You are trying to run 3D across a thin wire. Good luck.

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: glxgears errors

    Ditto
    Just what practical purpose is there to running glxgears via ssh -X?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,746

    Default Re: glxgears errors

    It might work maybe if you do a remote Xwindows session. But the remote machine must be running Xwindows and OpenGL. Again you are transmiting a lot of information across a thin wire sooooo

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: glxgears errors

    Hang on I'm going to try it.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: glxgears errors

    Yuck
    It works, but the gears move like mega slow
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,746

    Default Re: glxgears errors

    Cool that it works but I expected it to be best slow. How many frames per sec can you transmit across the network. Internal data paths have far far higher bandwidth.

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,746

    Default Re: glxgears errors

    Also it is insecure and should only be used behind a firewall.

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: glxgears errors

    I'm only using it on the LAN
    Code:
    2655 frames in 5.5 seconds = 485.265 FPS
    3005 frames in 5.0 seconds = 597.804 FPS
    2322 frames in 5.0 seconds = 463.270 FPS
    2662 frames in 5.0 seconds = 530.467 FPS
    2660 frames in 5.0 seconds = 531.806 FPS
    2782 frames in 5.0 seconds = 556.398 FPS
    2889 frames in 5.0 seconds = 574.270 FPS
    Rubbish isn't it
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,746

    Default Re: glxgears errors

    If you had a 10 gigabit network and you did not mind saturating it, it might run ok LOL

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •