Results 1 to 8 of 8

Thread: can't open remote files in Openoffice

  1. #1
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default can't open remote files in Openoffice

    Have openoffice 3.1.1 and samba shares set up between my Opensuse 11.2 desktop and wife and daughters widows7 notebooks. Can access everything perfectly over the shares except anything in Openoffice.

    When I try to open a file located on one of the two notebooks Openoffice gives the message "you can only select local files"

    I found an old solution from 2005 on this in google suggesting that you had to mount manually the remote drive.
    That seems extremely clunky and cumbersome.

    There must be a way to enable Openoffice to open remote files. I can't believe in 2009 Openoffice is not able to do this without jumping through hoops.

    Have checked Kword and it has no problems opening files over samba shares

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: can't open remote files in Openoffice

    Try a cifs mount with the nobrl option included

    [I know that's not your iodeal solution -- clunky and cumbersome]
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  3. #3
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: can't open remote files in Openoffice

    found this solution that works - and seems very simple . . . but are there any downsides to it or any reason I should not leave Openoffice set like this?

    Openoffice is currently set to open in its preferences using

    Code:
    oowrite %U
    changing Openoffice preferences to
    Code:
    oowriter %f
    will force a temp file to be written locally allowing Openoffice to open remote files

  4. #4
    Join Date
    Sep 2008
    Location
    Earl Shilton UK
    Posts
    298

    Default Re: can't open remote files in Openoffice

    Not sure, but won't that mean when you click Save it will save to the temp file, not the real file?

    If so, you'll have to be very careful not to accidentally lose your work in some random temp file...
    Happily using Linux since 1998
    Share & Enjoy

  5. #5

    Default Re: can't open remote files in Openoffice

    sounds like a permission problem!
    do you have write access to the other two notebooks through samba??
    if not try adding the write access and see if that clears this

  6. #6

    Default Re: can't open remote files in Openoffice

    Quote Originally Posted by farcusnz View Post
    found this solution that works - and seems very simple . . . but are there any downsides to it or any reason I should not leave Openoffice set like this?

    Openoffice is currently set to open in its preferences using

    Code:
    oowrite %U
    changing Openoffice preferences to
    Code:
    oowriter %f
    will force a temp file to be written locally allowing Openoffice to open remote files
    Sounds like a nice solution; but where do I change this ? Couldn't find it anywhere

  7. #7

    Default Re: can't open remote files in Openoffice

    In case anyone also needs to find the place where you can change the command line, it is here:

    Personal Settings -> Advanced
    -> File Associations

    Search for pattern: msword

    Select Know Types: msword
    Select OpenOffice.org Writer
    Select Edit
    Select Application tab
    Change Edit Box named Command to: oowriter %f

    That's it.
    The changes are updated immediately.

  8. #8
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: can't open remote files in Openoffice

    like weighty_foe says though - be careful about saving your files.
    I haven't tested it so not sure if he is correct that when you hit save - it saves to the temp file.
    Easily solved by always using the save-as button instead.

    Hopefully this is all sorted out in future versions of Openoffice as seems like a very elementary feature that should be in place.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •