Results 1 to 7 of 7

Thread: zypper won't die

  1. #1

    Default zypper won't die

    This is opensuse 11.2.

    Somehow zypper is running at 100% cpu and won't die with command line kill, the system monitor kill, terminate or anything. I set it's priority to the lowest it will go, tried to stop it then kill it, nothing works as it simply is not responding to anything and it has been running now for 47 hours.

    Is there a way to simply dump a process out of memory without requiring it to respond to a signal? because signals are doing nothing.
    Last edited by Reg_gie; 04-Feb-2010 at 03:35. Reason: added info.

  2. #2
    palladium NNTP User

    Default Re: zypper won't die

    have you opened top to see if maybe the monitor you are looking at is
    broken....or maybe zypper is a zombie?

    i'm not questioning your eyes, but i've never (yet) seen a process
    that couldn't be killed this way:

    in a terminal:

    Code:
    ps -A | grep -i zypper
    the output might be something like:

    Code:
    4182 ?        00:00:00 zypper
    4187 ?        00:10:13 zypper
    4194 ?        00:10:13 zypper
    it might be one line or lots of different lines, at this point we
    don't care, we just want those process numbers at the beginning of the
    line..

    since we can anticipate that zypper is being run by root, lets become
    root to kill it:

    Code:
    su -
    do not forget the dash, and give the root password when asked (you
    will not see what you type) and hit enter...the prompt will change and
    may be red, and will probably have one of these #

    so, now as root lets kill:

    Code:
    kill 4182
    hit enter and you should not get an error, instead just be returned to
    the command prompt..

    then do the same to kill all other process ID numbers you received as
    output from the ps -A command...

    some of the other numbers may or may not be killed when you kill an
    earlier number.....that is, killing one number _may_ kill several of
    the listed numbers....and, if it did then you will get an error kinda
    like: "No such process" or something like that when you try..

    kill all the numbers listed OR just do another:
    Code:
    ps -A | grep -i zypper
    to see if maybe all were killed already

    was that helpful/did it work? (if my instructions were too basic it
    wasn't because i didn't think you knew much, just i can't see from
    here your experience level....ok?)

    if that does not kill zypper then you may have to push that box over a
    cliff to kill it..

    BUT, post back with error messages if need be....before going to a
    cliff.. ;-)

    --
    palladium

  3. #3

    Default Re: zypper won't die

    Hm, my experience level is medium at this point. I can't really call myself a newbie anymore but certainly don't feel like an expert yet.

    I am a programmer so commands etc. certainly don't intimidate me.

    There were no error codes when executing kill and I had tried it before. There is only one process for zypper and it did not die going through the process of killing it.

    I am not sure what a zombie process is.

    I can see the same process number in the gnome system monitor and in htop (like top but a little nicer).

  4. #4

    Default Re: zypper won't die

    I looked up zombie process and it wasn't that. I did read however if a process is tied into the kernel tightly it won't let you kill it because that would put the kernel in an indeterminate state.

    I don't know if zypper when running in quiet mode is in the kernel's process space I figured about the only thing left was a reboot so that's what I did.

    However, now that I think about it, is there a way to determine if a process is in the kernel's or some other space?

    That would be great to know for figuring out what's going on and what to do about it.

  5. #5
    palladium NNTP User

    Default Re: zypper won't die

    hmmm, htop i like too...look at atop and ntop sometimes..

    as mentioned i've not run across a process that i couldn't kill, as
    root....so, i believe your level of technical ability and this
    question/need probably would be best served in a mail list where many
    of the developers hang out (instead of here, which is by and large new
    users and wanna be gurus willing to try and help'em, like me)..

    while waiting to see if someone who can/will answer here drops by,
    suggest you give a clear/concise background and ask your kernel
    space/mode question here:

    opensuse@opensuse.org - This is the list where most technical support
    and discussions can occur; start here!
    subscribe by sending mail to: opensuse+subscribe@opensuse.org

    an alternative place to catch the real gurus is in IRC, you can find a
    full list of all openSUSE mail lists and IRC channels on this page:
    http://en.opensuse.org/Communicate

    oh, if you can recall the circumstances of how zypper got hung up, and
    can duplicate it i'm pretty sure they want a bug report....yours
    sounds nasty, maybe someone else has had the same...you can learn if
    so here:

    http://en.opensuse.org/Submitting_Bug_Reports

    good luck, happy bug squashing--Have a lot of fun.

    --
    palladium

  6. #6

    Default Re: zypper won't die

    Thanks for all that information and I will certainly follow through with where the developers are.

    I don't think I can be of much help about how zypper got hung up as I didn't actually see it happen, I just saw that it had been there a long time and was wavering between 96% and 100% CPU time. Fortunately my processor is a 4 core so it didn't hang up the server - just one core.

    My best guess is that zypper comes as part of auto-updates which I have turned on to once a day... the server's not in production yet so it's fine that way for now.

    I'll keep a sharp eye out for the problem to reoccur so I can say something about how it happened if it comes up again.

    Again, thanks so much.

  7. #7
    palladium NNTP User

    Default Re: zypper won't die

    Reg gie wrote:
    > Again, thanks so much.


    welcome...do me (or us, or you) a favor, look in the file
    /var/log/zypper for the time in question and see what was going
    on...better yet, SAVE a copy somewhere so it won't get lost....say
    from the time the cron ran (two days earlier?) until you pulling the
    plug...you might see one log named zypper.log and one or several
    others which are archived...copy all those for the interesting time to
    some else...and protect them...maybe they are needed if it happens
    again (cross fingers it doesn't)..

    of course, if you look in (you should) you might find and can fix the
    problem...

    come back,

    --
    palladium

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •