Recently I installed Firefox 3.6 on my SuSE 11.0 system. In order to do that I had to uninstall Firefox 3.0 and install 3.6 from scratch from the mozilla repository. In order to upgrade Firefox I had to change xulrunner packages to satisfy dependencies.

As soon as I did that, my Zend Studio started quitting with this message:
/usr/local/Zend/ZendStudio-7.1.1/jre/bin/java: symbol lookup error: /usr/lib64/xulrunner-1.9.1.7/libxul.so: undefined symbol: gdk_x11_window_get_drawable_impl
In YaST I have these xulrunner packages:

xulrunner191 1.9.1.7-78.2-x86_64
mozilla-xulrunner191-gnomevfs 1.9.1.7-2.4-x86_64
mozilla-xulrunner192 1.9.2.0-2.1-x86_64
mozilla-xulrunner192-gnome 1.9.2.0-2.1-x86_64.

I am far from knowledgeable about the microscopic details of my system. I found a post here from someone who had this problem with Firefox itself. He added the Gnome factory repo and updated to gtk2 to 2.18 from there, but I'm on KDE I didn't want to rush in and do that without seeking more expert advice.

Does anyone have an idea how I can regain libxul.so: gdk_x11_window_get_drawable_impl?