Results 1 to 5 of 5

Thread: Ldapuserseach Problem

  1. #1

    Cool Ldapuserseach Problem

    Dear all,

    I put "src all_users {
    ldapusersearch ldap://192.168.1.215/cn=Domain%20Users,ou=Groups,ou=example,dc=lan?uid?sub?(&(objectclass=posixGroup)(uid=%s))
    }" in squidguard.conf,however,when I use "squidGuard -d" ,the log shows me that "syntax error in configfile /etc/squidguard.conf line 23",line 23 is the line which I put ldapusersearch,
    Can you show me where the syntax error is.
    any suggestion will be appreciated,thanks in advance!

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Ldapuserseach Problem

    Does your version of squidguard satisfy this condition mentioned in the docs?

    You need either squidGuard version 1.5 (or higher) or the ldapip patch by Denis Bonnenfant for ldapipsearch to work.

    SquidGuard

  3. #3

    Default Re: Ldapuserseach Problem

    I am using squidGuard 1.4,so I can not do ldapusersearch,but have to use ldapipsearch,right?

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Ldapuserseach Problem

    Whatever the doco says.

  5. #5

    Default Re: Ldapuserseach Problem

    I think I can use ldapusersearch function with my squidguard version,which is 1.4,but can not use ldapipsearch.for my syntax error,I have not found where the issue is,I have read the document from the official site(Tips for using LDAP),for the 4th step:configure with ldap,when I use "./configure --with-ldap=yes
    ",I got this error:-bash: ./configure: No such file or directory.

    If anyone has any ideas of what else I can do to fix it, do let me know. Thanks in advance.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •