Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: VirtualBox problem with 64 bit OS

  1. #1

    Default VirtualBox problem with 64 bit OS

    Hi,
    I have just installed openSUSE 11.2 64 bit and am getting some issues with VirtualBox which I didn't have with 32 bit system.

    I have been following the instructions posted in this forum (Virtual Box (Sun Version) Install How To,).

    First question concerns required packages. My 11.2 kernel version is 2.6.31.8-0.1.1 so I installed matching kernel-source. When I came to installing linux-kernel-headers however only version 2.6.31-3.4 was offered so I installed that.

    When I ran vboxdrv setup to rebuild the kernel module I received a pack of errors which are logged (see below) and the rebuild failed.

    I have also checked the system log and this reports:-
    kernel: [ 539.193906] warning: `VirtualBox' uses 32-bit capabilities (legacy support in use) This suggests to me that something is missing but what I have no idea.

    The vbox-install.log is very long but here are the first few lines:-

    Makefile:155: Warning: using /usr/src/linux as the source directory of your Linux kernel. If this is not correct, specify KERN_DIR=<directory> and run Make again.
    make KBUILD_VERBOSE=1 -C /usr/src/linux SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 modules
    test -e include/linux/autoconf.h -a -e include/config/auto.conf || ( \
    echo; \
    echo " ERROR: Kernel configuration is invalid."; \
    echo " include/linux/autoconf.h or include/config/auto.conf are missing."; \
    echo " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
    echo; \
    /bin/false)

    ERROR: Kernel configuration is invalid.
    include/linux/autoconf.h or include/config/auto.conf are missing.
    Run 'make oldconfig && make prepare' on kernel src to fix it.

    mkdir -p /tmp/vbox.0/.tmp_versions ; rm -f /tmp/vbox.0/.tmp_versions/*

    WARNING: Symbol version dump /usr/src/linux-2.6.31.8-0.1/Module.symvers
    is missing; modules will have no dependencies and modversions.

    Clearly I am missing something (as well as not knowing how to include quoted script in a box on this forum)!

    I have not found anything about this on Sun website yet but guess it is not a new problem. Can anybody advise please.

    Regards,
    Budgie2

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: VirtualBox problem with 64 bit OS

    Please check you have the required packages installed
    Virtual Box (Sun Version) Install HowTo - openSUSE Forums
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: VirtualBox problem with 64 bit OS

    Quote Originally Posted by caf4926 View Post
    Please check you have the required packages installed
    Virtual Box (Sun Version) Install HowTo - openSUSE Forums
    I followed these instructions as before and stated in my post, but there may be a version problem with linux-kernel-headers. Unless somebody knows where I can find a version matching the latest 11.2 64 bit kernel (2.6.31.8-0.1.1) then it looks like I shall have to revert to 2.6.31-3.4 which is the version of the headers available.

    Sun are very insistent upon matching versions but why is there not a more recent version of headers available or are there any suggestions as to where I might find it?

    Thanks for the quick reply
    Budgie2

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: VirtualBox problem with 64 bit OS

    You need the matching kernel-source package, not the matching linux-kernel-headers package.

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: VirtualBox problem with 64 bit OS

    kernel-source is easily missed, as it often doesn't get updated. Just check
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: VirtualBox problem with 64 bit OS

    oops, I'm overlapping with ken - sorry about that.

    If you do this from a terminal

    Code:
    rpm --query --all '*kernel*'
    post result
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: VirtualBox problem with 64 bit OS

    Quote Originally Posted by caf4926 View Post
    oops, I'm overlapping with ken - sorry about that.

    If you do this from a terminal

    Code:
    rpm --query --all '*kernel*'
    post result
    Hi there, here is the result:-

    kernel-debug-devel-2.6.31.8-0.1.1.x86_64
    kernel-default-devel-2.6.31.8-0.1.1.x86_64
    kernel-xen-devel-2.6.31.8-0.1.1.x86_64
    linux-kernel-headers-2.6.31-3.4.noarch
    kernel-syms-2.6.31.8-0.1.1.x86_64
    kernel-firmware-20090821-4.1.noarch
    kernel-desktop-2.6.31.8-0.1.1.x86_64
    kernel-source-2.6.31.8-0.1.1.noarch
    kernel-desktop-devel-2.6.31.8-0.1.1.x86_64

    As I explained the headers file does not match and Sun website insists this is important but I can't find anything more recent than 2.6.31-3.4
    I hope this will help.
    Regards,
    Budgie2
    I hope you can help.

  8. #8
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: VirtualBox problem with 64 bit OS

    That should be sufficient, it works for me with the same linux-kernel-headers version too. For some reason I can't explain the first line of your make output is different from mine. Your's says:

    make KBUILD_VERBOSE=1 -C /usr/src/linux SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 modules

    Mine says:

    make KBUILD_VERBOSE=1 -C /lib/modules/2.6.31.8-0.1-desktop/build SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 modules

    The difference is in the directory after -C.

    Maybe that will give you a clue where to look for the problem.

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: VirtualBox problem with 64 bit OS

    Quote Originally Posted by Budgie2 View Post
    Hi there, here is the result:-

    kernel-debug-devel-2.6.31.8-0.1.1.x86_64
    kernel-default-devel-2.6.31.8-0.1.1.x86_64
    kernel-xen-devel-2.6.31.8-0.1.1.x86_64
    linux-kernel-headers-2.6.31-3.4.noarch
    kernel-syms-2.6.31.8-0.1.1.x86_64
    kernel-firmware-20090821-4.1.noarch
    kernel-desktop-2.6.31.8-0.1.1.x86_64
    kernel-source-2.6.31.8-0.1.1.noarch
    kernel-desktop-devel-2.6.31.8-0.1.1.x86_64

    As I explained the headers file does not match and Sun website insists this is important but I can't find anything more recent than 2.6.31-3.4
    I hope this will help.
    Regards,
    Budgie2
    I hope you can help.
    I hate messy output. Half of that stuff you don't even need and heavens know why it's installed.

    My 64 bit box has Virtual Box compiled and I use the Desktop kernel and have the following

    kernel-source-2.6.31.8-0.1.1.noarch
    kernel-desktop-devel-2.6.31.8-0.1.1.x86_64
    linux-kernel-headers-2.6.31-3.4.noarch
    kernel-desktop-2.6.31.8-0.1.1.x86_64
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: VirtualBox problem with 64 bit OS

    Hi Budgie2,

    as I also have problems with 11.2-VBox-XP, I'm interested in the solution of your problem.

    thanx, Ralf

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •