Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: how to downgrade to 11.2?

  1. #1
    Join Date
    Nov 2009
    Posts
    21

    Exclamation how to downgrade to 11.2?

    Somehow a factory repo sneaked into my repo list. It was even labeled OpenSUSE 11.2!

    Anyways a zypper up resulted in a distribution upgrade (it should've been obvious ). It was actually fine until now I can't compile anything due to:
    /usr/include/linux/errno.h:4:23: error: asm/errno.h: No such file or directory
    Anyways this is a production system so in general using 11.3 is of course ill-advised.

    I've removed the nefarious 11.3 repo and tried a zypper dup, but this only resulted in various upgrades and no downgrades.

    The 'zypper dup' man page claims to do downgrades, but it didn't appear to be the case.

    Suggestions?

  2. #2
    Join Date
    Nov 2009
    Posts
    21

    Default Re: how to downgrade to 11.2?

    Huh actually I just needed to a zypper ref or I was misreading before. zypper dup does appear to be doing a downgrade operation.

    So I'll go ahead and do that. </famous last words>

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: how to downgrade to 11.2?

    Good luck
    So long as you now have the correct repos
    zypper dup should do it
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Nov 2009
    Posts
    21

    Default Re: how to downgrade to 11.2?

    zypper: /lib64/libc.so.6: version `GLIBC_2.11' not found (required by /lib64/libreadline.so.6)

    Fail...

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: how to downgrade to 11.2?

    Quote Originally Posted by eean View Post
    zypper: /lib64/libc.so.6: version `GLIBC_2.11' not found (required by /lib64/libreadline.so.6)

    Fail...
    I though zypper was already running?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Nov 2009
    Posts
    21

    Default Re: how to downgrade to 11.2?

    SCP and such still works. Is there a bootstrap tarball with enough in it to run zypper on 11.2 somewhere?

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: how to downgrade to 11.2?

    Quote Originally Posted by eean View Post
    SCP and such still works. Is there a bootstrap tarball with enough in it to run zypper on 11.2 somewhere?
    Sorry, I'm not understanding where you are at with this.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8
    Join Date
    Nov 2009
    Posts
    21

    Default Re: how to downgrade to 11.2?

    It was, but when a mirror hiccuped it did the "abort, retry, ignore". I said retry and it had to spawn some sort of process at that point. Pretty much 'scp' is the only executable that works.

  9. #9
    Join Date
    Nov 2009
    Posts
    21

    Default Re: how to downgrade to 11.2?

    Zypper is broken because of some sort of glibc mismatch with some of its dependent libraries. If zypper were to function again, I could continue the zypper dup and all would be well.

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: how to downgrade to 11.2?

    What it is, is once you remove a repo that was providing something and that something is still installed but is no longer available in the current repos. You get missing lib or packages.

    Try this. Logout, and do a console login and switch to level 3 and become su and type: yast

    See if you can get an unconditional update from view by repos and select system and do Update all in this list unconditionally.

    Boot to Level 3, then Yast and More.... - openSUSE Forums
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •