Results 1 to 4 of 4

Thread: trying to install Firefox 3.6 but YaST says "3.5 is needed"

  1. #1
    Join Date
    Aug 2008
    Location
    Seattle
    Posts
    80

    Default trying to install Firefox 3.6 but YaST says "3.5 is needed"

    I am on OpenSuSE 11.0 running Firefox 3.0. I want to upgrade Firefox to 3.5 or 3.6 but all I can find in /pub/opensuse/repositories/mozilla/openSUSE_11.0/x86_64 is MozillaFirefox-3.6.0-1.2.x86, or MozillaFirefox-branding-openSUSE 3.5-3.9.x86.

    When I try to install MozillaFirefox-branding-openSUSE 3.5-3.9.x86 I am told I need to install Firefox 3.5 because of failed dependencies. I have looked around on the internet for an RPM for this version but can't find it.

    Can someone help me by either telling me where I can find the correct RPM to install, or advise me with other instructions to wean my old 11.0 system of the old Firefox?

    By the way I can not upgrade this system to 11.1 or 11.2 because it is a production machine. However, I debug on this machine using Firebug and I would just like to bring these two tools up to date. Thanks for the help.

  2. #2

    Default Re: trying to install Firefox 3.6 but YaST says "3.5 is need

    You can find current versions for Mozilla Software here: Index of /repositories/mozilla

    Old versions (including FF 3.5) can be found here:
    Index of /repositories/mozilla:/legacy

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,756
    Blog Entries
    20

    Default Re: trying to install Firefox 3.6 but YaST says "3.5 is need

    Quote Originally Posted by fogelfish View Post
    I am on OpenSuSE 11.0 running Firefox 3.0. I want to upgrade Firefox to 3.5 or 3.6 but all I can find in /pub/opensuse/repositories/mozilla/openSUSE_11.0/x86_64 is MozillaFirefox-3.6.0-1.2.x86, or MozillaFirefox-branding-openSUSE 3.5-3.9.x86.

    When I try to install MozillaFirefox-branding-openSUSE 3.5-3.9.x86 I am told I need to install Firefox 3.5 because of failed dependencies. I have looked around on the internet for an RPM for this version but can't find it.

    Can someone help me by either telling me where I can find the correct RPM to install, or advise me with other instructions to wean my old 11.0 system of the old Firefox?

    By the way I can not upgrade this system to 11.1 or 11.2 because it is a production machine. However, I debug on this machine using Firebug and I would just like to bring these two tools up to date. Thanks for the help.
    Try doing an unconditional update on mozilla repo, like this but on mozilla
    carl4926 - Unconditional Update in Yast Software management
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Aug 2008
    Location
    Seattle
    Posts
    80

    Default Re: trying to install Firefox 3.6 but YaST says "3.5 is need

    It's been a while since I posted this. I should follow up with what happened. I tried an unconditional update on the mozilla repo and that did not work. I tried to find an old enough version of Firefox in an rpm and was unsuccessful.

    I ended up uninstalling Firefox and removing all of mozilla's firefox-related rpms that did not complain about other dependencies being broken. Once I did that I installed the latest Firefox rpm, which was successful.

    Coincidentally or not, soon after I did these things, my copy of Zend Studio started to crash and became unusable. I am still trying to figure out why, but it sure seems odd that it started misbehaving on the heels of the changes I made to Firefox.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •