Results 1 to 5 of 5

Thread: Ati Big-Desktop issue

  1. #1

    Default Ati Big-Desktop issue

    Using opensuse 11.2 with KDE

    With xinerama enabled I couldn't use compositing, so I tried my hand at Ati's "big-desktop"
    Left monitor, 1360x768, right monitor 1680x1050.

    Here is my current xorg.conf

    Code:
    Section "ServerLayout"                                                    
            Identifier     "aticonfig Layout"                                 
            Screen      0  "aticonfig-Screen[0]-0" 1360 0                     
    EndSection                                                                
    
    Section "Files"
    EndSection     
    
    Section "Module"
    EndSection      
    
    Section "Monitor"
            Identifier   "aticonfig-Monitor[0]-0"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
            Option      "DPMS" "true"
    EndSection
    
    Section "Device"
    
      #BusID       "PCI:1:0:0"
            Identifier  "aticonfig-Device[0]-0"
            Driver      "fglrx"
            Option      "DesktopSetup" "horizontal"
            Option      "VideoOverlay" "on"
            Option      "Monitor-DFP1" "0-DFP1"
            Option      "PairModes" "1366x768+1680x1050"
            BusID       "PCI:1:0:0"
    EndSection
    
    Section "Screen"
            Identifier "aticonfig-Screen[0]-0"
            Device     "aticonfig-Device[0]-0"
            Monitor    "aticonfig-Monitor[0]-0"
            DefaultDepth     24
            SubSection "Display"
                    Viewport   0 0
                    Depth     24
                    Modes    "1366x768" "1680x1050"
            EndSubSection
    EndSection
    The right monitor (1680x1050) is working great now, with compositing enabled (yay!), there's just a slight issue with the fonts being too little.

    The left monitor is running at 1680x1050 also, instead of the intended 1360x768

    Here is what aticonfig --list-pairmode says

    Code:
    aticonfig --list-pairmode
    Get pair modes : 2
     0    1366x768 + 1680x1050 --> 3046x1050
     1    1680x1050 + 1680x1050 --> 3360x1050
    Pairmode1 should be "1366x768 + 1680x1050", when I try "aticonfig --add-pairmode 1366x768+1680x1050" it doesn't make a difference

    Please advise

  2. #2

    Default Re: Ati Big-Desktop issue

    Update,

    Was able to remove the pairmode and get 1366*768 to index #1 but that doesn't make a difference at all..

    Help?

  3. #3

    Default Re: Ati Big-Desktop issue

    Wow, bloody hell, managed to fix it
    After literally hours and hours of trying to figure out the problem I've found it.

    Section "Device"

    #BusID "PCI:1:0:0"
    Identifier "aticonfig-Device[0]-0"
    Driver "fglrx"
    Option "DesktopSetup" "horizontal"
    Option "VideoOverlay" "on"
    Option "Monitor-DFP1" "0-DFP1"
    Option "PairModes" "1366x768+1680x1050"
    BusID "PCI:1:0:0"
    EndSection
    The thread on the ubuntu forums I was reading was using both Pairmode, and Pairmodes command. Turns out Pairmodes does nothing

    Don't I feel silly!

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,567
    Blog Entries
    38

    Default Re: Ati Big-Desktop issue

    Quote Originally Posted by xenth View Post
    Wow, bloody hell, managed to fix it
    After literally hours and hours of trying to figure out the problem I've found it.
    Congratulations on finding a solution, ... and THANK YOU for sharing it.

  5. #5

    Default Re: Ati Big-Desktop issue

    I'm sad to admit that I spoke too soon
    It was working properly when I made the post, changed one setting and the secondary screen reverted back to 1080i resolution (==not proper)

    Changed the setting back and the screen still won't return to normal.
    I've tried every single option available, experimented with everything I could find, started from scratch countless times, but I -cannot- for the life of me get this stupid setup to work.

    I've resorted to restoring my xinerama style (==no desktop effects) which is less pretty, but at least it works.
    After all the hours I put in this I'm gutted that it won't work properly, something that's literally 5 minutes of work in Windows, makes me cringe.

    Working xinerama xorg.conf, might help someone.

    Code:
    Section "ServerLayout"                     
    Identifier "aticonfig Layout"              
    Screen 0 "aticonfig-Screen[0]-0" 0 0       
    Screen "aticonfig-Screen[0]-1" LeftOf "aticonfig-Screen[0]-0"
    EndSection                                                   
    
    Section "Files"
    EndSection     
    
    Section "Module"
    EndSection      
    
    Section "ServerFlags"
    Option "Xinerama" "on"
    EndSection            
    
    Section "Monitor"
    Identifier "aticonfig-Monitor[0]-0"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"                              
    EndSection                                        
    
    Section "Monitor"
    Identifier "aticonfig-Monitor[0]-1"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"                              
    EndSection                                        
    
    Section "Device"
    Identifier "aticonfig-Device[0]-0"
    Driver "fglrx"                    
    BusID "PCI:1:0:0"                 
    EndSection                        
    
    Section "Device"
    Identifier "aticonfig-Device[0]-1"
    Driver "fglrx"                    
    BusID "PCI:1:0:0"                 
    Screen 1                          
    EndSection                        
    
    Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device "aticonfig-Device[0]-0"
    Monitor "aticonfig-Monitor[0]-0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection
    
    Section "Screen"
    Identifier "aticonfig-Screen[0]-1"
    Device "aticonfig-Device[0]-1"
    Monitor "aticonfig-Monitor[0]-1"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1360x768"
    EndSubSection
    EndSection
    - A very sad penguin.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •