Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: SMB keeps shuting down after about a minute

  1. #1

    Default SMB keeps shuting down after about a minute

    Hello everyone!

    I am new to linux and WAS a window user. boy am i glad i switched, but still have lots to learn. Any who, currently i am working on a server for some residents at my current job. I have DNS and everything setup right and it is working. Samba on the other hand is configured right but it keeps shutting down after about a minute. When i run this command:

    chksmb status

    it says "Dead". Ill restart the service(rcsmb start), and keep checking the status, and after about a minute it shuts down again. I have done a restart, double checked my configurations and still cant find why this is happening. (config file somewhere?)

    Now since im new, im not sure what info any of you would need to help me out, so please chime in, if there is a specific file or info you need to know, please let me know and ill try my best to get it. thanks so much in advance for the help and suggestions!!

  2. #2
    palladium NNTP User

    Default Re: SMB keeps shuting down after about a minute

    i know nothing about Samba (Friends don't let friends use, or network
    to, Windows) but this guy does (he is a moderator here in the openSUSE
    forums), see the upper left quadrant of his site:
    http://www.swerdna.net.au/linux.html

    --
    palladium

  3. #3

    Default Re: SMB keeps shuting down after about a minute

    thanks for the link

    I understand, i don't want to do this with Winblows workstations, but my work needs it done.

    that link is great, but unfortunately it does not fix my issue anyone else have other ideas?

  4. #4
    palladium NNTP User

    Default Re: SMB keeps shuting down after about a minute

    tbattista1 wrote:
    > that link is great, but unfortunately it does not fix my issue
    > anyone else have other ideas?


    well, while you wait on a real expert let me ask some questions:

    1. why is it that the command you say you used has *never* ever been
    used before (at least not where Google can find it--which is VERY
    strange!) see: <http://www.google.com/search?q="chksmb+status"> yeilds
    exactly *one* hit, your question!

    2. so, is there any evidence that Samba is "dead" before you run that
    command...or are you killing Samba with that command??

    oh, now i see (via google) that chksmb is a M$ utility...*WAIT*!
    google tells me "The purpose of the CHKSMB utility is to insure that
    mail and/or message bases are valid."

    what does that have to do with Samba?

    are you sure you are using the right M$ command? i wouldn't know, i've
    not used any Redmond since '95...

    --
    palladium

  5. #5

    Default Re: SMB keeps shuting down after about a minute

    oh wow.....sorry I didn't realize i typed the wrong command in my initial post. I'm actually using "rcsmb status".

    this is what ill see on my screen:

    #rcsmb status_________________________________dead
    #rcsmb start__________________________________running

    (wait about a min)

    #rcsmb status_________________________________dead

    i have looked at so many forums and it doesn't seem like anyone has seen this issue, which is leading me to believe that something in the OS broke?

  6. #6

    Default Re: SMB keeps shuting down after about a minute

    oh and i kept an eye on the log.smbd log and when the service switches to dead there is no error, BUT i notices that each time i started the service it said WARNING: The "Printer Admin" option is deprecated. what does that mean?

  7. #7
    palladium NNTP User

    Default Re: SMB keeps shuting down after about a minute

    > i have looked at so many forums and it doesn't seem like anyone has
    > seen this issue, which is leading me to believe that something in the OS
    > broke?


    wait a second! you have a unique situation that no one else has had
    and from that you determine it must be a broken OS??

    amazing, from the same set of facts i must wonder what is *unique*
    about your machine since *thousands* and *thousands* of other machines
    are not having this problem....and, my assessment is the uniqueness
    lies in one of several things:

    -your set up is somehow damaged, maybe by a faulty install or maybe
    through incorrect setup, or maybe by a bad sector on disk or a RAM
    fault which wrote incorrectly a setup parameter or or or or or

    -a hardware fault of some sort

    -a networking/routing fault

    and probably some other things you need to check before you rule them
    out and decided that the OS is broke despite the fact that it working
    EVERYWHERE else..

    now, lets investigate a little from the top:
    how did you install openSUSE?
    did you download an iso image? which one, what did you install?
    did you do a md5sum check prior to burning the disk?
    after burning the disk did you do this http://tinyurl.com/yajm2aq ?
    did you have any errors during the install?
    did you have to install more than once? why?
    did you install while connected to the internet? did you update while
    installing?

    have you updated since?
    have you enabled any non-default repos or used any 1-Click installs?

    which documentation did you use to set up Samba?
    what version of Samba are you running?
    did the error you are now seeing begin immediately after install, or
    did all work ok for a while and suddenly break?
    when you check the log files do you find any evidence of errors or
    warnings? what are they?

    --
    palladium

  8. #8

    Default Re: SMB keeps shuting down after about a minute

    i am not SAYING that the OS is broken, if you read it correctly you would see that i am asking a question if it could be a broken OS.

    any who,

    I installed 11.1 (32-bit) via ISO and burn to DVD.
    Booted computer to dvd disk, and yes i had it check the media first before installing.

    I followed this guide
    http://en.opemsuse.org/howto_setup_S...3_as_Samba_PDC

    no errors during install

    installed updates AFTER the OS was installed

    recent update was yesterday

    install was done while connected to the internet.

    Samaba version is 3.4.2-5.2
    no errors after install

    it seams that it worked, but then suddenly broke after all configuration was completed, which is why im hoping its just a config error, which is why im looking for help because i don't see anything that stands out.

    Logs did not show any errors except for, WARNING: The "Printer Admin" option is deprecated.

    I hope this helps and thank you for giving the time to help me. Its really appreciated

  9. #9
    palladium NNTP User

    Default Re: SMB keeps shuting down after about a minute

    > I hope this helps and thank you for giving the time to help me. Its
    > really appreciated


    unfortunately, i can't see the problem either...i was hoping to find
    out that your install disk was bad and you installed an error..

    one thing you might do (since you ask if their is a fault in the
    system) is to have a look yourself in the bug reports...it is open and
    easy to do:

    http://en.opensuse.org/Submitting_Bu...ching_for_Bugs

    good luck!

    --
    palladium

  10. #10

    Default Re: SMB keeps shuting down after about a minute

    i will check it out, thanks a bunch!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •