Results 1 to 5 of 5

Thread: Font problem on laptop (Dell Inspiron 1520)

Hybrid View

  1. #1

    Default Font problem on laptop (Dell Inspiron 1520)

    Wasn't really sure whether to put this in the hardware or applications section but here goes:

    The fonts on my laptop (Inspiron 1520 nvidia 8600m GT), on both KDE and gnome look strange (using opensuse 11.2). I've made a comparison with the desktop (using an intel graphics card) I use at work which displays fonts perfectly.

    I installed the driver via Yast after adding the nvidia repository (the desktop kernel one) and ran sax2 as well. I've updated to the latest kernel too.

    Here's a comparison between the two for the guardian website:

    On the laptop (notice how some of the fonts appear too big and are "overflowing"):

    Yfrog - guardianj

    Compared with the desktop where everything appears perfectly:

    Yfrog - screenshot1tm

    the Steam website looks fuzzy too

    Laptop Yfrog - steamw

    Desktop Yfrog - screenshot2f

    I've compared the fonts installed on both computers and they have the same ones installed, and they both have the same entries in the xorg.conf file under the fonts subsection.

    Any ideas would be great.

    Cheers

  2. #2

    Default Re: Font problem on laptop (Dell Inspiron 1520)

    Here's the contents of my xorg.conf file

    Code:
    # /.../
    # SaX generated X11 config file
    # Created on: 2010-01-21T17:31:33+0530.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    
    Section "Files"
      FontPath     "/usr/share/fonts/misc:unscaled"
      FontPath     "/usr/share/fonts/local"
      FontPath     "/usr/share/fonts/75dpi:unscaled"
      FontPath     "/usr/share/fonts/100dpi:unscaled"
      FontPath     "/usr/share/fonts/Type1"
      FontPath     "/usr/share/fonts/URW"
      FontPath     "/usr/share/fonts/Speedo"
      FontPath     "/usr/share/fonts/PEX"
      FontPath     "/usr/share/fonts/cyrillic"
      FontPath     "/usr/share/fonts/latin2/misc:unscaled"
      FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/Type1"
      FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
      FontPath     "/usr/share/fonts/baekmuk:unscaled"
      FontPath     "/usr/share/fonts/japanese:unscaled"
      FontPath     "/usr/share/fonts/kwintv"
      FontPath     "/usr/share/fonts/truetype"
      FontPath     "/usr/share/fonts/uni:unscaled"
      FontPath     "/usr/share/fonts/CID"
      FontPath     "/usr/share/fonts/ucs/misc:unscaled"
      FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
      FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/misc:unscaled"
      FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/Type1"
      FontPath     "/usr/share/fonts/misc/sgi:unscaled"
      FontPath     "/usr/share/fonts/xtest"
      FontPath     "/opt/kde3/share/fonts"
      InputDevices "/dev/gpmdata"
      InputDevices "/dev/input/mice"
    EndSection
    
    Section "ServerFlags"
      Option       "AllowMouseOpenFail" "on"
      Option       "ZapWarning" "on"
    EndSection
    
    Section "Module"
      Load         "dri"
      Load         "dbe"
      Load         "extmod"
      Load         "glx"
    EndSection
    
    Section "InputDevice"
      # Driver "kbd" will be disabled unless 'Option "AutoAddDevices" "off"' 
      # is set in "ServerFlags" section. 
      Driver       "kbd"
      Identifier   "Keyboard[0]"
      Option       "Protocol" "Standard"
      Option       "XkbLayout" "gb"
      Option       "XkbModel" "microsoftpro"
      Option       "XkbRules" "xfree86"
    EndSection
    
    
    Section "InputDevice"
      # Driver "mouse" will be disabled unless 'Option "AutoAddDevices" "off"' 
      # is set in "ServerFlags" section. 
      Driver       "mouse"
      Identifier   "Mouse[1]"
      Option       "Buttons" "12"
      Option       "Device" "/dev/input/mice"
      Option       "Name" "Logitech USB Optical Mouse"
      Option       "Protocol" "explorerps/2"
      Option       "Vendor" "Sysp"
      Option       "ZAxisMapping" "4 5"
    EndSection
    
    
    Section "Monitor"
      Option       "CalcAlgorithm" "XServerPool"
      DisplaySize  332 207
      HorizSync    50-70
      Identifier   "Monitor[0]"
      ModelName    "1440X900@60HZ"
      Option       "PreferredMode" "1440x900"
      VendorName   "--> VESA"
      VertRefresh  50-60
      UseModes     "Modes[0]"
    EndSection
    
    
    Section "Modes"
      Identifier   "Modes[0]"
    EndSection
    
    
    Section "Screen"
      DefaultDepth 24
      SubSection "Display"
        Depth      15
        Modes      "1440x900" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      SubSection "Display"
        Depth      16
        Modes      "1440x900" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      SubSection "Display"
        Depth      24
        Modes      "1440x900" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      SubSection "Display"
        Depth      8
        Modes      "1440x900" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      Device       "Device[0]"
      Identifier   "Screen[0]"
      Monitor      "Monitor[0]"
    EndSection
    
    
    Section "Device"
      BoardName    "GeForce 8600M GT"
      Driver       "nvidia"
      Identifier   "Device[0]"
      VendorName   "NVIDIA"
    EndSection
    
    
    
    Section "ServerLayout"
      Identifier   "Layout[all]"
      InputDevice  "Keyboard[0]" "CoreKeyboard"
      InputDevice  "Mouse[1]" "CorePointer"
      Option       "Clone" "off"
      Option       "Xinerama" "off"
      Screen       "Screen[0]"
    EndSection
    
    
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection
    
    Section "Extensions"
      Option       "Composite" "on"
    EndSection

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Font problem on laptop (Dell Inspiron 1520)

    Try switching to these settings
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: Font problem on laptop (Dell Inspiron 1520)

    Switching to Liberation sans did the trick! Cheers caf, is there any problem that you can't solve ?

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Font problem on laptop (Dell Inspiron 1520)

    Quote Originally Posted by Anonymous1986 View Post
    Switching to Liberation sans did the trick! Cheers caf, is there any problem that you can't solve ?
    I'm sure there is.
    Good to know it worked for you
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •