Hi,

I have two Nvida graphics procs with two monitors
GeForce 6150SE nForce 430 onboard (PCI:0:13:0) NEC monitor
GeForce 8400 GS in a PCI slot (PCI:0:13:0) Samsung Monitor
on a 64 PC running Suse 11.2 and KDE.

I installed the nvidia driver with Yast from download.nvidia.com as per instructions on that site.

When I booted only the Samsung displayed. The NEC was blank

I ran nvidia-settings which could see both video cards. The 6150/NEC was disabled. I enabled it, saved the configuration and rebooted.

Now I see the 8400/Samsung working fine, but the 6150/NEC is black, but the led is green showing it is getting a signal. The mouse is displayed on the Samsung as an arrow, when I move it across to the NEC it turn into an X.

I assume that this means the Xserver is working but for some reason the display is not initialised. As far as I can tell only one xserver is running.

I have tried to enable Xinerama but then both screens go blank when the Xserver starts.

Also Sax2 can only see the 8400 video card.

Any help welcome.

Thank you

/etc/X11/xorg.conf

(Sorry if this is long, I do not know how to put the text in the scrollable text boxes that a lot of experienced posters use.)

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder58) Wed Dec 9 16:35:48 PST 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Samsung SyncMaster"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 60.0
ModeLine "1920x1080" 148.500 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
ModeLine "1280x1024" 157.500 1280 1344 1504 1728 1024 1025 1028 1072 +hsync +vsync
Option "DPMS"
EndSection
Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor1"
VendorName "Unknown"
ModelName "NEC LCD1960NX"
HorizSync 31.0 - 81.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8400 GS"
BusID "PCI:2:0:0"
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6150SE nForce 430"
BusID "PCI:0:13:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1920x1080 +0+0; 1680x1050 +0+0; 1400x1050 +0+0; 1280x1024 +0+0; 1440x900 +0+0; 1280x960 +0+0; 1280x800 +0+0; 1152x864 +0+0; 1280x720 +0+0; 1024x768 +0+0; 800x600 +0+0; 640x480 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection