Results 1 to 6 of 6

Thread: help with XFCE Xorg!

  1. #1
    Join Date
    Aug 2008
    Location
    Minsk
    Posts
    105

    Unhappy help with XFCE Xorg!

    recently I've downloaded XFCE desktop environment on to my suse 11.2, cause i like it that much, unfortunately when i login into xfce after some time my xorg.org process starts to eat 98% of my CPU, don't know why, I turned off composition and other effects in my KDE and XFCE, but nothing helped, can anyone provide a clue ? thank you.

  2. #2

    Default Re: help with XFCE Xorg!

    The first thing to do is to type top in a terminal to find out which process is eating up your CPU resources.

  3. #3
    Join Date
    Aug 2008
    Location
    Minsk
    Posts
    105

    Default Re: help with XFCE Xorg!

    as i mentioned above, its "xorg" - the process, that starts to eat all my cpu up to 99 % after some time, even when my pc is in idle state, this issue is being discussed on some forums, but there is no anything that could help to solve it

  4. #4

    Default Re: help with XFCE Xorg!

    Well ... In such cases I usually restart X.

    You can try to boot in runlevel 3, set the variable WINDOWMANAGER to xfce :
    export WINDOWMANAGER=xfce
    and startx with startx

    It would also make sense to reenable CTRL-ALT-BKSP in order to be able to kill X from the keyboard with:
    setxkbmap -option terminate:ctrl_alt_bksp
    I put it in /etc/X11/xinit/xinitrc

    If the beep bothers you (as it does bother me), you can add:
    Option "ZapWarning" "off" in the "ServerFlags" section of /etc/X11/xorg.conf

    Once you have that you can start and exit X a couple times and see if the problem persist. You can also look at the running processes with : ps ax and in some log files in /var/log/messages and /var/log/Xorg.0.log.

    It can help to replace the line starting with
    xinit $client $clientargs -- $server $display $serverargs
    towards the end of /usr/bin/startx with
    xinit $client $clientargs -- $server $display $serverargs >> /tmp/Xout.log 2>&1

    so X will redirect a bunch of error messages in /tmp/Xout.log. This file might provide indications about what went wrong.

    It might look a little bit different for you since I use my own startx

    How did you install Xfce ?
    The best way to install it is with :

    zypper -t pattern xfce

  5. #5
    Join Date
    Aug 2008
    Location
    Minsk
    Posts
    105

    Default Re: help with XFCE Xorg!

    thank you a lot, i've installed xfce via yast software manager from the internet depositories while i was in KDE, well, I'm a newbie, so I know only some basic commands for linux, so i do everything i used to do when i was a windows user. thanks again, i'll try it.

  6. #6

    Default Re: help with XFCE Xorg!

    Quote Originally Posted by letian View Post
    thank you a lot, i've installed xfce via yast software manager from the internet depositories while i was in KDE
    That's fine too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •