Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 31

Thread: question about KDE updates

  1. #21
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: question about KDE updates

    If you want to post your repo's I'll have a look because you may well have some duplicates having used a Oneclick. Open a terminal and do:

    Code:
    zypper lr -d
    I have a bit of a guide here:
    Repository Management - openSUSE Forums

    In openSUSE 11.2 there have been some significant changes is software management and all repos should be at the same priority (99)
    You use the switcher to change priority to any given repo, like this example for Packman (the most likely one you will use)
    http://tinyurl.com/yejwull
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  2. #22
    Join Date
    Nov 2009
    Location
    Rome
    Posts
    110

    Default Re: question about KDE updates

    This is my repository situation,after your HowTo:

    I hope is correct..
    Is Libdvdcss repository necessary?
    NOTE: the KDE 4.3.4 repository is absent because this is another PC with the same system: openSuse 11.2

    The Package Manager indicate me for every repository the posibility of a SWITCH SYSTEM PACKAGE.
    Which switch should I do?
    Is it correct to maintain obsolet version of package in a conflict case?

  3. #23
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: question about KDE updates

    Quote Originally Posted by MaxiPigna View Post
    This is my repository situation,after your HowTo:

    I hope is correct..
    Is Libdvdcss repository necessary?
    NOTE: the KDE 4.3.4 repository is absent because this is another PC with the same system: openSuse 11.2

    The Package Manager indicate me for every repository the posibility of a SWITCH SYSTEM PACKAGE.
    Which switch should I do?
    Is it correct to maintain obsolet version of package in a conflict case?
    Once you have installed libdvdcss, you can remove that repository.

    The repos otherwise look fine. Except you don't have the kde4 desktop repo (as you comment)
    The repo for that would be:
    Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2

    Regarding the switching: If you already have or add the kde4 desktop, you should do this
    ImageBam - Fast, Free Image Hosting and Photo Sharing

    Then on Packman lastly do:
    http://tinyurl.com/yejwull
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #24
    Join Date
    Nov 2009
    Location
    Rome
    Posts
    110

    Default Re: question about KDE updates

    • Remove Libdvdcss repository - done
    • Switch of KDE Desktop repository - done
    • Switch of Packman repository - done


    I have a doubt: when must I switch a repository? If there are packages blue highlighted...
    I thought that the packages update was automatic.

  5. #25
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: question about KDE updates

    You don't need to do it again

    Now all you need do is open a su terminal and do

    Code:
    zypper up
    I never use the auto updater that sits in the tray. It's just rubbish.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #26
    Join Date
    Nov 2009
    Location
    Rome
    Posts
    110

    Default Re: question about KDE updates

    Oh ok..So update is manual,launching 'zypper up' command.
    Or is it possible automate this operation?

  7. #27
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: question about KDE updates

    By default there should be an updater applet in your tray, unless you removed it like I do?

    For me it's no use, I have too many complications for it to cope with.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #28
    Join Date
    Nov 2009
    Location
    Rome
    Posts
    110

    Default Re: question about KDE updates

    Thanks all caf4926...

  9. #29
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: question about KDE updates

    Quote Originally Posted by MaxiPigna View Post
    Thanks all caf4926...
    You are welcome
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #30

    Default Re: question about KDE updates

    Quote Originally Posted by caf4926 View Post
    It's advisable to stick with stable releases, in your early years anyway

    If you want to add the kde4 stable and matching community, you should get on well with those.

    Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2

    Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.2
    A slightly old thread I know, but it's linked to off the weekly news #108, so I figured I'd post here, in interests of others with the similar queries...

    By adding the STABLE and Community repos mentioned, one can come by the most recent KDE SC release (4.3.5 at the time of writing). However some other apps are stuck at quite old versions. E.g.:

    Amarok: 2.1.1 (2.2, 2.2.1, and 2.2.2 have all been released since)
    Digikam: 0.10.0 (current stable release is 1.0)

    The KDE:/43 repo seems to have up-to-date versions of these apps, but the actual KDE SC version is still at 4.3.4.

    Is there a repo setup that contains the most recent stable version of both KDE SC as well as the most recent stable versions (i.e. released as stable by the relevant projects) of independently released, but nonetheless associated, apps too?

    (FWIW, I don't really understand why apps like Amarok or Digikam are in with the KDE SC packages, and not in Community, but maybe that's just me )

Page 3 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •