Results 1 to 7 of 7

Thread: Always got ERROR during installing

  1. #1

    Default Always got ERROR during installing

    Hi, there! This is my first post.

    I installed openSuse 11.2 using x86_64-KDE Live CD last Wednesday and this is my first distro. So, i don't even know anything about Linux.

    I have been googling this whole time and even asking in other forum, but i still fail to install any software, except Opera browser.

    1. I try to set-up PPPoE and have been following this tutorial - How-to configure a PPPoE Broadband Internet Connection in OpenSuSE 11.0. But, it required me to install KInternet.

    I have downloaded KInternet from this website, but I always got this ERROR messaage, which required dependencies [
    Code:
    warning: kinternet-0.75-308.1.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 2e1efa87
    error: Failed dependencies:
            libDCOP.so.4()(64bit) is needed by kinternet-0.75-308.1.x86_64
            libkdecore.so.4()(64bit) is needed by kinternet-0.75-308.1.x86_64
            libkdeui.so.4()(64bit) is needed by kinternet-0.75-308.1.x86_64
            libkio.so.4()(64bit) is needed by kinternet-0.75-308.1.x86_64
            libkwalletclient.so.1()(64bit) is needed by kinternet-0.75-308.1.x86_64
            libnetworkstatus.so.0()(64bit) is needed by kinternet-0.75-308.1.x86_64
            libqt-mt.so.3()(64bit) is needed by kinternet-0.75-308.1.x86_64
    2. I try to install jdk6.bin to my system. But then again, i got this ERROR message again:
    [
    Code:
    Do you agree to the above license terms? [yes or no]
    yes
    Unpacking...
    Checksumming...
    Extracting...
    UnZipSFX 5.50 of 17 February 2002, by Info-ZIP (Zip-Bugs@lists.wku.edu).
      inflating: jdk-6u18-linux-amd64.rpm
      inflating: sun-javadb-common-10.5.3-0.2.i386.rpm
      inflating: sun-javadb-core-10.5.3-0.2.i386.rpm
      inflating: sun-javadb-client-10.5.3-0.2.i386.rpm
      inflating: sun-javadb-demo-10.5.3-0.2.i386.rpm
      inflating: sun-javadb-docs-10.5.3-0.2.i386.rpm
      inflating: sun-javadb-javadoc-10.5.3-0.2.i386.rpm
    error: can't create transaction lock on /var/lib/rpm/__db.000 (No such file or directory)
    Installing JavaDB
    error: can't create transaction lock on /var/lib/rpm/__db.000 (No such file or directory)
    3. Since, until now I cant set-up PPPoE in my home, I cant connect to Internet using openSuse. So, this time I decided to go to my school which provides Wi-Fi (easier to set-up Wi-Fi compare to PPPoE).

    When I open Yast -> Software Management, I have been waiting nearly 5 hours for this state (see the picture below) and nothing happen.


    Please, any help would be good for me. I really appreciate for anyone who trying to help me.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,738
    Blog Entries
    20

    Default Re: Always got ERROR during installing

    Can you browse with a web browser OK.? If yes. Try this

    Open a terminal and become su
    Become su in Terminal - HowTo - openSUSE Forums

    In there type

    Code:
    zypper up
    report back
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    palladium NNTP User

    Default Re: Always got ERROR during installing

    iamatimebender wrote:
    > Please, any help would be good for me. I really appreciate for anyone
    > who trying to help me.


    -welcome- to freedom, but stop trying to install software like you did
    on another operating system (Redmond: go to a web site, download
    something, then install it) instead open YaST, click on Software
    Management, search for (for example) KInternet or java, click on it
    and press "Accept"..

    read more about how to get things done here (the more you try to do it
    the WRONG way, the more hard it is): http://en.opensuse.org/Concepts

    as for problems at school, on wi-fi: maybe the school is blocking
    access...ask the system administrator ..

    --
    palladium

  4. #4

    Default Re: Always got ERROR during installing

    Quote Originally Posted by caf4926 View Post
    Can you browse with a web browser OK.? If yes. Try this

    Open a terminal and become su
    Become su in Terminal - HowTo - openSUSE Forums

    In there type

    Code:
    zypper up
    report back
    Yes, I can browse with any web browser. Today, i have tried what you said before. And, still I got an ERROR Message:
    Code:
    linux-tten:/ # zypper up
    Retrieving repository 'openSUSE-11.2-Non-Oss' metadata [/]Failed to download /repodata/repomd.xml from http://download.opensuse.org/distribution/11.2/repo/non-oss/

    1. Yesterday, I finished downloading 4.7GB DVD (it took me many days to download it) and I installed the KInternet as the Tutorial did said. It works perfectly fine.

    The problem is I need to install 4.7GB DVD just to install KInternet. It really doesn't make any sense to me. If I know that it will happen to me like this, I would download 4.7GB DVD at first time, instead of download Live CD.

    2. Yesterday, I was not sure how did I install jdk and even I dont know whether it was installed or not. After I inserted the DVD (no connection to internet), I open Yast and click Add-On Package and set the URL to DVD. After that, the Software Management Window pop-up and I type KInternet on the search box and click on it and click Accept.

    During the process, I saw so many things that being installed (i'm not sure) on the list box and I saw java and jdk on the list box as well.

    After the process finished, I search jdk by using the keyword java at Software Management. I saw checkbox (black box with the green tick). Does it mean that the jdk was installed perfectly?

    Where can I find the location of all the software that had been installed? I mean like in Windows OS, we can find it in Drive C:/ inside of the program files folder.

    3. Again, today, I have been waiting for software Management and nothing happen. What should I do? Everyone said, if you want to install software, open Software Management, but nothing happen.

    Note: I need to use internet connection at my school as I overused my internet plan this month.

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,738
    Blog Entries
    20

    Default Re: Always got ERROR during installing

    If you can't currently connect to the internet you should disable all online repos - do that in Software Repositories.

    Installed packages are a Black Tick in the check box
    A Green tick means a package that is due to be installed.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: Always got ERROR during installing

    I can connect to Internet if I'm in school. Everyday, I go to my school and bring my laptop.

    About the jdk, does it mean it hasn't been installed? How to install it? I just select jdk Software Management and click "Accept", right?

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,738
    Blog Entries
    20

    Default Re: Always got ERROR during installing

    Quote Originally Posted by iamatimebender View Post
    I can connect to Internet if I'm in school. Everyday, I go to my school and bring my laptop.

    About the jdk, does it mean it hasn't been installed? How to install it? I just select jdk Software Management and click "Accept", right?
    Accept yes.

    But if your online repos are enabled and your are offline, you may well get errors.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •