Results 1 to 10 of 10

Thread: Problem launching programs kde 4.4RC1

  1. #1
    Join Date
    Sep 2009
    Location
    Seattle, WA
    Posts
    276

    Unhappy Problem launching programs kde 4.4RC1

    Hi all:

    I suspect this is a kde problem but someone here may have some advise.

    I did a one-click install of kde 4.4RC1 from the openSUSE factory repos. No errors were displayed (other than dependency ones) during or after the install.

    However, now when I try to open a file requiring another program (i.e. a pdf file & xpdf) it does nothing. This is in a file manager (tried both krusader and dolphin). When I right click on a file and try to "open with" and select the correct program, it still does nothing, no messages or bouncing balls.

    There are also no appropriate error messages in /var/logs/* when I searched it.

    I've checked the "Configure Desktop > Advanced > File Associations" but they all look proper and show the programs I want.

    The files all run with the associated programs when opened from CLI.


    The only message I got after install (in yast) was "did not install ssh" which should not affect this problem anyway.
    Code:
    tom@laptop:~/Documents> /usr/bin/xpdf /downloads/SEATTLE_110309.pdf
    tom@laptop:~/Documents>
    From CLI this input brings xpdf up displaying the file just file but double clicking on it in the file managers does nothing.

    Any suggestions?
    Tom Taylor - retired penguin
    AMD Phenom II x4 955 -- 4GB RAM -- 2x1.5TB sata3
    openSUSE 12.3x86_64 openSUSE 13.1-M2x86_64
    KDE 4.8.5, FF 14.0.1 - 8- KDE 4.10.0, FF 20.0
    registered linux user 263467

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: Problem launching programs kde 4.4RC1

    Please post result of

    Code:
    zypper lr -d
    and

    Code:
    ked4-config -v
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Sep 2009
    Location
    Seattle, WA
    Posts
    276

    Default Re: Problem launching programs kde 4.4RC1

    Quote Originally Posted by caf4926 View Post
    Please post result of

    Code:
    zypper lr -d
    and

    Code:
    ked4-config -v
    Code:
    tom@laptop:~/Documents> zypper lr -d
    #  | Alias                          | Name                                        | Enabled | Refresh | Priority | Type   | URI                                                                                  | Service
    ---+--------------------------------+---------------------------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------------------+--------
    1  | Education                      | Education                                   | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/Education/openSUSE_11.2/                   |        
    2  | Emulators                      | Emulators                                   | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_11.2/             |        
    3  | KDE4_Community                 | KDE4 Community                              | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.2/        |        
    4  | KDE:KDE4:Factory:Desktop       | KDE:KDE4:Factory:Desktop                    | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.2/ |        
    5  | KDE_4_core_repo                | KDE 4 core repo                             | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2/  |        
    6  | Libdvdcss repository           | Libdvdcss repository                        | No      | No      |   99     | rpm-md | http://opensuse-guide.org/repo/11.2/                                                 |        
    7  | Packman KDE3 Repository        | Packman KDE3 Repository                     | No      | No      |   99     | rpm-md | http://ftp.skynet.be/pub/packman/suse/kde3/11.2/                                     |        
    8  | Packman2                       | Packman2                                    | No      | No      |   98     | rpm-md | http://packman.unixheads.com/suse/11.2/                                              |        
    9  | Packman3                       | Packman3                                    | No      | No      |   95     | rpm-md | http://packman.jacobs-university.de/suse/11.2/                                       |        
    10 | X11:Utilities                  | X11:Utilities                               | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/X11:/Utilities/openSUSE_11.2/              |        
    11 | devel:languages:perl           | devel:languages:perl                        | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_11.2/      |        
    12 | download.opensuse.org-mozilla  | openSUSE BuildService - Mozilla             | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.2/                     |        
    13 | download.opensuse.org-standard | Main Repository (Contrib)                   | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/11.2:/Contrib/standard/          |        
    14 | download.opensuse.org-webcam   | openSUSE BuildService - Drivers for webcams | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/drivers:/webcam/openSUSE_11.2/             |        
    15 | download.videolan.org-SuSE     | VideoLan Repository                         | No      | No      |   95     | rpm-md | http://download.videolan.org/pub/videolan/vlc/SuSE/11.2/                             |        
    16 | ftp.skynet.be-suse             | Packman Repository                          | No      | No      |   97     | rpm-md | http://ftp.skynet.be/pub/packman/suse/11.2/                                          |        
    17 | openSUSE 11.2-0                | openSUSE 11.2-0                             | Yes     | No      |   99     | yast2  | cd:///                                                                               |        
    18 | openSUSE-factory-repo-non_oss  | openSUSE-factory-repo-non_oss               | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/factory/repo/non-oss/                                   |        
    19 | openSUSE-factory_repo          | openSUSE-factory repo-oss                   | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/factory/repo/oss/                                       |        
    20 | openSUSE:11.2:Update           | openSUSE:11.2:Update                        | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.2/                                            |        
    21 | openSUSE:Factory:Contrib       | openSUSE:Factory:Contrib                    | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Factory:/Contrib/openSUSE_11.1/  |        
    22 | repo-debug                     | openSUSE-11.2-Debug                         | No      | No      |   99     | yast2  | http://download.opensuse.org/debug/distribution/11.2/repo/oss/                       |        
    23 | repo-non-oss                   | openSUSE-11.2-Non-Oss                       | No      | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/non-oss/                         |        
    24 | repo-oss                       | openSUSE-11.2-Oss                           | No      | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/oss/                             |        
    25 | repo-source                    | openSUSE-11.2-Source                        | No      | No      |   99     | yast2  | http://download.opensuse.org/source/distribution/11.2/repo/oss/                      |
    Yes, too many repos, but I'm only using a few of them. Need to clean things up a bit.
    Code:
    tom@laptop:~/Documents> kde4-config -v
    Qt: 4.6.0
    KDE Development Platform: 4.3.90 (KDE 4.3.90 (KDE 4.4 RC1)) "release 212"
    kde4-config: 1.0
    Tom Taylor - retired penguin
    AMD Phenom II x4 955 -- 4GB RAM -- 2x1.5TB sata3
    openSUSE 12.3x86_64 openSUSE 13.1-M2x86_64
    KDE 4.8.5, FF 14.0.1 - 8- KDE 4.10.0, FF 20.0
    registered linux user 263467

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: Problem launching programs kde 4.4RC1

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Sep 2009
    Location
    Seattle, WA
    Posts
    276

    Default Re: Problem launching programs kde 4.4RC1

    Quote Originally Posted by caf4926 View Post
    Unfortunately the image won't open. I'll try rebooting into windoze and see if I can do it there.
    Tom Taylor - retired penguin
    AMD Phenom II x4 955 -- 4GB RAM -- 2x1.5TB sata3
    openSUSE 12.3x86_64 openSUSE 13.1-M2x86_64
    KDE 4.8.5, FF 14.0.1 - 8- KDE 4.10.0, FF 20.0
    registered linux user 263467

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: Problem launching programs kde 4.4RC1

    Try it from here
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Sep 2009
    Location
    Seattle, WA
    Posts
    276

    Talking Re: Problem launching programs kde 4.4RC1

    Quote Originally Posted by caf4926 View Post
    Try it from here
    Thanks, caf, that seems to have fixed the problem. Took a few logins for everything to settle down and work properly.

    Had to get out of linux and into windoze to see the image. Couldn't open it from my image viewers (URL). Will have to research how to do that.
    Tom Taylor - retired penguin
    AMD Phenom II x4 955 -- 4GB RAM -- 2x1.5TB sata3
    openSUSE 12.3x86_64 openSUSE 13.1-M2x86_64
    KDE 4.8.5, FF 14.0.1 - 8- KDE 4.10.0, FF 20.0
    registered linux user 263467

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: Problem launching programs kde 4.4RC1

    Couldn't open it from my image viewers (URL). Will have to research how to do that.
    This is very odd!

    What exactly is Your Image Viewer? - You just click it and it opens a new tab in FFox.

    Happy to hear things are better though
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9
    Join Date
    Sep 2009
    Location
    Seattle, WA
    Posts
    276

    Unhappy Re: Problem launching programs kde 4.4RC1

    Quote Originally Posted by caf4926 View Post
    This is very odd!

    What exactly is Your Image Viewer? - You just click it and it opens a new tab in FFox.

    Happy to hear things are better though
    Spoke too soon. Problem is back again in a different way. Now I can't open root mode programs (krusader & dolphin). Can launch them from terminal as root but not as user from the start menu icons. Just get the bouncing balls but no message or action.

    By the way, the image viewer is gwenview which worked prior to the original problem and is working again now.
    Tom Taylor - retired penguin
    AMD Phenom II x4 955 -- 4GB RAM -- 2x1.5TB sata3
    openSUSE 12.3x86_64 openSUSE 13.1-M2x86_64
    KDE 4.8.5, FF 14.0.1 - 8- KDE 4.10.0, FF 20.0
    registered linux user 263467

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: Problem launching programs kde 4.4RC1

    Quote Originally Posted by tommyttt View Post
    Spoke too soon. Problem is back again in a different way. Now I can't open root mode programs (krusader & dolphin). Can launch them from terminal as root but not as user from the start menu icons. Just get the bouncing balls but no message or action.

    By the way, the image viewer is gwenview which worked prior to the original problem and is working again now.
    Are you telling me that when you click a http link to a image it starts gwenview? That would be very strange.

    As for the dolphin and krusader root modes - It's possible you have more than a few complications as a result of that repo list, I can't really tell what you have installed form where. If you look at Yast - Software Management, filter by repository and select the 'system' and scroll the list, do you see many red versions?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •