Results 1 to 4 of 4

Thread: no sound

  1. #1

    Default no sound

    Stats: Dual Boot Vista and Opensuse 11.2 Gnome I think.
    Speakers are working in Vista. Not working in OpenSuse.
    Just got Nvidia installed.
    NVIDIA Quadro NVS 290.
    I see some stuff in YAST about sound but it doesn't seem to address the problem. I'm new to OpenSuse so please bare with me.
    Thanks for OpenSuse.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: no sound

    Quote Originally Posted by JackPS View Post
    Stats: Dual Boot Vista and Opensuse 11.2 Gnome I think. Speakers are working in Vista. Not working in OpenSuse. Just got Nvidia installed.
    NVIDIA Quadro NVS 290. I see some stuff in YAST about sound but it doesn't seem to address the problem.
    OK, good on ya for checking in Vista. That confirms that your wiring for your speakers are setup correctly.

    In general, I recommend if you have a problem getting your sound card to work, please go here:
    SDB:AudioTroubleshooting - openSUSE

    If that that does not help you get your basic sound working (or if it is simply too complex given your relative newness to all of this), then please post in this sub-forum, providing in your post the following information:
    • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
      SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. ie run the script:
      Code:
      /usr/sbin/alsa-info.sh
      and select the SHARE/UPLOAD option when asked. After the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL. Just the URL.
    • in a terminal, or xterm, or konsole, type: rpm -qa '*alsa*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -qa '*pulse*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
    • in a terminal, or xterm, or konsole, type: uname -a #and post output here
    • for openSUSE-11.2 or later, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here


    There is also guidance for new users here, in setting up their multimedia: Multi-media and Restricted Format Installation Guide - openSUSE Forums

    Note when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

    speaker-test -Dplug:front -c2 -l5 -twav

    Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

    If that test yields errors (and its not uncommon to get errors there), try instead this more simple test:
    speaker-test -c2 -l5 -twav
    You should hear a female voice saying 'FRONT LEFT', 'FRONT RIGHT' five times. Its quite common that one of those speaker tests will work and one will NOT work, so don't be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version ... etc ... ).

    Or alternatively, if neither of those two tests work, then for testing the simple playback, use aplay program. Prepare a WAV file (which I arbitrarily called "somefile.wav" ) and simply run like:
    Code:
    aplay -vv somefile.wav
    With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

    Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

  3. #3

    Default Re: no sound

    Thank you for your response.
    Just went into Yast and clicked on "Sound".
    Got the sound window configuration and down in the lower Right
    Hand Corner I clicked on "other".
    When the next windows came up I clicked on "Play test Sound".
    Low and behold I heard something.
    Does this mean my sound is working? I didn't do anything.
    But I don't hear anything else even when I boot up OpenSuse.
    Maybe I didn't have the volume on the speakers turned up enough.
    They work fine with windows

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: no sound

    Quote Originally Posted by JackPS View Post
    When the next windows came up I clicked on "Play test Sound".
    Low and behold I heard something.
    Does this mean my sound is working?
    Most likely it does.

    Do any of the speaker-tests or the aplay provide sound?

    If you have sound, then please follow this guide for your applications (to sort codecs and install non-crippled multimedia): Multi-media and Restricted Format Installation Guide - openSUSE Forums

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •