Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: How to run IBUS input method on openSUSE 11.2?

  1. #1

    Default How to run IBUS input method on openSUSE 11.2?

    I just heard about the newly developed input method IBUS (ibus - Project Hosting on Google Code) the other day. Supposedly, it fixes a number of problems of SCIM (which, unfortunately, is pretty much dead upstream), and both Ubuntu and Fedora are moving toward making IBUS the standard input on their systems.

    Interestingly, there's nothing on the openSUSE forums yet, so this thread is supposed to fill the void and become, eventually, a how-to guide for running IBUS on openSUSE 11.2.

    I've tried to get IBUS running the past few days, but without succcess so far. Perhaps some of you how got it up and running already can help me out?

    What I got so far:

    REPOSITORIES:

    According to webpin, all relevant files are available under:
    Index of /repositories/home:/j-engel/openSUSE_11.2.

    Another user recommended the m17n devel repository:
    Index of /repositories/M17N:/Devel/openSUSE_11.2
    This might fix some problems I've been having, but

    The IBUS website also mentions the repository Index of /repositories/home:/swyear for openSUSE, but as far as I can see, the IBUS files don't exist there anymore.

  2. #2

    Default Re: How to run IBUS input method on openSUSE 11.2?

    INSTALLATION:

    So far, I've done the following:

    (1) Complete uninstalled all SCIM/SKIM-related packages.

    (2) Installed the following IBUS packages:
    Code:
    S | Name                         | Type    | Version            | Arch   | Repository            
    --+------------------------------+---------+--------------------+--------+------------------------------
    i | ibus                         | package | 1.1.0.20090612-1.7 | i586   | Extra_m17n (11.2 devel, ibus)
    i | ibus-anthy                   | package | 1.1.0.20090603-1.2 | i586   | Extra_m17n (11.2 devel, ibus)
    i | ibus-gtk                     | package | 1.1.0.20090612-1.7 | i586   | Extra_m17n (11.2 devel, ibus)
    i | ibus-m17n                    | package | 1.1.0.20090211-1.1 | i586   | Extra_m17n (11.2 devel, ibus)
    i | ibus-qt4                     | package | 1.1.0.20090612-1.7 | i586   | Extra_m17n (11.2 devel, ibus)
    i | libibus0                     | package | 1.1.0.20090612-1.7 | i586   | Extra_m17n (11.2 devel, ibus)
    (3) Tried the advice for running IBUS on the IBUS installation page (http://code.google.com/p/ibus/wiki/Install):

    Started ibus-daemon (was running already, but I re-did it anyway):
    Code:
     $ pkill -9 ibus
     $ ps -ef | grep ibus
     $ /usr/bin/ibus-daemon --xim &
    Set the environmental variables:
    Code:
    $ GTK_IM_MODULE=ibus 
    $ QT_IM_MODULE=ibus
    $ XMODIFIERS="@im=ibus"
    Then I tried to run ibus-setup, but I get stuck with an error message:
    Code:
    ~> ibus-setup
    Traceback (most recent call last):
      File "/usr/share/ibus/setup/main.py", line 28, in <module>
        import gtk
    ImportError: No module named gtk
    (This one I don't understand. I DID install the ibus-gtk package, so what is it complaining about?!)

    (4) I've also tried to open the IBUS Preferences dialog from KRunner, but that one doesn't work either.


    What are my next steps? What did I do wrong?

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,746

    Default Re: How to run IBUS input method on openSUSE 11.2?

    maybe you need the devel package??

  4. #4

    Default Re: How to run IBUS input method on openSUSE 11.2?

    I found out something tonight that may help you. I have two computers, both have openSUSE 11.2 (w/ KDE4 from default repo) and both have ibus with Japanese input.

    On Computer A, I was trying to type Japanese in kwrite but I wasn't able to. In fact, I wasn't able to type Japanese in any QT apps but it did work in all GTK apps.

    On Computer B, I was able to type Japanese in any apps.

    I found out what was different on the two computers... it was:

    Code:
    export GTK_IM_MODULE=ibus 
    export QT_IM_MODULE=ibus
    export XMODIFIERS=@im=ibus
    I removed the above lines from my .bashrc file on Computer A and rebooted. I was then able to type Japanese in any apps.

  5. #5

    Default Re: How to run IBUS input method on openSUSE 11.2?

    gogalthorp,

    I've added the relevant devel packages, I still get the error message when I try to open ibus-setup.


    londy,

    interesting. I took a look at my .bashrc file, but there's nothing in it (except one line irrelevant to the input method). I wonder which file contains the default settings for the environmental variables you mentioned by default?

    Interestingly, if I don't change the variables by hand, they look the following way after installing ibus & rebooting:

    Code:
    ~> echo $GTK_IM_MODULE
    ibus
    ~> echo $QT_IM_MODULE
    xim
    ~> echo $XMODIFIERS
    @im=ibus
    So, only the QT-relevant variable is apparently not set automatically.


    Anyway, the main problem seems to me that I can't open the setup/preferences dialog, so I'll probably have to work on that. Are you able to get the dialog if you type 'ibus-setup' in console?

    ... hmmm, does this mean that I have to compile everything from scratch?

  6. #6

    Default Re: How to run IBUS input method on openSUSE 11.2?

    I misunderstood your problem. I get it now, you can't even get the preferences dialog to show up and I assume no ibus in your system tray.

    When I run ibus-setup, the preferences dialog pops up. No problems for me.

    Did you remove everything from the j-engel repo and what command did you run to install ibus?

    I'm only using Japanese with it, but I don't have that "ibus-m17n" package installed.

  7. #7

    Default Re: How to run IBUS input method on openSUSE 11.2?

    Oh, I was wondering about the system tray ... I figured there should be something, but I got no ibus icon or anything in there ...

    It's strange, I removed all SKIM files and all ibus files from jengels, so theoretically there should be nothing interfering with the ibus package from the m17n devel repo. I installed them a couple of times in different ways (directly through yast2 / using zypper in ibus ibus-anthy, as you mentioned), but it always comes out to the same thing.

    Interestingly, it also doesn't seem to make any difference whether I use the packages from jengels or from m17n, since I end up with the same error message (and nothing in my sys tray).

    londy, how did you start with ibus? I assume you first had SCIM on your system, but erased it then and installed ibus through the command you told me earlier?

  8. #8

    Default Re: How to run IBUS input method on openSUSE 11.2?

    I wonder: Is there anyone else out there who installed ibus on a fresh openSUSE 11.2 installation?

  9. #9

    Default Re: How to run IBUS input method on openSUSE 11.2?

    londy, how did you start with ibus? I assume you first had SCIM on your system, but erased it then and installed ibus through the command you told me earlier?
    No, I installed ibus on the very first day that I installed opensuse 11.2 for both my computers. I never installed scim or uim on opensuse.

    Your error "ImportError: No module named gtk" seems to be related to python-gtk. Do you have it installed? Try re-installing it.

    Here are my other gtk related packages I have installed. Maybe you're missing something. I'm pretty sure these all came installed by default other than the ibus one.

    Code:
    i | gtk2                    | Library for Creation of Graphical User Interfaces-> | package
    i | gtk2-branding-openSUSE  | openSUSE theme configuration                        | package
    i | gtk2-engine-murrine     | Murrine GTK Theme Engine                            | package
    i | gtk2-engines            | Engines for GTK2 Themes                             | package
    i | gtk2-metatheme-gilouche | openSUSE themes and metathemes for gtk2 and metac-> | package
    i | gtk2-metatheme-sonar    | GTK+ and Metacity Sonar Theme                       | package
    i | ibus-gtk                | IBus im module for gtk2                             | package
    i | kcm_gtk                 | KDE control module for switching GTK+ style         | package
    i | python-gtk              | Python bindings for the GTK+ widget set             | package
    i | qtcurve-gtk2            | QtCurve style for Gtk2                              | package

  10. #10

    Default Re: How to run IBUS input method on openSUSE 11.2?

    londy,

    fantastic, python-gtk was the culprit. Actually it was missing from my installation, and after I installed it everything is working fine now (Japanese, Chinese, Hindi).

    If you have a second, could you check one thing for me?
    If you installed the ibus-m17n package, there should be several input methods under "Other", including one called "latin-pre" (latn-pre, I think it is actually). It used to input non-ascii latin characters like German umlauts and French accents; e.g. "+a should give you the German a-umlaut.

    Could you check whether it's working for you? For me, it actually isn't (e.g. when inputing the above, I get two characters, one quotation mark and a separate a), and since it's a very convenient input method, I'd like to figure out why.

    Cheers

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •