Page 1 of 4 123 ... LastLast
Results 1 to 10 of 35

Thread: Not-quite-so-super user mode...

  1. #1
    Join Date
    Dec 2009
    Location
    Find me...
    Posts
    71

    Question Not-quite-so-super user mode...

    Hi,

    Not sure if anyone else has had this problem before, so here goes.

    I recently installed openSUSE 11.2 64-bit with KDE and after running through the necessary installations for the sound/graphics card drivers and then running the YaST update I found that Flash player has no sound whatsoever, regardless of the browser used. Long story short, after a bit of searching and probing around the net and this forum, I managed to pin it down to something Chrysantine said not that long ago in this thread:

    I had a person today in IRC who said they had complete sound in the system otherwise but none in Flash. It turned out to be because Flash was using the *first* detected soundcard in the system, listed in /proc/asound/cards rather than the real card they wanted.
    So when I went to look inside said file, sure enough the wrong sound card was set as number 1, and the card I wanted to use as number 2 as shown below:

    Code:
     1 [Intel          ]: HDA-Intel - HDA Intel
                          HDA Intel at 0xf9ff8000 irq 22
     2 [DX             ]: AV200 - Xonar DX
                          Asus Virtuoso 100 (rev 2) at 0xd800, irq 18
    So I went to open it in KWrite and then saved the changes under the same name, except under the Documents folder since the original was read-only under normal circumstances and KWrite wouldn't let me write over it due to not having the permissions for it. Then I opened 'Applications' > 'System' > 'File Manager' > 'File Manager - Super User Mode', hoping that this would enable me to simply copy and paste the file in question without being prompted about permissions. However this won't let me copy and paste into the folder mentioned by Chrysantine. I right-click the file and choose copy, but when I go to right click into the other folder the paste option is greyed out. I can paste it pretty much anywhere else but not this folder for whatever reason.

    Any ideas why? Is there something I've missed here? Is there perhaps a way to open KWrite in super user mode? Any help would be appreciated.

    Thanks.


    Regards,

    Jon.

  2. #2
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    921

    Default Re: Not-quite-so-super user mode...

    You can open kwrite in superuser mode one of two ways:

    Code:
    kdesu kwrite /proc/asound/cards
    or

    Code:
    su - <enter> <password> kwrite /proc/asound/cards

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,491
    Blog Entries
    37

    Default Re: Not-quite-so-super user mode...

    Quote Originally Posted by jonitfcfan View Post
    So I went to open it in KWrite and then saved the changes under the same name, .
    Why do you not use YaST to change these settings?

    There is guidance here is step#9: SDB:AudioTroubleshooting - openSUSE - step#9

  4. #4
    Join Date
    Dec 2009
    Location
    Find me...
    Posts
    71

    Default Re: Not-quite-so-super user mode...

    Quote Originally Posted by oldcpu View Post
    Why do you not use YaST to change these settings?

    There is guidance here is step#9: SDB:AudioTroubleshooting - openSUSE - step#9
    Under YaST they are in the correct order I want them in. The Xonar DX is card 0, the HDA Intel (on-board) is card 1. Also if it helps I can get sound everywhere else.

  5. #5
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Not-quite-so-super user mode...

    Quote Originally Posted by jonitfcfan View Post
    Hi,

    Not sure if anyone else has had this problem before, so here goes.

    I recently installed openSUSE 11.2 64-bit with KDE and after running through the necessary installations for the sound/graphics card drivers and then running the YaST update I found that Flash player has no sound whatsoever, regardless of the browser used. Long story short, after a bit of searching and probing around the net and this forum, I managed to pin it down to something Chrysantine said not that long ago in this thread:



    So when I went to look inside said file, sure enough the wrong sound card was set as number 1, and the card I wanted to use as number 2 as shown below:
    The problem is /proc/asound/cards isn't a real file. Files under /proc are not real files. It is a pseudo-file that when read, displays some internal kernel state. This particular pseudo-file is always read-only. Chrysantine was reading it for problem solving. To actually modify the order of the sound cards the file to edit is /etc/modprobe.d/50-sound.conf, in particular the "alias" lines. It should be self-explanatory.

    So today you have learnt another fact about Linux.

  6. #6
    Join Date
    Dec 2009
    Location
    Find me...
    Posts
    71

    Default Re: Not-quite-so-super user mode...

    Going to bed now, it's around 02:40 here in the UK as I write this. Will pick this up in the morning (or afternoon, whichever is more convenient for me ). Thanks for the input...

  7. #7
    Join Date
    Dec 2009
    Location
    Find me...
    Posts
    71

    Default Re: Not-quite-so-super user mode...

    Good morning/afternoon/evening/night,

    I've just had a look at the file you suggested, ken_yap. This seems to all be in the order I want as below (I want the Xonar DX as primary):

    Code:
    options snd slots=snd-oxygen,snd-hda-intel
    # X3uT.hJ2fTVR7hHD:Virtuoso 100 (Xonar DX)
    alias snd-card-0 snd-oxygen
    # u1Nb.ub5J74xk772:82801JI (ICH10 Family) HD Audio Controller
    alias snd-card-1 snd-hda-intel
    If there is something I've missed here please let me know.

  8. #8
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Not-quite-so-super user mode...

    The strange thing from the output of your /proc/asound/cards is that your numbering starts from 1. Mine starts at 0, and is in the order specified by the aliases in /etc/modprobe.d/50-sound.conf. Perhaps somewhere in the bootup sequence you deactivated card 0 and reactivated it? I don't have any better ideas, this is the first time I'm seeing this kind of sequence.

    I assume you have done a reboot?

    If it doesn't work I would simply delete all entries in YaST and redetect them in the right order.

  9. #9
    Join Date
    Dec 2009
    Location
    Find me...
    Posts
    71

    Default Re: Not-quite-so-super user mode...

    Quote Originally Posted by ken_yap View Post
    The strange thing from the output of your /proc/asound/cards is that your numbering starts from 1. Mine starts at 0, and is in the order specified by the aliases in /etc/modprobe.d/50-sound.conf. Perhaps somewhere in the bootup sequence you deactivated card 0 and reactivated it? I don't have any better ideas, this is the first time I'm seeing this kind of sequence.

    I assume you have done a reboot?

    If it doesn't work I would simply delete all entries in YaST and redetect them in the right order.
    Yes I did do a reboot afterward. When that seemed to make no difference I tried the latter method in YaST and unfortunately this resulted in catastrophe: the card I wanted to redetect wouldn't let me do it, it kept giving me some error in loading the kernel module snd-oxygen. I did a bit of searching and the only relevent info I could find linked to this thread which then led to this article toward the end of the thread. However I've ruled out the possibility of the latter after the required probing was done. So I did a full re-install of openSUSE to get the sound back, not ideal really but since there wasn't much I'd saved on there no big loss really.

    Since then I've looked at the /proc/asound/cards file again and it's the same story with regard to starting from 1 rather than 0. If it helps, during the boot sequence, I do hear a loud clicking sound coming from my sound card to tell me it's being activated. This loud click can be heard once each time I boot into Windows, and is also heard (sometimes twice) when I boot into openSUSE. Perhaps this is what's causing /proc/asound/cards to start from 1 rather than 0? I'm not sure if any other Asus Xonar DX owners can vouch for this same sound, but at least the card itself seems to be fine.

    Perhaps it would be wise to log this with the ALSA team, as suggested at the end of the above linked thread. Also this thread seems to be tailing off from its original title so I'll probably start a new thread if I get any more problems later down the line.

    Thanks for your input.


    Regards,

    Jon.

  10. #10

    Default Re: Not-quite-so-super user mode...

    I just installed Opensuse and i didn't have sound for flash, but i had it for Amarok. I checked and I had the PCM volume to 0. I dont think it is going to be something so simple as that, but check anyway.

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •