Results 1 to 2 of 2

Thread: Evolution 2.29 issue(s)

  1. #1

    Exclamation Evolution 2.29 issue(s)

    HI.
    Running 11.2 with Gnome

    I was having trouble getting Evolution 2.28 from 11.2 to connect to my Exchange 2003 server using the MAPI connector. I was logged on/authenticated to the domain. I was getting errors about not being able to find passwords in the keyring, and 'Key file does not have group 'Passwords-ExchangeMAPI''.

    So I thought I would try the 0.29 version (evolution-mapi-0.29.4-1.4.x86_64.rpm) thinking that maybe it might be in better shape, in that regard, and installed it using the 1-Click option. It came from Index of /repositories/GNOME:/Evolution:/mapi/openSUSE_11.2_Evolution_snapshots but was the only one available. I installed it last night as I can't get Yast past our ISA proxy.It wound up upgrading my Evolution to 2.29 in the process.

    When I start Evolution now, I still have the keyring messages but also have an undefined symbol error and a missing function error (related?). Here's the log data:

    OLYMPUS\jc@hwlt13-OpenSuSE:~/Desktop> evolution
    (evolution:11746): e-data-server-DEBUG: Loading categories from "/home/OLYMPUS/jc/.evolution/categories.xml"
    (evolution:11746): e-data-server-DEBUG: Loaded 31 categories
    evolution-shell-Message: Preparing for online mode...
    evolution-shell-Message: Online preparations complete.
    *** nss-shared-helper: Using shared location /home/OLYMPUS/jc/.pki/nssdb
    ** (evolution:11746): DEBUG: Loading Exchange MAPI Plugin

    ** (evolution:11746): DEBUG: MAPI listener is constructed with 1 listed MAPI accounts

    (evolution:11746): evolution-plugin-lib-WARNING **: can't load plugin '/usr/lib64/evolution/2.30/plugins/liborg-gnome-exchange-operations': /usr/lib64/evolution/2.30/plugins/liborg-gnome-exchange-operations.so: undefined symbol: ldap_ntlm_bind

    (evolution:11746): evolution-plugin-lib-WARNING **: can't load plugin '/usr/lib64/evolution/2.30/plugins/liborg-gnome-exchange-operations': /usr/lib64/evolution/2.30/plugins/liborg-gnome-exchange-operations.so: undefined symbol: ldap_ntlm_bind
    e-data-server-ui-Message: Unable to find password(s) in keyring (Keyring reports: No matching results)
    e-data-server-ui-Message: Key file does not have group 'Passwords-ExchangeMAPI'

    (evolution:11746): evolution-plugin-lib-WARNING **: can't load plugin '/usr/lib64/evolution/2.30/plugins/liborg-gnome-exchange-operations': /usr/lib64/evolution/2.30/plugins/liborg-gnome-exchange-operations.so: undefined symbol: ldap_ntlm_bind

    (evolution:11746): e-utils-CRITICAL **: Plugin "Exchange Operations" is missing a function named eex_ui_mail_init()
    libexchangemapi-Message: exchange-mapi-connection.c:156: exchange_mapi_connection_close: lock(connect_lock)
    libexchangemapi-Message: exchange-mapi-connection.c:159: exchange_mapi_connection_close: unlock(connect_lock)
    evolution-shell-Message: Preparing to quit...
    evolution-shell-Message: Quit preparations complete.

    One other noted behavior is that if/when I start Evolution now and try to add a new mail account, the configuration assistant window opens, but the "Forward" button is grayed out. The same is true if starting it for the first time for a new user. When the initial dialog opens for the user to enter their name, etc., the dialog's "Forward" button is also grayed out.

    Thanks,
    john

  2. #2

    Default Re: Evolution 2.29 issue(s)

    This issue is resolved. a couple days after the original posting some updates were made available which resolved these issues.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •