Results 1 to 10 of 10

Thread: Setting up compiz 11.2

  1. #1

    Default Setting up compiz 11.2

    Im using opensuse 11.2 X64 with KDE and ati drivers.
    I want to set up compiz so I can use transparancy and the likes.

    I've used the 1-click installer provided for KDE and compiz is installed.
    I've ran a "check script" for compiz which indicated that there's no rendering method in use currently (AIGLX, Xgl or Nvidia

    Anyone point me in the right direction, there's lots of information to be found but it's either obsolete or confusing

    Xorg.conf
    Code:
    Section "ServerLayout"                                                 
            Identifier     "aticonfig Layout"                              
            Screen      0  "aticonfig-Screen[0]-0" 1360 0                  
            Screen         "amdcccle-Screen[1]-1" 0 282                    
    EndSection                                                             
    
    Section "Files"
    EndSection     
    
    Section "Module"
    EndSection      
    
    Section "ServerFlags"
            Option      "Xinerama" "on"
    EndSection                         
    
    Section "Monitor"
            Identifier   "aticonfig-Monitor[0]-0"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
            Option      "DPMS" "true"                              
    EndSection                                                     
    
    Section "Monitor"
            Identifier   "0-DFP1"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
            Option      "DPMS" "true"                              
            Option      "PreferredMode" "1680x1050"                
            Option      "TargetRefresh" "60"                       
            Option      "Position" "0 0"                           
            Option      "Rotate" "normal"                          
            Option      "Disable" "false"                          
    EndSection                                                     
    
    Section "Monitor"
            Identifier   "0-DFP2"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
            Option      "DPMS" "true"                              
            Option      "PreferredMode" "1360x768"                 
            Option      "TargetRefresh" "60"                       
            Option      "Position" "0 0"                           
            Option      "Rotate" "normal"                          
            Option      "Disable" "false"                          
    EndSection                                                     
    
    Section "Device"
    
      #BusID       "PCI:1:0:0"
            Identifier  "aticonfig-Device[0]-0"
            Driver      "fglrx"                
            Option      "Monitor-DFP1" "0-DFP1"
            BusID       "PCI:1:0:0"            
    EndSection                                 
    
    Section "Device"
            Identifier  "amdcccle-Device[1]-1"
            Driver      "fglrx"
            Option      "Monitor-DFP2" "0-DFP2"
            BusID       "PCI:1:0:0"
            Screen      1
    EndSection
    
    Section "Screen"
            Identifier "aticonfig-Screen[0]-0"
            Device     "aticonfig-Device[0]-0"
            Monitor    "aticonfig-Monitor[0]-0"
            DefaultDepth     24
            SubSection "Display"
                    Viewport   0 0
                    Virtual   3600 3600
                    Depth     24
            EndSubSection
    EndSection
    
    Section "Screen"
            Identifier "amdcccle-Screen[1]-1"
            Device     "amdcccle-Device[1]-1"
            DefaultDepth     24
            SubSection "Display"
                    Viewport   0 0
                    Depth     24
            EndSubSection
    EndSection
    Tia

  2. #2
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,021

    Default Re: Setting up compiz 11.2

    If you're using KDE4 you don't need Compiz to get "transparency and the likes". It's built into KDE with Kwin.
    It is possible to run Compiz with KDE4 but not recommended.
    My advice is to uninstall Compiz and go into Personal Settings > Desktop to enable Desktop effects. And then let us know if you're still having a problem (which would probably be related to your video card configuration).
    Günter

    Desk: Tumbleweed, KDE 5, AMD Ryzen 5 3400G, 16Gb, 120Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,038
    Blog Entries
    14

    Default Re: Setting up compiz 11.2

    Looks like this is missing, put it at the bottom of xorg.conf:

    Section "Extensions"
    Option "Composite" "enable"
    EndSection


    Edit: just saw gminnerup's post. He's right, you don't need compiz. But for the desktop effects in KDE4 you do need the above in your xorg.conf
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: Setting up compiz 11.2

    Quote Originally Posted by Knurpht View Post
    Looks like this is missing, put it at the bottom of xorg.conf:

    Section "Extensions"
    Option "Composite" "enable"
    EndSection


    Edit: just saw gminnerup's post. He's right, you don't need compiz. But for the desktop effects in KDE4 you do need the above in your xorg.conf
    I've removed compiz.

    Here's thew new xorg.conf, is this right?

    Code:
    Section "ServerLayout"                                                                                             
            Identifier     "aticonfig Layout"                                                                          
            Screen      0  "aticonfig-Screen[0]-0" 1360 0                                                              
            Screen         "amdcccle-Screen[1]-1" 0 282                                                                
    EndSection                                                                                                         
                                                                                                                       
    Section "Files"                                                                                                    
    EndSection                                                                                                         
                                                                                                                       
    Section "Module"                                                                                                   
    EndSection                                                                                                         
                                                                                                                       
    Section "ServerFlags"                                                                                              
            Option      "Xinerama" "on"                                                                                
    EndSection                                                                                                         
                                                                                                                       
    Section "Monitor"                                                                                                  
            Identifier   "aticonfig-Monitor[0]-0"                                                                      
            Option      "VendorName" "ATI Proprietary Driver"                                                          
            Option      "ModelName" "Generic Autodetecting Monitor"                                                    
            Option      "DPMS" "true"                                                                                  
    EndSection                                                                                                         
    
    Section "Monitor"
            Identifier   "0-DFP1"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
            Option      "DPMS" "true"                              
            Option      "PreferredMode" "1680x1050"                
            Option      "TargetRefresh" "60"                       
            Option      "Position" "0 0"                           
            Option      "Rotate" "normal"                          
            Option      "Disable" "false"                          
    EndSection                                                     
    
    Section "Monitor"
            Identifier   "0-DFP2"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
            Option      "DPMS" "true"
            Option      "PreferredMode" "1360x768"
            Option      "TargetRefresh" "60"
            Option      "Position" "0 0"
            Option      "Rotate" "normal"
            Option      "Disable" "false"
    EndSection
    
    Section "Device"
    
      #BusID       "PCI:1:0:0"
            Identifier  "aticonfig-Device[0]-0"
            Driver      "fglrx"
            Option      "Monitor-DFP1" "0-DFP1"
            BusID       "PCI:1:0:0"
    EndSection
    
    Section "Device"
            Identifier  "amdcccle-Device[1]-1"
            Driver      "fglrx"
            Option      "Monitor-DFP2" "0-DFP2"
            BusID       "PCI:1:0:0"
            Screen      1
    EndSection
    
    Section "Screen"
            Identifier "aticonfig-Screen[0]-0"
            Device     "aticonfig-Device[0]-0"
            Monitor    "aticonfig-Monitor[0]-0"
            DefaultDepth     24
            SubSection "Display"
                    Viewport   0 0
                    Virtual   3600 3600
                    Depth     24
            EndSubSection
    EndSection
    
    Section "Screen"
            Identifier "amdcccle-Screen[1]-1"
            Device     "amdcccle-Device[1]-1"
            DefaultDepth     24
            SubSection "Display"
                    Viewport   0 0
                    Depth     24
            EndSubSection
    EndSection
    
    Section "Extensions"
    Option "Composite" "enable"
    EndSection
    Desktop effects says the following,
    Compositing is not supported on your system.
    Required X extensions (XComposite and XDamage) are not available.
    Thanks so far guys

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,038
    Blog Entries
    14

    Default Re: Setting up compiz 11.2

    Something must be wrong in the xorg.conf

    In openSUSE 11.2 you don't need an xorg.conf anymore. Rename it, reboot and see how the system does by itself

    Please also post output of:

    rpm -qa | grep kernel-
    rpm -qa | grep xorg
    lsmod | grep fglrx
    su -c 'find / -name fglrx* -print'
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,021

    Default Re: Setting up compiz 11.2

    You've got Xinerama "on". Xinerama disables compositing. Well, at least on my NVIDIA setup, maybe it's different with ATI, I can't tell.
    Günter

    Desk: Tumbleweed, KDE 5, AMD Ryzen 5 3400G, 16Gb, 120Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  7. #7

    Default Re: Setting up compiz 11.2

    Quote Originally Posted by Knurpht View Post
    Something must be wrong in the xorg.conf

    In openSUSE 11.2 you don't need an xorg.conf anymore. Rename it, reboot and see how the system does by itself

    Please also post output of:

    rpm -qa | grep kernel-
    rpm -qa | grep xorg
    lsmod | grep fglrx
    su -c 'find / -name fglrx* -print'
    Hi, I think I still need xorg.conf, after renaming it and restarting X I just get a blinking black screen

    Here's the output you requested, thanks for replying

    Code:
    baas@werkstation:~> rpm -qa | grep kernel
    linux-kernel-headers-2.6.31-3.4.noarch    
    kernel-desktop-2.6.31.8-0.1.1.x86_64   
       
    baas@werkstation:~> rpm -qa | grep xorg
    xorg-x11-libxcb-7.4-11.1.x86_64         
    xorg-x11-libSM-7.4-7.1.x86_64           
    xorg-x11-libXext-7.4-7.1.x86_64         
    xorg-x11-server-7.4-61.63.1.x86_64      
    xorg-x11-libXext-32bit-7.4-7.1.x86_64   
    xorg-x11-libX11-7.4-12.3.x86_64         
    xorg-x11-fonts-core-7.4-6.3.noarch      
    xorg-x11-libXprintUtil-7.4-6.1.x86_64   
    xorg-x11-Xvnc-7.4-61.63.1.x86_64        
    xorg-x11-libXau-32bit-7.4-6.1.x86_64    
    xorg-x11-libXmu-32bit-7.4-6.1.x86_64    
    xorg-x11-libXp-32bit-7.4-6.1.x86_64     
    xorg-x11-libX11-ccache-7.4-2.4.x86_64   
    xorg-x11-libXfixes-7.4-6.1.x86_64       
    xorg-x11-libXv-7.4-6.1.x86_64           
    xorg-x11-libs-7.4-25.1.x86_64           
    xorg-x11-7.4-35.3.x86_64                
    xorg-x11-driver-video-radeonhd-1.3.0_20091026_8b89b9-1.1.1.x86_64
    xorg-x11-libICE-32bit-7.4-7.1.x86_64
    xorg-x11-libs-32bit-7.4-25.1.x86_64
    xorg-x11-libXt-7.4-6.1.x86_64
    xorg-x11-libXrender-7.4-6.1.x86_64
    xorg-x11-libXmu-7.4-6.1.x86_64
    xorg-x11-libfontenc-32bit-7.4-6.1.x86_64
    xorg-x11-libSM-32bit-7.4-7.1.x86_64
    xorg-x11-libXpm-32bit-7.4-6.1.x86_64
    xorg-x11-libXrender-32bit-7.4-6.1.x86_64
    xorg-x11-driver-video-7.4-87.90.1.x86_64
    xorg-x11-libICE-7.4-7.1.x86_64
    xorg-x11-driver-input-7.4-39.1.x86_64
    xorg-x11-fonts-7.4-6.3.noarch
    xorg-x11-libX11-32bit-7.4-12.3.x86_64
    xorg-x11-libXt-32bit-7.4-6.1.x86_64
    xorg-x11-libXau-7.4-6.1.x86_64
    xorg-x11-libfontenc-7.4-6.1.x86_64
    xorg-x11-libXp-7.4-6.1.x86_64
    xorg-x11-xauth-7.4-35.3.x86_64
    xorg-x11-libxcb-32bit-7.4-11.1.x86_64
    xorg-x11-libXfixes-32bit-7.4-6.1.x86_64
    xorg-x11-libXprintUtil-32bit-7.4-6.1.x86_64
    xorg-x11-libXdmcp-7.4-6.1.x86_64
    xorg-x11-libxkbfile-7.4-6.1.x86_64
    xorg-x11-libXpm-7.4-6.1.x86_64
    xorg-x11-libxkbfile-32bit-7.4-6.1.x86_64
    
    baas@werkstation:~> lsmod | grep fglrx
    fglrx                2279288  47
    
    baas@werkstation:~> su -c 'find / -name fglrx* -print'
    Password:
    /proc/irq/29/fglrx[0]@PCI:1:0:0
    /lib/modules/2.6.31.8-0.1-desktop/weak-updates/updates/fglrx.ko
    /lib/modules/2.6.31.5-0.1-desktop/updates/fglrx.ko
    /sys/bus/pci/drivers/fglrx_pci
    /sys/module/fglrx
    /usr/lib64/xorg/modules/drivers/fglrx_drv.so
    /usr/lib64/dri/fglrx_dri.so
    /usr/lib/dri/fglrx_dri.so
    /usr/include/X11/extensions/fglrx_gamma.h
    /usr/share/pixmaps/fglrx.png
    /usr/share/doc/packages/fglrx
    /usr/share/doc/packages/fglrx/fglrx_sample_source.tgz
    /usr/bin/fglrx_xgamma
    /usr/bin/fglrxinfo
    find: `/home/baas/.gvfs': Permission denied
    You've got Xinerama "on". Xinerama disables compositing. Well, at least on my NVIDIA setup, maybe it's different with ATI, I can't tell.
    Heya, if I remove that line from xorg.conf my secondary display can't be used anymore, please advise

    Sorry for slow reply guys.

  8. #8
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,021

    Default Re: Setting up compiz 11.2

    Quote Originally Posted by xenth View Post
    Heya, if I remove that line from xorg.conf my secondary display can't be used anymore, please advise

    Sorry for slow reply guys.
    There's two methods, as far as I know, of extending one desktop over two screens: Twinview, which is NVDIA only so you can't use it, or Xinerama. Xinerama, again AFAIK, disables compositing. If you disable Xinerama, there's only one desktop per monitor and in order to get two, now separate, desktops on the two monitors you have two enable two Xwindows. That way, you can move the mouse pointer from one to the other but not the windows, and applications will start wherever you launch them.
    Günter

    Desk: Tumbleweed, KDE 5, AMD Ryzen 5 3400G, 16Gb, 120Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  9. #9

    Default Re: Setting up compiz 11.2

    That doesn't sound like something I want Guess I'm stuck..thanks for replying.

  10. #10

    Default Re: Setting up compiz 11.2

    Madness with X----

    I also have the same problem i.e. compositing not supported and get the XComposite/XDamage messages.

    System here is an Intel 975 motherboard, 2 GB RAM 2 ea NVidia GeForce 8500 GT's PCIe. The two cards are driving 3 Samsung 204B monitors. I am under the impression that I need to use separate X screens since there are more than 2 monitors and 2 different graphics cards. Additionally the desktop is spread across all three monitors, with the taskbar docked on the left edge of the left most monitor. Nice large desktop because this machine is used in a semi production environment.

    I get a little more confused about where 11.2 is the more I read, about how under KDE 4.4. the ongoing multi monitor support and functionality and so forth.

    Im running KDE 4.3.5.011. Nvidia package is gfx-g02-kmp-desktop 190.53_2.6.31.5_0.1-8.1. kernel module and the graphics driver version 190.53-9.1.

    Now before, under SUSe 10.3 one used to have to edit the /etc/sysconfig file to decide which windows manager to use and get the effects i.e. rotating cube, wobblies &c. Now it seems that's no longer necessary. Additionally compositing is enabled in my xorg.conf file.

    Lets see.

    kernel-desktop-2.6.31.12-0.2.1.x86_64

    linux-r7d9:/home/carr # rpm -qa | grep xorg
    xorg-x11-libxcb-7.4-11.1.x86_64
    xorg-x11-libSM-7.4-7.1.x86_64
    xorg-x11-libXext-7.4-7.1.x86_64
    xorg-x11-server-7.4-61.63.1.x86_64
    xorg-x11-libfontenc-32bit-7.4-6.1.x86_64
    xorg-x11-libXp-32bit-7.4-6.1.x86_64
    xorg-x11-libX11-7.4-12.3.x86_64
    xorg-x11-fonts-core-7.4-6.3.noarch
    xorg-x11-libXprintUtil-7.4-6.1.x86_64
    xorg-x11-Xvnc-7.4-61.63.1.x86_64
    xorg-x11-libICE-32bit-7.4-7.1.x86_64
    xorg-x11-libXfixes-32bit-7.4-6.1.x86_64
    xorg-x11-libX11-ccache-7.4-2.4.x86_64
    xorg-x11-libXfixes-7.4-6.1.x86_64
    xorg-x11-libXv-7.4-6.1.x86_64
    xorg-x11-libs-7.4-25.1.x86_64
    xorg-x11-7.4-35.3.x86_64
    xorg-x11-libXau-32bit-7.4-6.1.x86_64
    xorg-x11-libXt-32bit-7.4-6.1.x86_64
    xorg-x11-libXt-7.4-6.1.x86_64
    xorg-x11-libXrender-7.4-6.1.x86_64
    xorg-x11-libXmu-7.4-6.1.x86_64
    xorg-x11-fonts-7.4-6.3.noarch
    xorg-x11-libxcb-32bit-7.4-11.1.x86_64
    xorg-x11-driver-video-radeonhd-1.3.0_20100216_79a0ab2-0.1.1.x86_64
    xorg-x11-libXrender-32bit-7.4-6.1.x86_64
    xorg-x11-libs-32bit-7.4-25.1.x86_64
    xorg-x11-libICE-7.4-7.1.x86_64
    xorg-x11-libXpm-32bit-7.4-6.1.x86_64
    xorg-x11-libXprintUtil-32bit-7.4-6.1.x86_64
    xorg-x11-libXau-7.4-6.1.x86_64
    xorg-x11-libfontenc-7.4-6.1.x86_64
    xorg-x11-libXp-7.4-6.1.x86_64
    xorg-x11-xauth-7.4-35.3.x86_64
    xorg-x11-libSM-32bit-7.4-7.1.x86_64
    xorg-x11-libxkbfile-32bit-7.4-6.1.x86_64
    xorg-x11-libXmu-32bit-7.4-6.1.x86_64
    xorg-x11-libXdmcp-7.4-6.1.x86_64
    xorg-x11-libxkbfile-7.4-6.1.x86_64
    xorg-x11-libXpm-7.4-6.1.x86_64
    xorg-x11-libX11-32bit-7.4-12.3.x86_64
    xorg-x11-libXext-32bit-7.4-7.1.x86_64
    xorg-x11-driver-video-7.4-87.91.1.x86_64
    xorg-x11-driver-input-7.4-39.2.1.x86_64
    linux-r7d9:/home/carr #


    lsmod | grep fglrx yields nothing

    Several questions.....is it necessary to use Xinerama for more than 2 monitors? With more than 2 monitors is compositing and other desktop effects impossible using my configuration??

    Any advice or info would be appreciated.

    Thanks for this thread.... something Im also dealing with.

    regards
    Carr

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •