Results 1 to 8 of 8

Thread: Problem with OOo/Scim: Japanese input suddenly stops working

  1. #1

    Default Problem with OOo/Scim: Japanese input suddenly stops working

    I installed openSUSE 11.2 yesterday, and with it OpenOffice 3.1.1.

    I've been typing some some things in Japanese and/or European accented characters, using Scim-Anthy / Scim-t-latn-pre as the input method, and just now, all of a sudden, the input doesn't work anymore. Instead, I get funky letters, for example in Japanese mostly something like "ccc/c+c;ccc'cc" (Hm, is this the usual gibberish you get if the program can't cope with 2-byte characters? I don't know ... )

    I assume it has something to do with Scim, because copy&pasting Japanese text into an OOo document works fine. At the same time, using Scim in any other program (like Kontact, Firefox, etc.) works fine, too, so perhaps something is messed up when Scim tries to communicate with OOo?

    Can anybody help?
    Last edited by homoludens1000; 13-Jan-2010 at 21:42. Reason: spelling mistake

  2. #2

    Default Re: Problem with OOo/Scim: Japanese input suddenly stops wor

    I can't be much help with your scim problem but I'm using ibus and I can type Japanese on OO. It's not in the official repos but I got it from M17N: Devel at Software.openSUSE.org. Maybe you can give that a try if you're not attached to scim.

  3. #3

    Default Re: Problem with OOo/Scim: Japanese input suddenly stops wor

    londy, thanks for the post!

    As a matter of fact, I just came across ibus and was wondering about it. Would you mind telling me what your experience has been so far? (Any problems with openoffice?)

    One more thing: Could you check whether there's an option for inputing Hindi (Devanagari characters)?

    Thanks a lot!

  4. #4

    Default Re: Problem with OOo/Scim: Japanese input suddenly stops wor

    One more thing, how exactly did you get IBUS running?

    I'Ve deleted all scim-related packages and installed the following ones for ibus, but don't get any input window for Japanese.

    Code:
    S | Name                  | Type    | Version            | Arch | Repository
    --+-----------------------+---------+--------------------+------+---------------------
    i | ibus                  | package | 1.2.0.20091225-4.1 | i586 | Extra_j-engel (ibus)
    i | ibus-anthy            | package | 1.1.0.20090509-3.2 | i586 | Extra_j-engel (ibus)
    i | ibus-gtk              | package | 1.2.0.20091225-4.1 | i586 | Extra_j-engel (ibus)
    i | ibus-m17n             | package | 1.1.0.20090509-1.2 | i586 | Extra_j-engel (ibus)
    i | ibus-pinyin           | package | 1.1.0.20090509-3.2 | i586 | Extra_j-engel (ibus)
    i | ibus-qt               | package | 1.2.0.20091217-5.1 | i586 | Extra_j-engel (ibus)
    i | ibus-table            | package | 1.2.0.20091113-1.1 | i586 | Extra_j-engel (ibus)
    i | ibus-table-additional | package | 1.2.0.20091113-1.1 | i586 | Extra_j-engel (ibus)
    i | libibus1              | package | 1.2.0.20091225-4.1 | i586 | Extra_j-engel (ibus)
    i | libusb-0_1-4          | package | 0.1.13-2.2         | i586 | openSUSE-11.2-Oss
    i | libusb-1_0-0          | package | 1.0.2-2.2          | i586 | openSUSE-11.2-Oss

  5. #5

    Default Re: Problem with OOo/Scim: Japanese input suddenly stops wor

    I see you added the "j-engel" repo. That was the first one I tried and had problems with it. Use the M17N: Devel one instead. All I did was:
    Code:
    zypper in ibus ibus-anthy
    Then open up ibus preferences and add Anthy as an input method.

    As a matter of fact, I just came across ibus and was wondering about it. Would you mind telling me what your experience has been so far? (Any problems with openoffice?)
    I don't type Japanese very often but for what I do ibus works perfectly. I used to use UIM and that works too but it's easier to setup ibus to behave the way I want it to. I only use Japanese in Firefox but I tried typing in OO after I read your thread and it worked fine.

    The only problem I noticed in OO was that the font-size kept changing while I typed Japanese. It kept changing from the Japanese fonts to the English fonts. For instance, let's say the Japanese font-size is 10 and English font-size is 12. If I want to type 日本語, the first 'n' would be size 12 and after typing 'i' it changes to size 10. Then 'h' changes the entire line to size 12 and the 'o' would change it back to 10. I don't know if that makes sense but the entire line keeps changes font sizes and it's quite annoying. But I think this is unrelated to ibus, though.

  6. #6

    Default Re: Problem with OOo/Scim: Japanese input suddenly stops wor

    Quote Originally Posted by londy View Post
    Use the M17N: Devel one instead.
    Could you give me the full URL, I can't find the M17N: Devel repository ...

    THanks!

  7. #7

    Default Re: Problem with OOo/Scim: Japanese input suddenly stops wor

    Here it is:

    HTML Code:
    http://download.opensuse.org/repositories/M17N:/Devel/openSUSE_11.2

  8. #8

    Default Re: Problem with OOo/Scim: Japanese input suddenly stops wor

    londy,

    I'm still can't get ibus to run on my system.

    I've opened a new thread, perhaps we can continue the discussion there (so far, there's nothing on ibus on the forum at all, so a dedicated thread might be a good idea anyway):

    How to run IBUS input method on openSUSE 11.2? - openSUSE Forums

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •