Results 1 to 7 of 7

Thread: Kdevelop 3.5 on Opensuse 11.2

  1. #1

    Unhappy Kdevelop 3.5 on Opensuse 11.2

    Hi everyone.
    I have installed opensuse 11.2 64-bit and downloaded Kdevelop4 using Yast. but kdevelop4 is buggy and I need to install a 3.5 version. So I downloaded kdebase3 and other packages and downloaded Kdevelop 3.5.3 rpm, but when I try to install it yast gives me these errors:

    kdesdk3 >= 3.4.0 is needed by kdevelop3-3.5.5-1.1.x86_64
    kdebindings3-ruby >= 3.4.0 is needed by kdevelop3-3.5.5-1.1.x86_64
    kdebindings3-python >=3.4.0 is needed by kdevelop3-3.5.5-1.1.x86_64
    libcvsservice.so.0()(64bit) is needed by kdevelop3-3.5.5-1.1.x86_64

    I can't find these packages using Yast. I even added suse11.0 repository but these packages are not there.

    Could you please help me with this? I really need to start programming...

    Thanks.

  2. #2

    Default Re: Kdevelop 3.5 on Opensuse 11.2

    hi anacreon,

    did you ever figure out the solution to this problem? i ran into the same thing!

    thanks,
    jesse

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,655
    Blog Entries
    14

    Default Re: Kdevelop 3.5 on Opensuse 11.2

    Do you realize the difference between developping KDE3 apps and KDE4 apps?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: Kdevelop 3.5 on Opensuse 11.2

    I'm not trying to create KDE 4 apps. I just use KDevelop to write C++ programs with CMake. CMake creates KDevelop 3 projects, but not KDevelop 4 projects.

    I tried to import the CMake project directly, but this just crashed KDevelop 4. So in the meantime, I'd love to just get KDevelop 3 running again.

  5. #5

    Default Re: Kdevelop 3.5 on Opensuse 11.2

    OK, I got it working.

    The build service provides a version of KDevelop 3.5. When it complained about kdebindings3-python, I accepted its offer to "change vendors" and install the python-sip package.

    Once installed, the executable is
    Code:
    /opt/kde3/bin/kdevelop
    I don't know if this has repercussions elsewhere.

  6. #6

    Default Re: Kdevelop 3.5 on Opensuse 11.2

    Hi, I wrote about my solution to the problem on this other thread

  7. #7

    Red face Re: Kdevelop 3.5 on Opensuse 11.2

    Indeed, I have found the problem. Using this method prohibits you from installing the python-kdebase4 package, which is used by a bunch of other applications, such as gmail-notifier.

    Oh well, I guess there might not be a perfect solution.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •